Jump to content

Archived

This topic is now archived and is closed to further replies.

Chip1

Graphics Problem with GTX-480 and i7-890X

Recommended Posts

I have been using a i7 930 with a GTX 480 for about a month and the results were excellent. I replaced the i7 930 with a i7 980X and the system seemed to be working very well. I did not give it a real checkout as I was designing scenery for lanai for over a month and not flying very often. I then noticed some odd artifacts in the FSX graphics when slewing. Flashes on the screen and scenery anomalies. I did some standard approaches to airports and would see the graphics problems pop up every so often. Runways lighting up white at auto-gen distances and horizontal and vertical streaks that would flash across the display for a few milliseconds. At other times there is absolutely no problem at all. I rebuilt my FSX.CFG file and checked to be sure Nhancer settings were set up properly following Nicks methods. I've run tests on the GPU and CPU with no errors showing up. FS9 seems to fly perfectly with none of the above problems.I've attached a few photos from FRAPS that show what I see. What you see in the photos are of a few milliseconds duration and obviously do not look as bad as the photos.Any ideas would be appreciated. I may go back to the i7 930 to see if that clears up the problem although the GTX 480 may be the problem

Share this post


Link to post
Share on other sites

I have this happen too, and I'm pretty sure its a issue with fiber frame limit or max texture bandwidth whatever settings, but I'm not sure. I'd love for a solution to this, too. Someone get *******!

Share this post


Link to post
Share on other sites

I'm very sorry you have a similar problem, it is very strange. I worked on the problem all day and have had some improvements with FSX.CFG modifications that many say do not work. I don't think this problem was there with the i7 930 and I don't think the i7 980X has anything to do with the problem. It may be my memory causing errors. I will keep you informed on my progress. I know there is an answer. There are very few "experts" here on Maui so I'm alone with the problem.

Share this post


Link to post
Share on other sites

I've seen that sort of behavior on other nVidia cards as the result of either overheating or an excessive GPU overclock. Are you watching your GPU temps when this happens? Is the GPU o/c'ed?RegardsBob ScottColonel, USAF (ret)ATP IMEL Gulfstream II-III-IV-VColorado Springs, CO

Share this post


Link to post
Share on other sites
I've seen that sort of behavior on other nVidia cards as the result of either overheating or an excessive GPU overclock. Are you watching your GPU temps when this happens? Is the GPU o/c'ed?RegardsBob ScottColonel, USAF (ret)ATP IMEL Gulfstream II-III-IV-VColorado Springs, CO
Hello Bob,Pardon the mistake on the i7-890X, It is a 980X as you may have guessed.Thanks much for the information. No the GPU temps when at low or high temperatures have the same problem. I'm not overclocking the CPU or GPU. I've used MSI's Kombustor graphics stability test program and can find nothing wrong at all. FS9 shows no problems even when slewing through the most dense scenery. I have run other test programs and get no errors. The photos are a bit extreme as the glitches last for around 1 or 2 milliseconds. I'm beginning to wonder of it is the CPU Memory. I'm getting ready to remove FSX as it is SP1 and SP2 with Acceleration. I will reload with the Gold Edition although I'm a bit worried nothing will change.Aloha from PHOG,Chip

Share this post


Link to post
Share on other sites

i've started getting the same problem lately. Got 8800gtx and e8600 @4.1 , suddenly started after i installed mytraffic 5.3 some months ago(but dont expect that to have anything to do with it).Was actually planning on upgrading to 980x/480gtx soon, so dont like to see this occuring on such a rig. Would also assume its heat or ram-related. What happens for me is sometimes ctd after a quick view-shift. get a display driver stopped working error-message. the white textures can be really anoying, even though the just appear for a split-second.Think maybe also bp=0 might have something to do with this.-a.

Share this post


Link to post
Share on other sites

Have the same issue on two different systems - 9650/GTX280 and 980x/GTX480 - Temps fine. Sort of a hit miss problem with me. Sometimes I'll see a little flash when I'm panning around nad then I don't see it again. Happened with or without a CPU clock or a GPU clock. Two different speed memory sets. Two completely different setups.Only common thing is the FSX setup which was identical on both systems.Never did track it down.Vic

Share this post


Link to post
Share on other sites
Have the same issue on two different systems - 9650/GTX280 and 980x/GTX480 - Temps fine. Sort of a hit miss problem with me. Sometimes I'll see a little flash when I'm panning around nad then I don't see it again. Happened with or without a CPU clock or a GPU clock. Two different speed memory sets. Two completely different setups.Only common thing is the FSX setup which was identical on both systems.Never did track it down.Vic
Hi Vic, I'm somewhat glad to hear others have a similar "problem". In my case I get a number of flashes that are repeatable at certain airports without panning. I was glad to find it repeatable at Lanai City Airport on the South Approach. I now at least can work on the system with a glitch that I know will be there every time. I hate problems that are intermittent. I prefer a good total failure! I was ready to change the GTX 480 with a replacement but since you see the same thing on other graphics cards that sounds like a mistake. I may try under clocking the 480 and see what happens. I may try the i7 930 again as I can't recall seeing the same problems when I was using that CPU. I hope I'm wrong.Chip

Share this post


Link to post
Share on other sites
i've started getting the same problem lately. Got 8800gtx and e8600 @4.1 , suddenly started after i installed mytraffic 5.3 some months ago(but dont expect that to have anything to do with it).Was actually planning on upgrading to 980x/480gtx soon, so dont like to see this occuring on such a rig. Would also assume its heat or ram-related. What happens for me is sometimes ctd after a quick view-shift. get a display driver stopped working error-message. the white textures can be really anoying, even though the just appear for a split-second.Think maybe also bp=0 might have something to do with this.-a.
Hello from PHOG tonight,I have just gone over to the latest drivers (258.96) for the GTX 4 series and love them. nHancer will not work with the new driver and hope there will be an update soon. The good news is Nick has the profiles that do the same thing as nHancer and I'm using NVIDIA Inspector and GeForce 3D Settings Profile Manager which makes setting the new drivers up very easy. Not as easy as nHancer though. I think the same problem still exists but will have to run more tests. If I find an answer before the next century I'll let you know. I'm looking around for another graphics card so I can eliminate the 480 as a cause of the glitches. I've run memory and graphics tests on everything and can find nothing wrong.Chip

Share this post


Link to post
Share on other sites

Try these tweaks to your fsx.cfg:[JOBSCHEDULER]AffinityMask=62[bufferpools]Usepools=0Poolsize=85000000Bufferpools: Should Usepools=0 still give you strange glitches, make it =1, it will then use the second value as well.At the end of the DISPLAY section, have these lines (replace existing if they are double)TEXTURE_BANDWIDTH_MULT=80UPPER_FRAMERATE_LIMIT=24TextureMaxLoad=15WideViewAspect=TrueRUNWAY_LIGHTS_SURFACE_SCALAR=0.30RUNWAY_LIGHTS_VASI_SCALAR=0.30RUNWAY_LIGHTS_APPROACH_SCALAR=0.33RUNWAY_LIGHTS_STROBE_SCALAR=0.30TEXTURE_BANDWIDTH_MULT=80 If you have FAST RAM working synchronous with the CPU, you may try 40 later, but for now, leave it as it is.WideViewAspect= True only with widescreen monitors, =FALSE with 4:3 aspect ratios.Framerate Limit should be as it is here. At least on my system :-)RUNWAY_LIGHTS are purely cosmetical. I love them when they aren't blurry.First line in [Main] should beFIBER_FRAME_TIME_FRACTION=0.05This can be raised up to 0.33 if needed, but again, leave it as it is for now. Only exception is if you fly over a lot of photoscenery - then 0.05 will give you extreme blurriesFirst lines in [GRAPHICS]STALE_BUFFER_THRESHOLD=1024HIGHMEMFIX=1SHADER_CACHE_PRIMED=1693500672TEXTURE_MAX_LOAD=1024No changing of that. Forget Texture_Max_Load at 4096, it just interferes with what is possible.Also, do NOT set LOD Radius higher than 4.5. It stresses RAM with complex planes to an extent that crashes FSX.And finally, first line in [sCENERY]MAX_ASYNC_BATCHING_JOBS=2

Share this post


Link to post
Share on other sites

Not trying to be rude here but you are giving Newbie quite a bit of misinformation. He has a GTX480 and an I7 980x cpu - your settings are flat out wrong.For the 980x the affinity mask has shown not great benefitBP = 0 disables Bufferpools so the Poolsize is ignoredTBM on the 980x should be 120Frames should be multipe of the refresh rate ( assuming an LCD monitor) so 30 or 60Fiber Frame has absolutely NO effect with SP2/AccelerationHighmemfix relates to only one problem - flashing VC panels - it can otherwise cause issuesthe rest are hit and miss and vary on each system so they are worth a try.Vic

Share this post


Link to post
Share on other sites

Sorry, vgbaron - but YOU are the one spreading misinformation. Have you TRIED my settings? I have been plagued with graphical problems for a long time, EXACTLY those described here. And your comments are flat out wrong.For the 980x the affinity mask has shown not great benefit.But we aren't talking about CPU, but GPU! And disabling the first core DOES have benefits for NVidia cards (more on that later).BP = 0 disables Bufferpools so the Poolsize is ignoredYes, certainly. This is why I wrote this as comment in my posting:Bufferpools: Should Usepools=0 still give you strange glitches, make it =1, it will then use the second value as well.So there you have it: I suggested to try it with =0, if this doesn't help with the anomalies, then make it =1 and it will use the value in the next line (which is ignored with =0). Makes sense, doesn't it?TBM on the 980x should be 120ONLY if you have photoscenery - else it's pure overkill. What the heck would you need 120 for here? Not even with GEX does 120 make sense.Frames should be multipe of the refresh rate ( assuming an LCD monitor) so 30 or 60On my system (as I wrote) it works best with 24. 30 gives me too many fluctuations over cities. And again, we are not talking about speed here, we are talking about eliminating graphic anomalies.Fiber Frame has absolutely NO effect with SP2/Acceleration*lol* - just a little suggestion: Try my settings - once time with Fiber Frame to 0 and once with Fiber Frame to 0.05 to .33. And then come here again and say it has absolutely no effect with SP2/Acc. 0 sends you to blurryland big time, 0.05 is perfect for non photo scenery, 0.33 for regions like photoreal Utah from FSDreamscapes or VFR Germany from Aerosoft.Highmemfix relates to only one problem - flashing VC panels - it can otherwise cause issuesOne more blatant misinformation. I have NEVER had flashing VC panels, but texture anomalies en masse, autogen loss and more - highmemfix in combinaton with the other settings was the cure to it. So, in my case and many others, it has solved an issue.Now to WHY Nvidia owners experiencing texture anomalies, spikes and autogen loss should disable Core 0 for FSX: Because it doesn't completely disable Core 0 :-). Fibres and a few other things are still handled on Core 0, and the other settings tune FSX to take max advantage of this.You can believe what you want, but PLEASE don't judge things you haven't experienced firsthand. And don't bring people away from trying something that is reversible if it doesn't help - here, on my system, it has ended a long period of frustration and CTD's. My suggestions make sense - they have helped a lot of people with the NVidia problem (they aren't even from me, but from a cooperation of a lot of people) and might be of help here as well. Your ignorance certainly isn't.

Share this post


Link to post
Share on other sites

ok smooth talker - anytime you want to buy a bridge, let me know - there's one born every minute.Have fun with your simming!Vic

Share this post


Link to post
Share on other sites

Thanks, vgbaron, I certainly will. And may you be happy with your attitude.Now, Chip1, I suggest you backup your fsx.cfg (if you don't know how to do it, I will certainly help), and try the settings I have posted. If they don't work, just revert to your old fsx.cfg, you will have wasted 5 minutes. If you don't try them you will have wasted a chance :-).

Share this post


Link to post
Share on other sites
http://blogs.msdn.com/b/ptaylor/archive/2007/05/11/tweak-of-the-week.aspxTry searching for a change - you won't believe me - how about the developers of FSX?I'll say it again - fiber frame time fraction is totally useless after SP1, but if YOU think it really, really works for you, by all means leave it in.That's just for one of the points I made - you can find the others if you care to.The idea of helping someone is to attempt to diagnose the problem and provide a solution - not throw out questionable solutions and hope that they fit the problem.In this case we are dealing with a self proclaimed NEWBIE, it wouldn't matter as much to an experienced computer person.Vic

Share this post


Link to post
Share on other sites

You are childish, vgbaron.It would take you five minutes to see the difference Fiber Time Fraction can make in combination with the other tweaks. Just pop in my changes, first with Fiber Time Fraction =0, then with =0.33. It will take you 5 minutes. But, nah - could change your opinion, so better not do it (better "search" than doing empiric research *g*).And THIS point of yours is as wrong as the others you made. I explained every single of my changes in the posting I made, and I explained how they work together. You didn't bring a single factual argument that counters what those people that build FSX machines for 12.000 bucks found out (you wouldn't believe me either that 1666MHz RAM is a waste of money even with the fastest CPU's nowadays and doesn't bring you a single frame more). Do you really think I would have applied and KEPT these tweaks if they wouldn't have solved my problem with my Nvidia card once and for all? They did - and my problems looked EXACTLY like the screenshots posted here, even worse in some cases. I do not suggest that they solve all problems with FSX on all computers (they are completely useless for ATI's, for example, because of their different architecture), but for NVidias, they are proven to work on many systems. Period.What's so ridiculous is that just for giving yourself thefeeling to be the "more clever guy", you try to hinder someone to try out something that has been proven to work, is easily reversible if it doesn't in his situation and has no ill effects whatsoever. It's all about your ego, right?Ok, enough time wasted, no more postings from me here (yes, you may have the "last word", if this helps you) - I made my suggestions, the rest is up to the original poster, not to you or me.

Share this post


Link to post
Share on other sites

Darem - pardon me but are you really that stupid? I'm not asking you to take MY word for it - the link I posted is from the DEVELOPER - the guy who wrote the code - Adam Szofran - he says and I quote - "Please emphasize the pointlessness of tweaking this value on multi-core machines."It DOES NOTHING on multicore systems, nada, zip, nothing. The fact that you see someting in your "empirical" research means that something else is happening.I guess you wouldn't believe it if Bill Gates himself told you it doesn't work.Enough of this - let the OP do what he wishes - at least what you posted can't do any harm. Hopefully you'll continue that practice as there are "some" tweaks that when applied in the wrong manner "can" cause harm. But you probably don't care - if it works for you it must be gospel.I can see that you not only have missed my point entirely but you can't even accept a documented fact from the developer.Whatever - and finally - I guarantee that I've tried and researched all those tweaks long before you even knew about them - some are nothing but placebos - they used to work but were disabled later on by Aces.Go ahead - have the last word or not as you choose.

Share this post


Link to post
Share on other sites
Try these tweaks to your fsx.cfg:[JOBSCHEDULER]AffinityMask=62[bufferpools]Usepools=0Poolsize=85000000Bufferpools: Should Usepools=0 still give you strange glitches, make it =1, it will then use the second value as well.At the end of the DISPLAY section, have these lines (replace existing if they are double)TEXTURE_BANDWIDTH_MULT=80UPPER_FRAMERATE_LIMIT=24TextureMaxLoad=15WideViewAspect=TrueRUNWAY_LIGHTS_SURFACE_SCALAR=0.30RUNWAY_LIGHTS_VASI_SCALAR=0.30RUNWAY_LIGHTS_APPROACH_SCALAR=0.33RUNWAY_LIGHTS_STROBE_SCALAR=0.30TEXTURE_BANDWIDTH_MULT=80 If you have FAST RAM working synchronous with the CPU, you may try 40 later, but for now, leave it as it is.WideViewAspect= True only with widescreen monitors, =FALSE with 4:3 aspect ratios.Framerate Limit should be as it is here. At least on my system :-)RUNWAY_LIGHTS are purely cosmetical. I love them when they aren't blurry.First line in [Main] should beFIBER_FRAME_TIME_FRACTION=0.05This can be raised up to 0.33 if needed, but again, leave it as it is for now. Only exception is if you fly over a lot of photoscenery - then 0.05 will give you extreme blurriesFirst lines in [GRAPHICS]STALE_BUFFER_THRESHOLD=1024HIGHMEMFIX=1SHADER_CACHE_PRIMED=1693500672TEXTURE_MAX_LOAD=1024No changing of that. Forget Texture_Max_Load at 4096, it just interferes with what is possible.Also, do NOT set LOD Radius higher than 4.5. It stresses RAM with complex planes to an extent that crashes FSX.And finally, first line in [sCENERY]MAX_ASYNC_BATCHING_JOBS=2
Hello Darem,Thanks for all of the information. Hey, I have nothing to loose by trying anything after bashing my head against a wall playing with memory and everything else. I think it has something to do with the graphics memory when it is first being loaded. The video you see is created by loading a saved flight on final approach and that is when the problem is the most obvious. If I start up at any airport and just hit F12 and slew to a high altitude and back and take off from the airport no "flashes" are visible at all. The other method is to slew around the area, at first there are the "flashes" and then they stop and do not return and flying is perfect. At least it is a repeatable fix and it must mean the loading of memory or something else that is not so obvious. I have been using Microsoft Flight Simulator since it was first created. I had a Radio Shack TRS_80 with a 1.78 MHz clock and 16 KB of RAM. Flight Simulator was very slow. I have to admit FSX is amazing but getting it working perfectly really is a big job. I'm almost there.I have tried some of the FSX.CFG fixes above over the past month but not every one mentioned. It can't hurt to experiment. I'll back up the CFG file and play around. It would be nice not to have to slew into space and back before using FSX. There is no problem at all on FS9 or any other program. All graphics and memory tests are positive. I also have the latest graphics drivers which helped slightly. I've used Nicks profiles and they work well.This is the youtube video I mentioned, I forgot that I put it on another forum and not here.http://www.youtube.com/watch?v=7mVzFlceW_IThanks to everyone for all of your help.Aloha,Chip

Share this post


Link to post
Share on other sites

Yeah, I know that too well :-) - The flashes are textures not loaded/displayed fast enough. This happens when FSX switches to higher detailed textures. Your hickups are very short, I have seen much longer ones on my system. They are annoying. I wish you good luck eliminating those. But it seems to me that your setup is 99% close to NOT displaying them :-).Please let us know the outcome of this. I am very interested in your results.

Share this post


Link to post
Share on other sites
Yeah, I know that too well :-) - The flashes are textures not loaded/displayed fast enough. This happens when FSX switches to higher detailed textures. Your hickups are very short, I have seen much longer ones on my system. They are annoying. I wish you good luck eliminating those. But it seems to me that your setup is 99% close to NOT displaying them :-).Please let us know the outcome of this. I am very interested in your results.
Last I heard is that those flashes were from too high of a memory OC.  They sure look familiar.  Graphics ram corruption.jja

Share this post


Link to post
Share on other sites
Guest morpheous

Darem,I just wanted to say thank you for your post, I updated my .cfg file with the tweaks you suggested and my system has never run better, stays locked at around 23-24 fps and smooth with minimal flashes, I don't know exactly how it all works but I don't care, it works!I do find the runway lights a little on the small size though, if I wanted to make them lets say 50% larger what values would I change?thanksJim

Yeah, I know that too well :-) - The flashes are textures not loaded/displayed fast enough. This happens when FSX switches to higher detailed textures. Your hickups are very short, I have seen much longer ones on my system. They are annoying. I wish you good luck eliminating those. But it seems to me that your setup is 99% close to NOT displaying them :-).Please let us know the outcome of this. I am very interested in your results.

Share this post


Link to post
Share on other sites
Darem,I just wanted to say thank you for your post, I updated my .cfg file with the tweaks you suggested and my system has never run better, stays locked at around 23-24 fps and smooth with minimal flashes, I don't know exactly how it all works but I don't care, it works!I do find the runway lights a little on the small size though, if I wanted to make them lets say 50% larger what values would I change?thanksJim
These:RUNWAY_LIGHTS_SURFACE_SCALAR=0.30RUNWAY_LIGHTS_VASI_SCALAR=0.30RUNWAY_LIGHTS_APPROACH_SCALAR=0.33RUNWAY_LIGHTS_STROBE_SCALAR=0.30Double the values to 0.60 and 0.66 - that should do the trick.I am happy that the settings were beneficial to you. Thanks for the feedback.

Share this post


Link to post
Share on other sites

×
×
  • Create New...