Jump to content

Archived

This topic is now archived and is closed to further replies.

JoTayhen

Perplexing EZdok V1.17 Issue

Recommended Posts

Hi fellas,This weekend I purchased EZdok V1.15.1, installed it and found it "played" well with my other add-ons including TrackIR5. I was careful to follow Marniftarr's instructions regarding configuring EZdok, re-naming the two TrackIR5 files, disabling "true view" in TrackIR5 and enabling the XYZ axis control in EZdok. All went very well and I was happy.After the successful installation of EZdok V1.15.1, I went ahead and upgraded to V1.17. I noticed in the upgrade instructions that those who run every version of FSX except the "English version with acceleration" would be asked to follow some special instructions which would enable EZdok V1.17 to locate a memory location involving world cameras. My version of FSX is the English version of FSX but without acceleration and so I was asked by the installation pgm to follow those specific instructions which I did and the newer version announced it was successful in finding that necessary memory location. I completed the necessary EZdok configuration.I fired up FSX again expecting to enjoy another flight with both TrackIR5 and EZCA and found my TrackIR did not work. Specifically, my routine is to load FSX, select a flight, click on the "fly now" button and be placed at my desired airport location in the a/c of my choice. Once in the cockpit, I load TrackIR5. This time it loaded successfully, I was able to confirm it was tracking my head movements at that time however, when it minimized to the taskbar it no longer tracked my head movements.I uninstalled the new version (v1.17), re-installed the older version (v1.15.1) and all worked perfectly again. I re-downloaded the update, re-installed the update and found I could not, again, use TrackIR5.I believe I am using the latest version of TrackIR5 (V5.1.0.300 build 9945).I have posted this situation on the EZdok forum and Marniftarr has kindly offered his assistance together with some others who have made some suggestions but my problem persists.I am hoping someone else has run into this problem with the new version and will send some guidance along.I also hope that I will be able to upgrade to the new (as yet unreleased) version 2 of EZCA when it becomes available.Thanks for your time and patience reading all of this!


John

Share this post


Link to post
Share on other sites

Check to make sure that under the titles tab in the TrackIR software that the profile that is selected for EZCA is correctly setup. Also check in the TrackIR setup options of EZCA that it is set up correctly as well.Thats all I can think of... strange problem. It seems like it has to be some kind of profile problem.


Philip Manhart  :American Flag:
 

13.jpg

- "Wise men talk because they have something to say; fools, because they have to say something." ~ Plato

Share this post


Link to post
Share on other sites
Guest

First of all: try to figure out if you really need version 1.17... If 1.15 works, why not stick with it?Secondly: I have the English version without Acceleration but WITH SP1 and SP2... I simply installed that 1.17 version and it worked. So you could try to install 1.17 and skip those specific steps and instructions...?

Share this post


Link to post
Share on other sites

Hi Pmanhart - I have checked the TrackIR options in EZCA and they are set up correctly. I will check the TrackIR profile closely, however. I assumed the profile being used by version 1.15.1 (which works well) was also the profile being used by version 1.17. That may very well not be the case and I just didn't pay enough attention to that detail.Hi J van E - Your point about simply using version 1.15.1 and not worrying about updating to version 1.17 is a good one and, in fact, is the path I've taken to date. My concern is I have read that the new version 1.17 employs a new mechanism involving the computer's memory and I am concerned that the upcoming version 2 will also employ that same mechanism. If that is somehow my problem then I may be precluded from upgrading to the new version 2 and therefore not be able to take advantage of the new features that version 2 promises.I also have the English version together with SP1 and SP2. When you installed version 1.17 did your upgrade installation require you to use the "memory wizard" to find the memory address related to "world cameras" ? If it did not then the upgrade miss-identified my version of FSX for some reason and maybe that is causing this problem. Finally, I will again try to install the upgrade and I will skip those instructions as you suggest and see what happens.Thank you both for your suggestions, comments and interest in this thread.RespectfullyJohn


John

Share this post


Link to post
Share on other sites

Do you have TIR enabled in the Studio i.e. when you click on an individually named camera view in the list to edit it, is the button TIR (far right) as seen in the image below enabled (lit)?tir.jpgAlso is TrackIR indeed connected as shown by the image below.connected.jpg


Cheers, Andy.

Share this post


Link to post
Share on other sites

Make sure that when you did the re-install of EZdok V1.15.1, that you did so from the "EZdokCamera.exe" Flight1 wrapper.I had a similar problem where I was doing a reinstall after system restore and was just running the unwrapped "EZCA-Setup-1.15.exe" and then applying the 1.17 patch and it would install ok but would never actually work in allowing my TIR to control the FSX view.After much pulling of hair I eventually decided to start from scratch using the "EZdokCamera.exe" Flight1 wrapper and redoing the license check and everything worked fine in the end... I think EZDok program has some sort of anti-piracy feature that makes it not work unless it was installed from the original Flight1 wrapper.I had posted on the Flight1 forum that they should add that to the FAQ but haven't checked recently to see.


--John near KPAE

Share this post


Link to post
Share on other sites

Hi Andydigital - I did indeed check to see if TrackIR was connected and it is in both versions. You first point - that being whether or not the "TIR" button is enabled is an excellent one! I confess I never noticed that button at all. When I originally installed EZdok (version 1.15.1) this weekend, I tried to follow the instructions carefully and to make sure I did all the things necessary to allow TrackIR to work in conjunction with EZCA. When I completed the installation of EZdok and fired up FSX and found both EZCA and TrackIR worked well together I was thrilled. I have created no cameras and I am simply using the basic EZCA program. I will look carefully at those buttons when I get home tonight. That might be the answer, my friend!Thanks very much!John


John

Share this post


Link to post
Share on other sites

Hi Kludger - Thanks for the good advice. I am, in fact, using the flight1 wrapper each time I re-install version 1.15.1 and each re-installation works perfectly. Your advice is sound and brings up another potential issue that I have attempted to resolve with flight1. I have written to inform them of my actions in this regard so they do not become suspicious with the number of re-installations that are taking place on my computer. Hopefully they will understand and allow me to continue to work to try to resolve my dilemma.Thank you also for your kind attention and good suggestion!Respectfully,John


John

Share this post


Link to post
Share on other sites

Hi Andydigital,My friend - you were spot on. Thank you so very much for your suggestion that I check whether or not the "TIR" activation button was lit. It was not. I activated TrackIR5 by pushing the button and the problem was solved. In my opinion, nothing beats being able to describe your dilemma and receive the support of your fellow sim pilots.Thanks again!John


John

Share this post


Link to post
Share on other sites

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    42%
    $10,690.00 of $25,000.00 Donate Now
×
×
  • Create New...