Jump to content

Archived

This topic is now archived and is closed to further replies.

Dave Potter

FSX: 8minute hang when using the NGX

Recommended Posts

Team,

 

Got a really annoying problem which is spoiling my enjoyment of this fantastic aircraft.

 

When flying (normally only in the cruise although does occasionally happen at other points in the flight) FSx hangs for exactly 8 minutes, with the sound still playing and then continues as if nothings happened. No fatal error, no CTD, no blue screen of death, just hangs. This can happen once, or can happen multiple times, there appears to be no pattern with this (which to me makes no sense).

 

I have a moderate system (please see below):

 

Windows 7 64bit

AMD Phenom II 3.40ghz processor

8gb RAM

640gb HDD

ATI Radeon HD 5800 graphics card

 

I have tried everything to stop this problem including:

 

UIAutomationcore.dll replacement

External frame rate limiter

Turn off Anti virus

Lower settings inside FSx

The Venetubo fsx.cfg editor

I have also checked that autosave is not selected in FSuipc.

 

What I run when FSx is open:

 

FSx (obviously)

Activesky X

Squawkbox 4

K Acars (for Norwegian virtual)

 

Inside FSx I have:

 

NGX

Ultimate Terrain Europe

REX (no weather)

Addon scenery

 

If someone can help me fix this problem I will owe them a massive drink because this problem is beginning to fraustrate me so much that I'm considering going on sabbatical from FSx.

 

Many thanks in advance.

Share this post


Link to post
Share on other sites

I hate to be the one to suggest it, but one possible solution may be to reinstall the NGX, unless someone else has experienced this problem before and has other suggestions from their own experiences.

 

Have you updated your drivers for GFx and sound (is this onboard too btw?)

Share this post


Link to post
Share on other sites

A long shot but if you have the registered version of FSUIPC try turning off Autosave, I don't think its related though as freezes with Autosave are usually as a result of the anti virus software scanning all the files that are saved during the autosave and its usually seconds long rather than minutes long and you also said you disabled the AV software anyway. Worth a bash though if you do have it.

Share this post


Link to post
Share on other sites

Good luck with this. If you do research you will find this has been a huge problem for many. Had the same issue and tried every suggestion there was. I actually reformated my hard drive at one point and slowly added everything back and after a good week or two "BLAM" does it again. It did not matter if I was overclocked or not, running addons or not , anti-virus, no FSUPIC, registered , not registered, default sound card, Sound Blaster cards, etc, etc. I gave up the hobby (after investing thousands of $) for about 4 months I was so frustrated. Decided to look at everything again and my latest fix was to use NVIDIA control panel to limit my FPS to 30fps and set NGX to unlimited. No issues the past few months but I am not dumb enough to believe this was totally the issue. I am always waiting for it to return on a long flight but knock on wood for now. I am sure it has something to do with FSX and Win7 but have heard rare similar stories from those using Vista. I don't believe anyone really knows why. Sorry for the Rant. But I do feel your pain and wish you luck.

Share this post


Link to post
Share on other sites

I had a similar problem in the sense that FSX (and in fact Windows) would freeze after a random period of time. Turned out my computer was overheating due to the high temperatures outside in the middle of the summer. Pointing a fan towards my MacBook Pro have solved the problem, so far... (this is not a problem as I have my MacBook hooked up to an external monitor)

 

Let us know how you get along,

 

Wiebe

Share this post


Link to post
Share on other sites

Sheesh, I feel for you matey. I used to get this often on my previous rig, but that was Win XP 32 bit. Since moving to Win 7 64bit, I have never had a problem. I think perhaps Andy may be on the right track. It could be associated with your AV updating, or more likely Windows updating. Why don't you try disabling both. IMO it does sound like there is some external influence at play, rather than FSX itself.

Share this post


Link to post
Share on other sites

Jason,

 

Yes I updated my graphics card but not the sound card. In fairness, I have no idea what my soundcard is.

 

Autosave feature is definitely turned off in FSuipc. Tried another test flight today with the FS control panel that comes with FSinn uninstalled as that seemed to be hogging resource, yet another stutter about 10 minutes into the cruise. This problem only exists with the NGx.

 

Thanks for any help anyone can offer.

Share this post


Link to post
Share on other sites

I think I've found the fix and it was so simple! Uninstalled the PMDG completely, reinstalled as Administrator, just did a flight, no hang. I've only done one test flight, but no hang is a very good sign. I'll let you know how I get on over the coming few days flights.

 

Thanks

Share this post


Link to post
Share on other sites

Dave

 

Good to hear you have it sorted - and generally it always turns out to be the simple things in life.

 

Never forget spending ages on the phone trying to help someone to get their printer working. Needless to say I neglected to appreciate how foolish some people can be with technology. The problem - they had only plugged one end of the USB in! D'oh.

 

Lesson learnt - always start with the very basics!

Share this post


Link to post
Share on other sites

Just a reminder, it is always good to read the documentation. The introduction clearly states that the NGX needs to be installed as Administrator. There are many other important configuration tips in the document as well. :smile:

Share this post


Link to post
Share on other sites

George make a valid point.

 

In fairness thought, it is easy to understand how people can oversee things like that in their enthusiasm to get onboard this beauty and fly off into the distance. :wink: Not to mention we are all human, makes mistakes and try to take as many shortcuts as we possibly can in life! :biggrin:

Share this post


Link to post
Share on other sites

×
×
  • Create New...