Jump to content

Archived

This topic is now archived and is closed to further replies.

jfri

The most annoying glitch

Recommended Posts

After installing this DX10 patch and setup NI and FSX.cfg according to recommendations my result are

Good

Better performance

Bad

See glowing dots sometimes

Still some shimmering

Water textures seem 'moving' at some distance

Worst

Even panels can exhibit glitches like broken lines shimmering. This is the case in PMDG 737NGX A2A Cub Milwiz Baron 55. See the pic below

As you can see the lines in the GPS are broken and what you can't see is the line pattern is moving (the same effect can sometimes be seen on runways)

 

 

 

I hope there is a solution at least to the worst problem

Share this post


Link to post

Did you tick anti aliasing to on in FSX?

You need it now for override to work in DX10

Share this post


Link to post

After installing this DX10 patch and setup NI and FSX.cfg according to recommendations my result are

Good

Better performance

Bad

See glowing dots sometimes

Still some shimmering

Water textures seem 'moving' at some distance

Worst

Even panels can exhibit glitches like broken lines shimmering. This is the case in PMDG 737NGX A2A Cub Milwiz Baron 55. See the pic below

As you can see the lines in the GPS are broken and what you can't see is the line pattern is moving (the same effect can sometimes be seen on runways)

 

 

 

I hope there is a solution at least to the worst problem

 

I don't think your main problem is Dx10, rather it's your settings.

In particular, I suspect these two

 

MultiSamplesPerPixel=4

MultiSampleQuality=8

 

You can help your self by zooming in your VC view, mine is at .70 and looks like this

BeechGPS.jpg

 

The lines in the GPS do flicker slightly but they did in Dx9 if I zoomed out as far as your screenshot.

To address your other points,

I don't see glowing dots unless they are supposed to be there, so I can't help.

I still saw some shimmering occasionally, in the extreme distance, in Dx9 this can often be cured by reducing

the visibility a little.

The only water movement I see is meant to be there, as the waves now seem to follow the wind direction

but I used REX textures optimised for Dx10.

Share this post


Link to post

 

but I used REX textures optimised for Dx10.

 

Where can I find these textures or whats the name of them in REX. I've got DX10 tuned nicely and now looking to find the best water/wave files for DX10.

Share this post


Link to post

Did you tick anti aliasing to on in FSX?

 

Yes

 

MultiSamplesPerPixel=4

MultiSampleQuality=8

 

You can help your self by zooming in your VC view, mine is at .70 and looks like this

 

Yes I have those two lines in my fsx.cfg according to the instructions. Or rather I had both to 4 because of performance suggestion. After changing the second to 8 the lines were still broken but didn't move. And yes zooming seem to affect this and I can remove it by zooming in enough. But a more zoomed out view seem the most appropriate in this case.

Share this post


Link to post

The appearance of water is highly subjective.

However, these are the settings I use before selecting any textures.

 

REX%20settings.jpg

 

and this

 

Waves.jpg

 

Which results in this, movement in this case, left to right.

 

Calm

Calm.jpg

 

Moderate

Moderate.jpg

 

Stormy

Stormy.jpg

Share this post


Link to post

Huge thanks! (this is just extra letters to allow my post to post since what I wanted to say wasnt enough for the forum. Now wherees that sigh emicon)

Share this post


Link to post

Yes I have those two lines in my fsx.cfg according to the instructions. Or rather I had both to 4 because of performance suggestion. After changing the second to 8 the lines were still broken but didn't move. And yes zooming seem to affect this and I can remove it by zooming in enough. But a more zoomed out view seem the most appropriate in this case.

 

I have managed, by accident, to reproduce the effect you saw and the problem seems to lie in the pre-defined Microsoft FSX profile in Nvidia Inspector.

There are several "unknown" parameters at the very bottom of the list which cannot be changed.

 

I first deleted the FSX pre-set and then created a new one by editing the global settings, saving them as a preset "FSX" and then associating this profile with fsx.exe.

The broken lines have now gone away again.

Share this post


Link to post

 

I have managed, by accident, to reproduce the effect you saw and the problem seems to lie in the pre-defined Microsoft FSX profile in Nvidia Inspector.
There are several "unknown" parameters at the very bottom of the list which cannot be changed.

I first deleted the FSX pre-set and then created a new one by editing the global settings, saving them as a preset "FSX" and then associating this profile with fsx.exe.
The broken lines have now gone away again

 

Just reviewing some earlier threads and came across your post. Could you post a screenshot of your NI settings - in particular the "unknown' parameter settings you're using now (though I'd like to see the whole thing for completeness).

 

Cheers, Brian

Share this post


Link to post

I am afraid I don't have a set of definitive settings.

Having read the very interesting "AA with Dx10" thread,

at the moment, I am using these

 

NIsettings1_zps6cff8dc6.jpg

 

which give me this

 

NIsettings2_zps93ea842b.jpg

 

If you select your Global profile and scroll to the bottom, you will see numerous entries in the "Other" section.

If you then scroll to the bottom of the FSX profile, you will see additional entries.

I do not know what they mean but I cannot remove the jagged lines referred to by the OP with these entries

included.

 

Also, with these NI settings, I can use a default Fsx.cfg file with only the HIGHMEMFIX=1 entry added.

 

Regards,

Nick

Share this post


Link to post

 

Yes

 

 

 

Yes I have those two lines in my fsx.cfg according to the instructions. Or rather I had both to 4 because of performance suggestion. After changing the second to 8 the lines were still broken but didn't move. And yes zooming seem to affect this and I can remove it by zooming in enough. But a more zoomed out view seem the most appropriate in this case.

 

If you didnt before, set both to 8 :

 

in fsx.cfg:

MultiSamplesPerPixel=8

MultiSampleQuality=8

in NI:

Override any aplication setting

8*Sparse Grid Supersampling

in fsx:

Antialiasing on

Share this post


Link to post
×
×
  • Create New...