Jump to content

Archived

This topic is now archived and is closed to further replies.

mikef_adi

Upgrading motherboard and CPU to improve FSX performance now results in FSX not loading due to invalid hardware or driver. Please help

Recommended Posts

I have been playing FSX for some years now and recently included the additional PMDG 737 NGX. This required downloading SP2 from the Microsoft Website which was problem free and all was working. However, after about half an hour the game froze saying that it had run out of memory. Despite numerous attempts at tweeking this and that the same error always came back to haunt me. So I decided it was about time for a system overhaul so I upgraded motherboard, CPU and RAM. My system is now as follows:

 

Windows 7 Professional Home Edition 32 bit (yes I know FSX prob works better on 64 bit but it'll do for now!!!)

Intel Core i3-3220 3.30 GHz x 4

8 Gbyte RAM

ATI Radeon HD 5450 1Gb

 

Every time I try and start FSX it now throws up this message:

 

"This graphics card does not meet minimum requirements for shader support. This product requires a geForce3/Radeon8500 class or better graphics card. Flight Simulator will now exit".

 

Er, hello! FSX worked perfectly well (up to a point) on my old set up and the graphics card spec says that it supports up to Shader 5.0 and DirectX 11.0 support. I am no tech guru but if someone points me in the right direction I can normally muddle my way around things, but right now, I'm pulling my hair out. It kind of defeats the object or upgrading in the first place. Has anyone experienced this before, and more importantly, has anyone found a way around this?

 

I would be eternally grateful for any help and guidance anyone can give

Share this post


Link to post
Share on other sites

Did you reinstall Windows and FSX after your hardware upgrade?

You should do this every time you change your motherboard.

If not do yourself a favour and install W7 x64 then install your drivers (motherboard chipset, sound and ATI video), then the latest DirectX package from MS. Finally install FSX.

Share this post


Link to post
Share on other sites

You do not need to install windows again with any hardware changes anymore. the only reason you should install windows is to get a x64 version. Did you delete your fsx.cfg file and let it rebuild? did you uninstall your old video card drivers then install the new one?

Share this post


Link to post
Share on other sites

 

You do not need to install windows again with any hardware changes anymore. the only reason you should install windows is to get a x64 version. Did you delete your fsx.cfg file and let it rebuild? did you uninstall your old video card drivers then install the new one?

 

I actually deleted FSX completely, then added SP2 and then the PMDG 737 NGX file. Still returned the same error message. The only thing I haven't done is delete the drivers for the video card. I'll try this next but I'm not hopefully!

 

Sorry, should have also said reinstalled FSX THEN SP2 etc

Share this post


Link to post
Share on other sites

I actually deleted FSX completely, then added SP2 and then the PMDG 737 NGX file. Still returned the same error message. The only thing I haven't done is delete the drivers for the video card. I'll try this next but I'm not hopefully!

 

Sorry, should have also said reinstalled FSX THEN SP2 etc

update.....deleted video card drivers and re-installed on next boot up, that didn't work. So, in response to your suggestion to delete the fsx.cfg file and let it rebuild, this is going to sound really strange, but i've been through the program files with a fine tooth comb and I can't find that file anywhere. There are plenty of other files with the .cfg extension but not that one. So the first question is, "where will I find it?" and the second is, "how do I let it rebuild once i've found it and deleted it?" Is it a simply question of re-inserting the program disc and letting that do it or how does that work?

Share this post


Link to post
Share on other sites

The fsx.cfg is hidden.  You have to go into Windows Explorer and change settings to view your hidden files - http://windows.microsoft.com/en-us/windows-vista/show-hidden-files (for Vista but will work for Windows 7 too).

 

Once files are unhidden, go to C:\Users\(Your User Name)\AppData\Roaming\Microsoft\FSX.

 

Hope this helps.

 

Best regards,

Jim


Jim Young | AVSIM Online! - Simming's Premier Resource!

Member, AVSIM Board of Directors - Serving AVSIM since 2001

Submit News to AVSIM
Important other links: Basic FSX Configuration Guide | AVSIM CTD Guide | AVSIM Prepar3D Guide | Help with AVSIM Site | Signature Rules | Screen Shot Rule | AVSIM Terms of Service (ToS)

I7 8086K  5.0GHz | GTX 1080 TI OC Edition | Dell 34" and 24" Monitors | ASUS Maximus X Hero MB Z370 | Samsung M.2 NVMe 500GB and 1TB | Samsung SSD 500GB x2 | Toshiba HDD 1TB | WDC HDD 1TB | Corsair H115i Pro | 16GB DDR4 3600C17 | Windows 10 

 

Share this post


Link to post
Share on other sites

The fsx.cfg is hidden.  You have to go into Windows Explorer and change settings to view your hidden files - http://windows.microsoft.com/en-us/windows-vista/show-hidden-files (for Vista but will work for Windows 7 too).

 

Once files are unhidden, go to C:\Users\(Your User Name)\AppData\Roaming\Microsoft\FSX.

 

Hope this helps.

 

Best regards,

Jim

 

Found it thanks.

 

Unfortunately, still no joy. Same error preventing FSX to load

Share this post


Link to post
Share on other sites

I'm cracking my brain to help you solve this problem because i've seen it my self a year a go. That was without having my system changed [hapend just like that!] Your system is far superior to my second machine that has a copy running of FSX on Vista 64b with an  ATI Radeon HD 3850 plus an older quadcore.

What you can try is: run FSX from KIOSK mode [the exe icon is in the main FSX folder] from there save the flight and use as startup flight [if it starts of course]

2 You could add the following line to the FSX.cfg:

[GRAPHICS]
HIGHMEMFIX=1
ALLOW SHADER_20=1
ALLOW SHADER_30=0

Test it.

If not then: ALLOW SHADER_30=1

3 Remove any startup situation:

SITUATION=C:\Users\"your name"\Documents\Flight Simulator X Files\"your flight name"

[it will probably not be there because you can't get in]

If you can get into FSX it self, try the DX10 preview mode and restart.

If you can't get in to put it in DX10 mode change : D3D10=0

Into: D3D10=1
I do agree with one of the others that there might be a connection with Windows.
If you didn't change Windows after updating your hardware there might be a problem there.

Try uninstalling the card an have Windows "find" it.

Hope any of this works for you.

happy landings

Joost


 


any thing that moves, moves me

Share this post


Link to post
Share on other sites

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    18%
    $4,710.00 of $25,000.00 Donate Now
×
×
  • Create New...