Jump to content

Archived

This topic is now archived and is closed to further replies.

BigRick

Soft mute and VoxATC, also VC clickspot

Recommended Posts

  Aloha.  I've been toying around with VoxATC here lately.  I've set up the soft mute key as instructed in the FS2C docs.  My understanding is that it will display an "M" when it's soft muted and a "M+" on a hard mute.  If that is right it's not showing the "M" but IS showing the "M+" if I choose hard mute.  Any idea on that one?

 

   Also, the VC clickspot (the standby HSI) doesn't seem to work.  I checked the panel.cfg file and it shows the FS2C gauge under the Third-party window but clicking it doesn't work.  Here's the entry in the config:

 

//////////////////////////////////////////////////////
// VC SECTION 36
// Third Party Addon
///////////////////////////////////////////////////////

[VCockpit36]
size_mm=8,8
pixel_size=8,8
texture=$ThirdParty
background_color=0,0,0
gauge00=FS2Crew2010\Versions\PMDG737NGX\Gauges\FS2CrewNGXVoice!FS2Crew_Icon, 0,0,8,8
 

 

   Any ideas on that on too?  Thanx!

 

-Rick

Share this post


Link to post
Share on other sites

Hi R,

 

Have you set up Soft Mute properly?

 

Soft Mute

 

 

  • Used when you only want to employ Mute temporarily, such as when communicating with on-line ATC.
  • Works on a "Push-to-Hold" basis.
  • If using on-line ATC, you would assign 'Soft Mute' to the same key used for your ATC 'Push-to-Talk (PTT) switch'.
  • An "M" symbol will appear in the left hand side of the FS2Crew Main Panel display area when operating.
  • By default, the LEFT or RIGHT CONTROL key acts as the SOFT MUTE KEY.
  • To create a Soft Mute key assignment in addition to the default LEFT and RIGHT CONTROL KEY, create a joystick or keyboard button assignment for 'PROPELLER SYNC (ON/OFF)' in the FSX 'SETTINGS - CONTROLS' menu.

 mute1.jpg 

 

 

 

 

For the VC,

 

You sure you're clicking this spot?

 

To open and close the FS2Crew Main Panel in either the 2D or Virtual (VC) cockpit, left click in the center of the Standby Instrument Panel section as shown below.



 isfd1.jpg

 isfd2.jpg

 

 

 

 

 

Failing that, use the backup system:

 

 

Special Tip:

You can also assign a Keyboard or Joystick button to open and close the Main Panel.
 

  • To create your "Toggle Main Panel" assignment, create a joystick or keyboard button assignment for 'AUTOFEATHER (ARM/OFF)' in the FSX 'SETTINGS - CONTROLS' menu
  • You can select any Joystick or Keyboard assignment (or both).


IMPORTANT:  Your PMDG 737 NGX cannot use the same key assignment for any PMDG 737 NGX Key Command function, or the Main Button will not work!  

So, for example, if you use "C" as your keyboard assignment for the Main Button, you cannot use "C" for any PMDG 737 NGX KEY ASSIGNMENTS.


 

 

 

autofeather2.jpg

Share this post


Link to post
Share on other sites

Ya, like I said I read the docs and set it up correctly.  I'll try one of my planes that doesn't have the standby gauge in there and see if it works with just the blank area.  I'll let you know.

 

-Rick

Share this post


Link to post
Share on other sites

It should also work in the Blank area, too.

Share this post


Link to post
Share on other sites

Ya, like I said I read the docs and set it up correctly.  I'll try one of my planes that doesn't have the standby gauge in there and see if it works with just the blank area.  I'll let you know.

 

-Rick

I have exact same issue here. I can get the FS2Crew panel up at first in 2d panel by clicking the gauge spot, but as soon as I -or the NGX itself (My NGX seems to auto switch from 2d panel to VC after a couple of seconds) to VC mode, then its gone and cannot be reopend. I am also trying VoXATC in trial mode now, so maybe they interfere.

Share this post


Link to post
Share on other sites

Maybe Vox ATC did something to the panel cfg.

 

At any rate, the easiest way to open the Panel is to use this assignment:

 

autofeather2.jpg

Share this post


Link to post
Share on other sites

Actually the thought that VoxATC did something to the panel came to me as well so I decided to look.  Here's all it added:

 

////<VoxATC
Window27=VoxATC
Window28=VoxATC Recent Comms
////>VoxATC

 

////<VoxATC
[Window27]
visible=1
size_mm=400,200
pixel_size = 400, 200
position=4
background_color=0,0,0
ident=14077
zorder=5
alpha_blend=0.65
gauge00=VAGauge!VoxATCPrompt,0,0
////>VoxATC


////<VoxATC
[Window28]
visible=0
size_mm=400,600
pixel_size = 400, 600
position=5
background_color=255,255,255
ident=14078
zorder=5
gauge00=VAInfo!VoxATCInfo,0,0,400,600
////>VoxATC
 

 

  I did notice that the panel entries (as far as actual location) was out of order in the cfg file.  27 and 28 was before all the NGX windows (numbered 21 thru 26). Not sure if that matters.   I'm going to move them and test it out again.

 

-Rick

Share this post


Link to post
Share on other sites

I use FS2Crew and VoxATC and the only problem I have is that I cannot use the click spot in the Virtual cockpit.

What I do is to press Shift+1 to see the 2-d cockpit, then click on the hotspot there and press Shift+1 again to hide it. I always have the Fs2Crew UI opened (by clicking the LK button).

 

I am using DEL as the key to mute FS2Crew and open the VoxAtc "Mic". If you use a mouse button, then be sure to have repeat on in the settings for the button, otherwise the mute will turn on, then off at once; having repeat on keeps mute on as long as you press the button.

 

Apart from this little startup glitch everything works fine.

 

Helge

Share this post


Link to post
Share on other sites

Must be a VoxATC and FS2C collision somewhere since I'm not the only one having the prob with the clickspot.  As for the mic, I'm using a joystick button and I've got the repeat on full for that one.

 

-Rick

Share this post


Link to post
Share on other sites

Not a collision in code, I suspect the problem is the way the Vox ATC panel cfg entries are added to the aircraft.  Based on what the user above reported, they're out of order.

 

As mentioned, you don't even need the clickspot to open the Panel.

 

Use the joystick/keyboard button instead.

Share this post


Link to post
Share on other sites

Moving the entries in the panel file made no difference.  Guess I'll have to try the hot-key for the main panel.

 

-Rick

Share this post


Link to post
Share on other sites

Well, ended up with a work-around.  Setting the panel toggle in the FS settings did NOT work.  I would not display.  So, I set up one of my joystick buttons via FSUIPC to toggle the panel and THAT works.  FYI Mork.  I'm going to try the same with the soft mute and will report back.....

 

-Rick

Share this post


Link to post
Share on other sites

Confirmed.  Setting up the soft mute via FSUIPC works as it is supposed to do.  Go figure.

 

-Rick

Share this post


Link to post
Share on other sites

Can't explain that one, but the important thing is you got it working  B)

Share this post


Link to post
Share on other sites

Hi,

 

I have a other problem. I use VoxAtc too so i must save the situation when i make a flightplan. Now when I load the Situation then i have a problem with Fs2crew Voice. >SDK Error.

Now I found the Problem. I stand in EDDS at Gate 14. PMDG 737-800NGX is in Cold and Dark. I start Fs2crew voice and it woks. But now when I save and then I load the situation so i get the SDK Error. I use the new Version from Fs2crew Voice. Any tips ?

 

(sorry for the bad english :D )

 

-Christian

Share this post


Link to post
Share on other sites

Hi Christian,

 

Have you tried starting FS2Crew only AFTER you saved/loaded your situation? I don't use VoxATC, but I remember having had the SDK error myself when loading a situation with FS2Crew already running.

Share this post


Link to post
Share on other sites

Hallo Stefan,

 

 

I start Fs2crew after I save/load my situation. So i select the PMDG 737-800 then i save the situation and after i load situation, i start Fs2crew

Share this post


Link to post
Share on other sites

 

 


I start Fs2crew after I save/load my situation. So i select the PMDG 737-800 then i save the situation and after i load situation, i start Fs2crew

 

It's not always the case, but try not using 'saved' situations.

 

Have the Trike as the default aircraft when FSX loads, then load the NGX directly from the Free Flight Screen.

Share this post


Link to post
Share on other sites

But the problem is i must save the situation because Voxatc. I make a flightplan then i must save the situation and then i must load because Voxatc. When i'm not save/load the situation Voxatc doesnt work.

Share this post


Link to post
Share on other sites

Try installing FS2Crew again (so after installing Vox). Then do your things and wait for the NGX to initialize, then open FS2Crew menu and after that Vox.

Vox also edits the panel.cfg and adss guages, and FS2Crew doesn't like that being altered. So reinstall FS2crew and open FS2Crew before Vox. And start your NGX with 2D panel if it still doesn't work.

Share this post


Link to post
Share on other sites

It doesn't work. But now it works because i load the sitution, then i start fs2crew >SDK ERROR and i load again the flight now it works. So i must load the situation 2X :lol:

Thank's for the tips

Christian

Share this post


Link to post
Share on other sites

 

 


But now it works because i load the sitution, then i start fs2crew >SDK ERROR and i load again the flight now it works. So i must load the situation 2X

 

Having to load the situation 2 time: You can thank Simconnect for that.  

 

Even the all mighty Pete Dowson has observed that, under certain situations, the NGX SDK only loads on "alternate" loads.

 

Your positive Vox ATC forces you to use their situation file?  That's the reason for this.

 

But as long as you got it working, that's all that counts.

 

Cheers,

Share this post


Link to post
Share on other sites

×
×
  • Create New...