Archived

This topic is now archived and is closed to further replies.

stratfordman10

Flashing clouds around mountains

Recommended Posts

I have just recently noticed a strange phenomenum when flying at say 30,000 feet of the clouds flashing back at me when they are surrounding the mountains.

 

Any suggestions or thoughts would be most welcome.

 

Many thanks in anticipation.

 

Michael

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Not sure if this applies to your situation Michael, but for flashing clouds, I've found that setting Water Effects to High 2.x eliminates that effect.   If you're referring to clouds popping up, then this is part of the FSX design and increasing your Scenery LOD and/or a larger cloud draw distance will help a little, but you may lose out in the FPS dept.

 

Chris

Share this post


Link to post
Share on other sites

What you are seeing is probably normal, you have clouds and terrain at the same elevation, I see it all the time.

 

As a test you can go into your FSX weather settings and move your cloud layer up 10,000 or 15,000 feet and then go fly over the same spot, if they are not flashing then it is what is normally seen.

Share this post


Link to post
Share on other sites

There is a cloud fix for this. Search the forum.

 

Bob

Share this post


Link to post
Share on other sites

Bob is probably referring to this post, by Stephen (Spirit Flyer), a few years back (I think). Here it is in it's entirety.

 

 

 

 This fix has been around for several years and works:  Go to this folder:

FSX\ShadersHLSL\misc

There you will find a file called SwarmCloud.fx. Make a backup copy of this file .

Open the original SwarmCloud.fx in notepad or wordpad and then look down about 20 lines down from the top. You will see this entry:

bool NewMaterialUsage = true;

Change its value from true to false. Make sure to keep the semi-colon.

Save and close the file.

Now, go to C:\documents & settings\<your username>\Local Settings\Application Data\Microsoft\FSX\

(If you can't get to this folder make sure that "show hidden & system files/folders" is turned on in your windows folder options.)

(This is the XP path by the way, Vista users will have to hunt for their equivalent in the users folder.)

You will see a folder there called: Shaders.

Either move that folder out of there or delete it. Don't worry, FSX will build a new one the next time you run it. It contains a cache of the compiled shaders. This folder must be removed to ensure that the change you made to the cloud shader file above will be compiled and used on FSX's next run.

That's it. Run FSX and enjoy very solid and reliable clouds! I haven't seen any other bugs or oddities crop up from this change. I've had a few friends who were also experiencing flashing clouds test it as well, one on nvidia, the other on ATI, and their clouds stay perfectly put now."

Kind regards,

Stephen

Share this post


Link to post
Share on other sites

There is a cloud fix for this. Search the forum.

 

Bob

If you're referring to the swarmcloud.fx fix, then i'm not sure if that would help him. Somtimes the clouds are clipping with the mountains.

I also have an issue with clouds. Even though the swarmcloudfix made it a little better, i still experience some flashing cloud layers with (but also without) Opus in DX10. Haven't testen with DX9 yet, but i don't think DX10 is the cause.

Share this post


Link to post
Share on other sites

I need to add - since moving to both REX E+OD and Active Sky 2012 - I have not seen any flashing  interaction with any scenery. They are both very good programs.

Share this post


Link to post
Share on other sites

Well, I'm here to tell ya --- these tips worked for me!!

 

I changed the swarm cloud setting to False (there was no shader folder in documents & settings\<your username>\Local Settings\Application Data\Microsoft\FSX\ to delete), I set water to High 2, and raised the cloud layer to 16000 & 20000. Have been flying over the Rockies out of DEN for 2 hours now and I have not seen one single shimmering, flashing or popping cloud anywhere. The sim looks so much more realistic weatherwise and I have default weather with clouds at 40mi/medium.  Fantastic!! Thank you FSX Gods!  B)

Share this post


Link to post
Share on other sites