Archived

This topic is now archived and is closed to further replies.

mixen82

Ground textures get blurry too near at the aircraft. NEED HELP :(

Recommended Posts

Hi everyone,

 

I know, this has been discussed a xillion times before, but my problem is really bad, so I want to give it a try. Especially because all solutions mentioned in the other thread came up negative.

 

Because of the architecture of FS9, the grounf textures used in the distance get les detailed the further away from the aircraft they are, as FS uses a lower LOD model for object further away. But my problem is,that is seems that my textures get blurry and less details way to close to the aircraft. 

 

I have tried to modify the related entries in my fs9.cfg. I have also read and understood Jobia's amazing documentation ( only in German ), but nothing helped. The problem is, that the textures get blurry and less detailes about 6 to 7 miles away from the aircraft. That is unacceptable, especially because I usually do IFR commercial airliner flying within Europe and across the pond. So in high altitudes the visual experience is just bad.  :Cry:

 

Attached is an image of what it looks like, and that is only at an altitude of 10.000ft. (!!!!)

 

I do not think it has anything to do with my system:

 

CPU: Intel CoreI5 3550 ( 4x3.3GHz )

Mainboard: MSI Z77A-GD65

Memroy: 16GB Kingston HyperX Genesis

Video Card: nVidia GeForce 660TI 

 

The strange thing is that I had a much sharper and detailed visual appearance before, but I have not changed anything compared to then, so I wonder what has changed.

 

Any help would be greatly appreciated.

 

And please no bashing just because I started a topic that comes up on a regular basis, thank you.

 

cheers

Mike

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

 

 


Any help would be greatly appreciated.

 

Are the textures we see in the screen shot default? If they are I also notice a lack of autogen - it is there, just not in the numbers I would expect (see the area below and left of the Airbus tail. Have you made any modifications to the Autogen\ default Xml file or the terrain.cfg file? If the textures we see are default and the answer to the other questions are "no" then I would take a look at the FS9.cfg files [Terrain] section settings.

 

Regards,

Mel

Share this post


Link to post
Share on other sites

Hi Mel,

 

no, they are GE Pro ground textures. Autogen "lever" is at max. I too noticed that there should be many more autogen visible. Autogen\default.xml and terrain.cfg files are completely unchanged, I have never modified those two files. Terrain section in the fs9.cfg reads as follows:

 

TERRAIN_USE_VECTOR_MAP=1
TERRAIN_USE_VECTOR_OBJECTS=1
 
and
 
TERRAIN_ERROR_FACTOR=100.000000
TERRAIN_MIN_DEM_AREA=0.000000
TERRAIN_MAX_DEM_AREA=200.000000
TERRAIN_MAX_VERTEX_LEVEL=21
TERRAIN_TEXTURE_SIZE_EXP=8
TERRAIN_AUTOGEN_DENSITY=5
TERRAIN_USE_GRADIENT_MAP=1
TERRAIN_EXTENDED_TEXTURES=1
TERRAIN_DEFAULT_RADIUS=4.000000
TERRAIN_EXTENDED_RADIUS=4.000000
TERRAIN_EXTENDED_LEVELS=4
 
On the last 3 entries, the factor 4 is the maximum that leads to a change, higher values have no effect to the visual appearance.
 
cheers
Mike

Share this post


Link to post
Share on other sites

Mike,

 

the trick I use is this: after starting a flight with whatever airplane, I adjust the spot view distance as follows:

 

1. Set zoom to 0.9

2. set the distance from the airplane so that the whole airplane is comfortably visible from a side, or 45 degrees.

 

As I wrote, it's just a trick, but it works. Some airplanes set a high zoom in spot view by default when loaded and therefore the ground textures will seem blurrier than otherwise.

 

Regards,

Jure

Share this post


Link to post
Share on other sites

Hi Jure,

 

thanks for your tip, I use that one myself :) the problem is that the problem even occurs when I am in virtual cockpit view ( I use walk and follow to get some kind of "window view" ) and set the zoom factor to 0,64, wghich gives a pretty realistic view in VC. Even there the textures a blurry.

 

cheers

Mike 

Share this post


Link to post
Share on other sites

 

 


Terrain section in the fs9.cfg reads as follows:

 

Mike,

Sorry it took so long for me to get back to this post. There are a few settings in your terrain section that caught my attention. They (the settings that differ from mine) may be causing your issues. Based on what you have written in your response to my questions, I think this is about the only area that could be responsible.

 

Here are my settings for you to try if you would like. At least to see if there are any positive / negative results.

 

[TERRAIN]
TERRAIN_ERROR_FACTOR=100.000000
TERRAIN_MIN_DEM_AREA=10.000000
TERRAIN_MAX_DEM_AREA=100.000000
TERRAIN_MAX_VERTEX_LEVEL=21
TERRAIN_TEXTURE_SIZE_EXP=8
TERRAIN_AUTOGEN_DENSITY=5
TERRAIN_USE_GRADIENT_MAP=1
TERRAIN_EXTENDED_TEXTURES=1
TERRAIN_DEFAULT_RADIUS=9.5
TERRAIN_EXTENDED_RADIUS=9.0
TERRAIN_EXTENDED_LEVELS=4

 

Regards,

Mel

Share this post


Link to post
Share on other sites

Hey Mike,

 

Could you please do screenshots of all your Display settings in FS9 and provide them here. Also let me know how is your VC tweaked in the CP. Bear in mind that all the settings in fs9.cfg are controlled through the program internal Display setup, so there is nothing more you can do by editing the lines manually in the text file.

 

Cheers,

Alex

Share this post


Link to post
Share on other sites

Hi Mel,

 

I have tried your settings although I knew that they would not solve the problem. Instead they led to the known "blue hole"-bug at LOD transitions. So I reset them back to my original settings.

 

Hi Alex,

 

Somehow the forum engine prevents me from attaching images. I will try to attach my display settings later :(

 

cheers

Mike

Share this post


Link to post
Share on other sites

 

 


So I reset them back to my original settings.

 

Sorry that did not work for you, but at least that is eliminated. I'm curious about what you described as a 'blue hole' bug. Could you please explain that in more detail for me.

 

After thought here; If you are referring to blue slivers showing up in the terrain in the distance that look like torn mesh, that is exactly what it is. This problem can be fixed. If you are using the default FS9 mesh change your "TERRAIN_MAX_VERTEX_LEVEL=21" back to "TERRAIN_MAX_VERTEX_LEVEL=19" that should help. If you are using a add on mesh of higher resolution such as 38m mesh then adding a intermediate level or two of mesh called a buffer mesh will in effect fill these blue areas and they will disappear. That will allow you to display the terrain a higher level such as 20 or 21 without the slivers except in a rare instance.

 

Search "Blue Slivers" from the main AVSIM forum page. There is a lot of detailed information on the subject.

 

You might try my settings again - with the change mentioned above, see if that helps.

 

Regards,

Mel

Share this post


Link to post
Share on other sites

Yeah, those are ecactly what I was referring to. I will now try to add a intermediate level as you described, as I indeed use mesh of higher resolution. Thanks for the tip. After that I will retry your settings again. I will keep you advised if that helped.

 

cheers

Mike

 

 

Share this post


Link to post
Share on other sites

Now I have installed a LOD7 buffer mesh and the blue slivers are gone :) trying out your values in the fs9.cfg had no effect. I changed them bach to mine.

 

cheers

Mike 

Share this post


Link to post
Share on other sites

What I'm seeing in your FS9.cfg setting that will cause this problem is:

 

 

TERRAIN_MIN_DEM_AREA=0.000000
      change to 10.000000
TERRAIN_MAX_DEM_AREA=200.000000
      change to 100.000000
TERRAIN_DEFAULT_RADIUS=4.000000
     change to 9.500000
TERRAIN_EXTENDED_RADIUS=4.000000
    change to 9.500000
TERRAIN_EXTENDED_LEVELS=4
    change to 8
also make sure your global max texture size is Massive.
 
If that don't fix your problem then the only other thing I can think of is memory starvation, and that's usually a texture problem.

Share this post


Link to post
Share on other sites

Hi Tommy,

 

as expected, the changed you suggested had no effect, so I changed them back to mine. BTW: maximum values under TERRAIN_DEFAULT_RADIUS, TERRAIN_EXTENDED_RADIUS and TERRAIN_EXTENDED_LEVELS are 4. FS will ignore all values above 4, resulting in no visual effect. But nonetheless I tried, but as mentioned without success. 

 

I don't think that memory starvation is the problem here: 16GB system memory at 9% load when FS is runnning (along with Win, Antivir and a few other programs), 2GB Video memory, at 56% load when FS is running. CPU sits almost idle at 1% load.

 

cheers

Mike

Share this post


Link to post
Share on other sites

Hi Mike,

 

Sorry that didn't work for you. On my system I can tell a big difference between TDR / TER 4.0 and 9.5 which is why I suggested that, slong with TEL at 8. I know this has been discussed to death over the years, for some it worked, some it didn't. I do seem to recall that someone from Aces had suggested the 9.5 settings.

 

Memory starvation can still be a problem, FS is still a 32 bit app. so it doesn't matter how much system memory you have FS will never use it all.

Are you using Ultimate Terrain, 32 bit textures,  a lot of AI, photo scenery, etc ?

 

On my system I start to see what you are seeing when memory usage in task manager starts getting up around 1.8-1.9 GB, at 2.1-2.2 GB I see exactly what you're seeing, my system has 4 GB ram, 1 GB video ram, and page file set at 3 GB.

( It's an old system)

Share this post


Link to post
Share on other sites

Hi Tommy,

 

right, some had sucess with it, others like me didn't. Too bad it doesn't work for me :( problem would be soled right now. So troubleshooting continues.....

 

No, I use GE Pro textures. Just recently I tried to get it fixed with using the textures out of the Reality packs, available as freeware here on Avsim. But the prob was still there. In addition, those textures did not look too good, so I switched bach to GE Pro. I am not using any photoscenery besides those included with several payware airport sceneries. While I like the look of photoscenery when flying at high altitude, they look just ugly on approach. The abstinence of autogen in photosceneries make it worse. But I use massive AI traffic, I would say about 80 to 90 % of the real world traffic is covered in my sim. I don't use payware AI traffic addons like MyTaffic or Ultimate traffic. I install AI Planes and flightplans manually by using Traffic Tools. A LOT of work I can tell you, but also a lot of fun, at least for me :)

 

I think to remember that I read somewhere that there is a way to bring FS to using more memory than originally intended to cope with higher end machines available today. Do you know how this can be achieved? I think I read something about a little patch style tool, but I am not entirely sure about that.

 

cheers

Mike

Share this post


Link to post
Share on other sites

 

 


I think to remember that I read somewhere that there is a way to bring FS to using more memory than originally intended to cope with higher end machines available today

 

The only one I can think of is the 3GB switch but that only applies if you are using a 32 bit OS.

And the greater than 2 GB address aware switch in the FS9.exe .

 

Are you using 32 bit textures on AI aircraft or in any scenery ?

 

Is this happening everywhere or just in certain areas ?

Share this post


Link to post
Share on other sites

Textures on AI aircraft vary, but most of them are in 32bit. If I had to guess I would say about 70 to 80% of them. Same applies for scenery.

 

The problem occurs everywhere. The only weird thing is that it appears to be more evident in Europe. In the US it is there too, but not as obvious as in Europe.

 

Too bad. I use a 64bit OS.

Share this post


Link to post
Share on other sites

 

 


Too bad. I use a 64bit OS.

 

In regards to your 64bit OS, have you made the FS9.1 executable large address aware so that it can take advantage of the extra RAM?

 

 

 


BTW: maximum values under TERRAIN_DEFAULT_RADIUS, TERRAIN_EXTENDED_RADIUS and TERRAIN_EXTENDED_LEVELS are 4.

 

I beg to differ here. It is my understanding that the maximum for TERRAIN_DEFAULT_RADIUS and TERRAIN_EXTENDED_RADIUS is 9.9 and TERRAIN_EXTENDED_LEVELS must be either 1 or 4, nothing else.

 

I'm sorry I can't provide a direct link to the article. It was a post by Holger Sandmann, on which forum I don't know, so in fact, I have nothing to back up what I am writing. I am going on memory and at my age I always question that source! I will also admit that I am sure this has and is a much debated topic.

 

AI textures should be DXT3 with alpha channel, mips are sort of optional. I do agree that 32 bit looks great, but are not a FS9 native texture and take a much larger amount of disk space and requires more GPU work. See the Pinned topic; "A Huge FPS Increase". I use 32 bit without mip maps for my flyable aircraft only and I make sure everything has a alpha channel.

 

Your use of a large number of 32 bit textures may be affecting your texture load time causing the loss of scenery texture resolution and autogen - just a thought.

 

Regards,

Mel

Share this post


Link to post
Share on other sites

Hi MEL,

 

how can i make FS9.1.exe aware of a larger amount of available system memory? Is there anything in the settings menu for the file that can achieve that?

 

So I see were i am going. I will try to reinstall all AI aircraft in DXT3 format. Dear, that will take some time, but since I have 2 weeks off, I now can be sure that I won't get bored :-) Hopefully that will help solving my problem. 

 

As for the max values for TERRAIN_DEFAULT_RADIUS and so on: From what I understood in Jobia's awesome FS graphics bible ( 500+ pages, unfortunately only in German ), the max values are unlimited, with the value 4 being the maximum value with a visible effect. But I agree, this has been discussed millions of times before and opinions vary for that matter. :-) Some do see a difference with values above 4, others don't. On a side note: Jobia's "bible" is a few years old now, and maybe knowledge of how FS works has increased since then, with max values of 9.9 being a more up-to-date statement.

 

cheers

Mike

Share this post


Link to post
Share on other sites

Hi Mike,

 

To set the large address aware flag you can use the programs here

 

http://www.ntcore.com/exsuite.php

 

or here

 

http://www.techpowerup.com/forums/showthread.php?t=112556

 

With most of your AI textures being 32 bit that is more than likely causing your memory starvation.

With 32 bit textures every AI aircraft loaded is using 8 mb just for textures where dxt3

will only use 2 mb, A huge difference, and that's for non mipped 1024x1024 textures. That's not counting any scenery you may have that also has 32 bit textures in it. Even with the large address aware flag set you will probably still have some memory starvation.

 

As an example, in the area around JFK I would normally have 6-800 aircraft loaded at any given time. With 32 bit textures I would be using 480-640 mb of memory just for AI aircraft textures with dxt3 it would only be 120-160 for the same area.

 

The only textures I allow to be 32 bit are clouds, and on user aircraft props, and some glass textures.

Share this post


Link to post
Share on other sites

Hi Scorp,

 

thanks, I will try that. In addition, I will change as much of the AI textures into DXT3 as possible. But, as mentioned, this will take some time, as I use massive AI traffic. 

Coming to your example: Memory starvation would make sense here I the problem would occur around JFK. In fact, the problem is more evident when flying around STR ( like on the screenshot in my first post ). From my understanding, when flying arounf JFK, the problem should be much worse than around STR. But it isn't. That's what's weird IMO.

 

Hi maple-syrup,

 

yes I have AA and trilinear filtering switched on. nVidia insepctor is overriding FS AA settings and runs AA at 8x Multisampling. In addition, nVidia Inspector is running 16x Anisotropic filtering.

 

cheers

Mike

Share this post


Link to post
Share on other sites

 

 


Jobia's "bible" is a few years old now, and maybe knowledge of how FS works has increased since then, with max values of 9.9 being a more up-to-date statement.

 

I have not read Jobia's work - my German is so rusty it could only cause me trouble! I will certainly not dispute your point of view based on that and the fact that what I 'think' is either equally dated or even older.

 

Do you actually have AA switched off in FS9? Make sure you do, so you are only using the inspector settings.

 

Let us know how the texture changes work for you. Finally, once you have the utility Tommy mentioned installed; Right click on the FS9.exe in the root folder and click on Open with CFF Explorer. In the new task pane that opens click on 'File Header', then in the window to the right, where it reads "characteristics" look to the right side for 'click here', click on that and it will open a new pane. The eighth item down reads "App can handle >2gb address space", put a check in the box and click ok. Then in the first pane click on 'file' and save. Close and you are done. I would also recommend that you delete any FS9 shortcuts and create new ones. I don't know if that is absolutely necessary but it can't hurt and may prevent problems.

 

Regards,

Mel

Share this post


Link to post
Share on other sites
and the fact that what I 'think' is either equally dated or even older.

 

Maybe, but you are by far not the only one suggesting those values, so it's quite possible you and the others are absolutely right and my knowledge is outdated. :-)

 

I definitely will let you know the outcome of the texture change. But as there is massive work to do on this, it might take a little while. 

 

Antialiasing option in FS is switched on, with nVidia Inspector set to "enhance application settings" in the first place. nVidia Inspector is now set to "Override application setting", so I assume that FS setting would just be ignored. 

 

Installed the tool and fs9.exe is now capable of using more than 2GB memory  :Big Grin:

 

cheers

Mike 

Share this post


Link to post
Share on other sites

 

 


Antialiasing option in FS is switched on, with nVidia Inspector set to "enhance application settings" in the first place. nVidia Inspector is now set to "Override application setting", so I assume that FS setting would just be ignored.

 

Here again, my understanding is that AA should be switched off in FS9 and thus GPU driver AA should be allowed to work independently of FS9 so that there is no conflict. I will add that I use a old driver and NHancer and not Inspector so there may be nothing at all wrong with your method. Judging from your screen shot I would say - no problem. It is just my opinion that having AA switched off in FS9 makes certain that the override function is not necessary and that no additional GPU work is caused. In the past the override application setting did not always do what it was supposed to do.

 

Good, you got the large address aware tweak done.

 

Regards,

Mel

Share this post


Link to post
Share on other sites