Sign in to follow this  
Nigge

Support for "download winds" to PMDGs 777

Recommended Posts

Hi!

I noticed that PMDG has implemented a function to download enroute winds into the fmc of their 777, will this be supported in OPUS?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi!

I noticed that PMDG has implemented a function to download enroute winds into the fmc of their 777, will this be supported in OPUS?

 

By the looks of it they have added the feature in the latest beta of Opus. Although I need to look into how to use it properly as when I requested for the data to be imported, the execute light lit up but then no data was actually added.

Share this post


Link to post
Share on other sites

The beta including this feature has just been posted earlier this morning, please check the SimForums Announcements and also I believe Cheryl may have already posted something on this forum.

 

Stephen

You must import or activate the flight plan into Opus, then process it, then update the weather. Only after processing the flight plan and updating the weather will the file be generated. Please read our Announcements.

 

Stephen

Share this post


Link to post
Share on other sites

The beta including this feature has just been posted earlier this morning, please check the SimForums Announcements and also I believe Cheryl may have already posted something on this forum.

 

Stephen

You must import or activate the flight plan into Opus, then process it, then update the weather. Only after processing the flight plan and updating the weather will the file be generated. Please read our Announcements.

 

Stephen

 

The file has been generated but for some reason it didn't get imported into the FMC.

Share this post


Link to post
Share on other sites

My responsibility is just generating the file in accordance with the manual and PMDG spec, I have no idea about the importing into the 777 via the FMC.

 

Stephen

It may need to be tab delimited, you could try removing the space delimiters and inserting a single tab character. Don't know why they couldn't just skip over ALL delimiters in the file, but that might be it.

 

Stephen

Share this post


Link to post
Share on other sites

Thanks a lot for the information,

Stephen: Can you post a link to information regarding this? I must have totally missed it:)

Share this post


Link to post
Share on other sites

We have posted a new beta at 13:00 Zulu which changed the delimiters within the file so can you try that and let me know if it works OK.

 

We seem to have several topics regarding this subject on the go at the moment so if you could report on SimForums that would be useful for us. http://www.simforums.com/forums/topic47077_post287606.html#287606

 

Thanks

Cheryl


The beta dev is progressing fast in our SimForums, a new beta is being tested with tab delimited text. You will find a link to our SimForums on our main web page, but this should take you to the forum.

http://www.simforums.com/forums/opus-software_forum49.html

Stephen

Share this post


Link to post
Share on other sites

That is their main forum. Here on AVSIM this is their sub. Better response time over there and more activity.

Share this post


Link to post
Share on other sites

Thanks, there doesnt seem to be any lack of activity here at all;-)

 

I hope its okay that I keep writing here...

 

Can anyone post an instruction step by step to get the winds into the fmc?

I am using PFPX as flight planner...

 

I guess I have to export my route as FSX-route (.pln) but when I import that into opus, it seems to interpret my airways as points in the US...

And I cant find any "buttons" for creating the 777 wx file.

:)

Thanks

Share this post


Link to post
Share on other sites

I haven't got the 777 but from the information on our SimForum you may need to export the flight plan in two formats PMDG and FSX. ...

 

"I export a plan in the PMDG format that is used solely for the PMDG aircraft FMC, and I export a seperate FSX plan that I use for my ACARS, EFB, and weather programs.

 
So, the FSX plan for this flight got imported into OpusFX and processed"
 

We have posted a new beta this morning since there were problems if you cut and pasted your flight plan from PFPX as opposed to using the OpusFSX import option.

 

Once you active your flight plan using the OpusFSX process option or via FSX options then the ICAO1ICAO2.wx file is automatically created for you, no need for any "buttons" for creating the 777 wx file.

 

Then I believe it is just a matter of pressing WIND DATA REQUEST on the WIND page in the airplane and it will automatically load the values into the FMC. Note that it is best if your cruise altitude is already entered on the PERF INIT page before you do this as it helps the PMDG algorithm narrow down the correct altitudes to use.

 

 
Cheryl

Share this post


Link to post
Share on other sites

One more point to note. If your GRIB data is not decoding then it may be caused by a setting in the Windows operating system English culture setting.

 

OpusFSX automatically selects and uses a generic English culture to ensure correct floating point number conversion. We have had problems where people have edited the English culture setting and changed the Windows Number format decimal separator from a dot to a comma. Ensure the dot character is assigned as the decimal separator in the Windows Number format, not the comma.

 

Cheryl

Share this post


Link to post
Share on other sites

One more point to note. If your GRIB data is not decoding then it may be caused by a setting in the Windows operating system English culture setting.

 

OpusFSX automatically selects and uses a generic English culture to ensure correct floating point number conversion. We have had problems where people have edited the English culture setting and changed the Windows Number format decimal separator from a dot to a comma. Ensure the dot character is assigned as the decimal separator in the Windows Number format, not the comma.

 

Cheryl

 

Dear Cheryl,

 

Lots of people throughout the world use OpusFSX in computers that are shared with other several applications, and each country has its own number format and other language characteristics. So, instead of each person having to change it as you told above, thus causing a lot of problems in regard to his/her other applications/language, don't you think that is so much more efficient OpusFSX to make an internal conversion?! It's so very simple! I'd say an "IF..THEN..FORMAT()" would do it.

Anyway, just my 2 cents.

 

Best regards,

Share this post


Link to post
Share on other sites

You have misunderstood what I have said, we do not want people to change the standard settings, if they do then that causes the problem.

 

If you are using non English GB language and culture settings then OpusFSX will automatically use the English culture just to decode the GRIB data. This has no affect on the culture used by your operating system or any other applications.

 

Cheryl

Share this post


Link to post
Share on other sites

Thanks, there doesnt seem to be any lack of activity here at all;-)

 

I hope its okay that I keep writing here...

 

Can anyone post an instruction step by step to get the winds into the fmc?

I am using PFPX as flight planner...

 

I guess I have to export my route as FSX-route (.pln) but when I import that into opus, it seems to interpret my airways as points in the US...

And I cant find any "buttons" for creating the 777 wx file.

 

 

 

:)

Thanks

 

Once you made your flight plan in pfpx  there is a option to export the flight plan to your pmdg folder etc ,if you look further   down the list you will see another option wind data  tick these 2 boxes and than click the save option on top you will get a notification if  done correctly. Than once in your t7  once your have finished  enrtering your co route in the fmc   in the legs page   go to the next page I think or  route  page one of  the 2  and  you will see wind  data  click on this  and than execute it  and it will upload  the wind  data  for  you

 

omxPr.png

Share this post


Link to post
Share on other sites

You have misunderstood what I have said, we do not want people to change the standard settings, if they do then that causes the problem.

 

If you are using non English GB language and culture settings then OpusFSX will automatically use the English culture just to decode the GRIB data. This has no affect on the culture used by your operating system or any other applications.

 

Cheryl

 

Hmmm, I see what you meant now. This is my third flight and it didn't work, I mean, the .WX file was created successfully and everything, but checking the winds within 777 there's nothing. Opening  the .WX file I see lots of zeros, so I think the population for 777 was fine and the problem lies in the .WX file, as to why it didn't get the proper values?

I must tell that my numbering format within Windows is different from the english default, even though I configure it as British English. The number format is like #.###,##. Anyway, thinking of it, I reverted it back to the english default, exchanging , with . and vice-versa. It didn't work either.

I plan to buy PFPX, and I know that it can also export .WX files to 777, automatically as the flightplan is created/exported, so considering using this feature, how can I disable the .WX file creation within OpusFSX?

 

Thank you again.

Share this post


Link to post
Share on other sites

There is no need to change your system's culture settings since the software will automatically use the GB English settings independently of your system settings. Just make sure you do not edit and change the default GB English culture settings.

 

Trouble shooting ... 

 

Make sure the GRIB data has been downloaded and decoded, if not check your \OpusFSX\FSDECODER.log file. 

 

If your wx data is all OK in the file OpusPMDGData.txt in the OpusFSX\Themes folder then it's a simple case of not being able to copy this file into your <FSX>\PMDG\WX folder. Perhaps it's a sharing and permissions issue, check these in accordance with the Getting Started Guide.

 

OpusFSX uses the English (GB) culture for the decoding format, do not change any settings in this culture especially the decimal separator type.

 

PMDG FMC Wind/Temp Data Request procedure ...

 

You must have a PMDG aircraft selected. Enable GRIB data; if you have Adjust Options Automatically enabled then make sure your cruise altitude is above 6000 feet.

 

You must enter or Import your flight plan into Opus, then the FP must be activated either via the OpusFSX Process option in the Flight Plan dialog or via the FSX options. Specify your Destination and Cruise Altitude, then Update the weather. 

 

Only after this will Opus be able to generate the file. There is no need to cut and paste anything. In the airplane on the LEGS page select WIND DATA, press WIND DATA REQUEST and the data will automatically load the values into the FMC, press EXECUTE to finish. Note that it is best if your cruise altitude is already entered on the PERF INIT page before you do this as it helps the PMDG algorithm narrow down the correct altitudes to use.  

 

If you are using PFPX to generate your flight plan then it must be exported in two formats, as Peter has explained above, one for the PMDG to its dedicated folder, and one in FSX .pln format to your docs/<SIM>/ folder so Opus can read it. 

 

Cheryl

Share this post


Link to post
Share on other sites

 

You simply do not have any GRIB upper forecast data in use. Please read and follow the Recommended Practices, make sure you set all defaults in the weather dialogs at least once, and before each flight make sure you specify your Destination and Max Cruise Altitude. You need a Max Cruise Altitude of at least 6000 feet to get GRIB data. If you are following Recommended Practices then you would know for certain that you have GRIB forecast data in use because you would have checked the on screen Lower and Upper Atmosphere report. Of course you must input and process a flight plan so that Opus can generate the flight plan reports including the WX file.

 

There should be no problems as many thousands are using these procedures.

 

Stephen :-)

 

If you are not getting GRIB data (check the on screen Lower and Upper reports) then open the Spy window before updating the weather and check your FSDECODER.log file in your OpusFSX folder. I assume you have installed the latest release version.

 

Stephen :-)

Share this post


Link to post
Share on other sites

Checking FSDECODER.log, it shows 0 Lines Decoded everywhere. Is it fine to mess US English settings? I was using UK English all messed up, because I like it to show english language days, but I need it to use "." as grouping and "," as decimal.

I have just reset all the UK English settings, and set US English as the new one, but making these changes stated above, among others, like the currency of my country, hour preferences, date preferences, etc.

Next I'm gonna test to see if it works.

 

Regarding PFPX, the .WX file generated by it doesn't conflict with the .WX file generated by OpusFSX?

Share this post


Link to post
Share on other sites

Please do NOT mess up the English GB setting, the software needs this culture in order to decode numbers !

 

Can you please show me the contents of your FSDECODER.log file. If all works your FSDECODER.log should show something like this,

 

 

OpusFSX GRIB Data Decoder, Version 3.43

 

Log Generated 20 March 2014, 08:38 Hrs

 

Decoding GRIB Forecast Data in Path C:\OpusFSX\GRIB

 

No Errors Detected.

 

 

I have no idea about PFPX WX files, I don't use the package.

 

Stephen

Share this post


Link to post
Share on other sites

You can select the US English settings for your PC and edit these as you wish but don't alter the default GB English settings since the decimal separator must be "." and not "," otherwise the GRIB decoder will not work.

 

Cheryl

Share this post


Link to post
Share on other sites

I've done as per your instructions. I reset the GB/UK English, I now selected US English (and "messed" with it as per my preferences) and it seemed to work, as the FSDECODER.log now shows no errors detected. Notwithstanding the .WX was not created again, but I need to test it again with a new fresh load of FSX and OpusFSX, I'll do that later today, probably.

Thank you for your assistance!

Share this post


Link to post
Share on other sites

To generate a PMDG WX report you must ...

 

Be performing a full weather update.

Have GRIB forecast data in use (check Opus Lower and Upper reports).

Have a PMDG aircraft selected within the simulator.

Have a \PMDG\WX sub-folder in the simulators folder.

Have processed an Opus flight plan (check the Weather dialog).

Have a specified and recognised Destination.

 

If these conditions are met then the OpusPMDGData.txt file is created and copied into the simulators PMDG\WX folder with and appropriate name.

 

There are many thousands of people currently using this feature so please check you have performed the above steps. The current GRIB forecast data is also recorded in the OpusWeatherReport.txt file and your flight plan weather in the OpusFlightReport.txt file.

 

Stephen

Share this post


Link to post
Share on other sites

Stephen,

 

Considering I've already exported .WX file to FSX via PFPX or any other software, when I process the flightplan within OpusFSX that .WX file will be overwritten?

 

Thank you!

 

PE

Share this post


Link to post
Share on other sites

Yes, OpusFSX generates a WX file based on the 'actual' winds that are 'going' to be injected into the sim. PFPX does not inject weather so its really pointless using the PFPX WX file. The WX file is only useful if the winds match what will be actually injected into the sim and experienced during the flight. That's why you should prepare your flight plan using PFPX (if you wish), then load and process the resulting flight plan into Opus which will then prepare the reports, including the WX file.

 

Stephen

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this