Archived

This topic is now archived and is closed to further replies.

Robert McDonald

777 will not save "FSX Comms Disabled" "NEVER" setting?

Recommended Posts

I select "NEVER" and then click the LSK 6 "RETURN" button and after exiting FSX and rebooting PC, then restart FSX and reload the 777, the "NEVER" setting reverts to "WHEN FAILED/MISCONFIG" which causes problems with FSInn Radio Stack.  I need "NEVER" to be remembered.  The EXEC button is NOT LIT after I make a change to the FSX COMMS DISABLED option... is this a bug or a feature?  Is there some key sequence I should hit to "SAVE" my changes?

 

Note:  All 777 CFG files are NOT READ-ONLY.

 

Thanks.

 

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Robert, are you running FSX as admin and with your FSX installed outside the \Programfiles (x86) directory with no UAC? I have not experienced this problem, it sounds like a rights issue. A shot in the dark maybe, but still :)

Share this post


Link to post
Share on other sites

Hi Morten,

NO UAC.  I have FSX.exe set to run as admin, though my user account on Win7 64bits is also ADMINISTRATOR.  Sorry, I have FSX in the Programs directory.  Not going to reinstall it for THAT issue.  I suspect something else is up.

If necessary, I may do an overlay repair install of Win 7 64.

 

Cheers.

Share this post


Link to post
Share on other sites

I think this might be a bug and its state isn't saved, I can't get this option to save no matter what I do with the panel states or startup states. It is rather irritating if you are trying to use a hardware radio stack with the aircraft as it wont work until you change this option to NEVER.

Share this post


Link to post
Share on other sites

Hi Morten,

NO UAC. I have FSX.exe set to run as admin, though my user account on Win7 64bits is also ADMINISTRATOR. Sorry, I have FSX in the Programs directory. Not going to reinstall it for THAT issue. I suspect something else is up.

If necessary, I may do an overlay repair install of Win 7 64.

 

Cheers.

 

Good, now we know it's a bug :)

 

Abit OT; I had issues with getting access to some cfg files, even w/o UAC, as admin and installed in C:\FSX.

 

I got a little freeware program called "TakeOwnership", I ran that on all FSX related directories, AppData an so forth, worked like a champ :)

Share this post


Link to post
Share on other sites

It is a bug indeed.

Now fixed for the next update.

 

Thanks for sharing.  Good to know.  I can deal with it until the update comes out :D

 

 

Good, now we know it's a bug :)

 

Abit OT; I had issues with getting access to some cfg files, even w/o UAC, as admin and installed in C:\FSX.

 

I got a little freeware program called "TakeOwnership", I ran that on all FSX related directories, AppData an so forth, worked like a champ :)

 

 

Thanks for your input.  I am a little reluctant to run permissions-settings batch files.  I did an overlay reinstall of Windows 7 - no improvement in the crash-on-exit-of-FSX which just started recently.  Sigh.

Share this post


Link to post
Share on other sites

I ran into the same problem. A workaround until the fix comes out is to manually change the setting 777 configuration file.

 

Richard

Share this post


Link to post
Share on other sites

rwalls, on 25 Sept 2013 - 10:23 AM, said:

 

I ran into the same problem. A workaround until the fix comes out is to manually change the setting 777 configuration file.

 

Richard

Richard,

Would you please give me the precise statement syntax and exact file name & file location so I can do the temp workaround, if it isn't a huge bother?

 

 

Also FYI Avsim Members, the little TakeOwnership Context-menu registry hack is simple to implement and simpler-still to use. You can take ownership of any folder and all folders that are below the folder you took ownership of. Simple install, then reboot (to reload the 'new' registry) and you're golden.

 

I 'took ownership' of the entire FSX directory and all of its subdirectories, plus the APP DATA (hidden folder) folder for PMDG and FSX both. Credit to Mosteen (Avsim member) for the idea. The link contains more information. It solves "permissions" issues (if you are having any) by making YOU the "owner" of the folder and all of its files. You then have "permission" to make changes to the folder/files.

 

Here is the link!

 

FWIW, this simple fix "may have" stopped the CRASH I was getting upon closing FSX! So far, so good!! Tried about everything else I could think of with no joy, but TakeOwnership looks like it 'fixed' the crash on exit issue.

 

Will report back after further flight testing. Greatest feature about the new T7 - "TIME COMPRESSION". Worth every dime, especially on long flights during your lunch hour!

 

Note: VA's and online ATC (Vatsim, PilotEdge) generally speaking do not permit time-compression.

 

Thanks.

Share this post


Link to post
Share on other sites

Awesome Robert, knew you would like that :)

 

You're right!  The right-click context menu is the ONLY way to fly!  It's WAY easier than issuing prompts at a command line.  Nearly instantaneous unless a gigantic number of files (FSX directory took a little bit).

 

Thanks so much for putting me onto this!

Share this post


Link to post
Share on other sites

This is how to prevent comms from being disabled.

 

In directory: FSX\PMDG\PMDG 777X

edit: 777_Options.ini

change this line from 1 to 0: AllowRadioDisable=0

 

Richard

Share this post


Link to post
Share on other sites

This is how to prevent comms from being disabled.

 

In directory: FSX\PMDG\PMDG 777X

edit: 777_Options.ini

change this line from 1 to 0: AllowRadioDisable=0

 

Richard

 

Thanks for taking the time to issue the workaround until the DEVS release the update, Richard!  MUCH appreciated, I'm sure that my good friends who have participated in this thread will be VERY appreciative, as am I!

 

Much respect and gratitude!

Share this post


Link to post
Share on other sites

That still wont work. Every time you exit FSX it will reset back to zero.

Only workaround is to make  the file "Read-only" .

Share this post


Link to post
Share on other sites