Sign in to follow this  
uhecht

DX10 Fixer Configuration

Recommended Posts

Hi guys,

 

after reading all DX10 stuff here and on other places on the internet I decided to give it a try and spend €25 for the tool.

But all in all I am pretty frustrated because the fps drops down to 10 coming from 25 on DX9.

 

My way:

1. I did a backup of my old fsx.cfg

2. I studied the manual and installed the DX10 fixer on my second disk which contains all FSX data.

3 The installer is doing fine and so I was really looking foward to start my FSX initially. Followed the instructions given in the installer and activated missing parts.

4. Highmem=1, Bufferpools=0, and so on

4. Started FSX- it takes longer than before and accepted all dlls from all my add-ons.

ALL my Add-ons are working at night (Aerosoft sceneries and UK2000 sceneries as well, FTX global too,PMDG,Airbus EXE 1.15)

5. I always press Strg+Z to check the fps: got "amazing" 10fps

6. Started REX ESS.

7. Started VATSIM client

8. While updating the REX weather engine drops to 5-6 :(

9. Views in or outside take time to load all the graphics (black shapes before coming up correctly)

10. Taxiing is like a slideshow // Flying a bit better but poor

 

During flights I normally have 35-40fps on DX9. Approaching Mega airports the fps are about 25fps

Now I have only 10-15 fps during flights and about 10 fps or less while approaching mega airports

 

I can't see any improvement on fsx. Better said. On my machine it is getting worse. That sucks and by now a wasting of money.

 

Is there anything I do wrong? Could cry when reading about your fps after installing DX10 fixer.

Do really need help :Praying:!

 

 

My computer:

ASROCK FX990

AMD Phenom X4 965 BE (not oc)

16 GB DDR3-1866

ATI HD6950

2x Samsung IPS235 on Eyefinity

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Hi Chris. Here we go:

 

// This file was tweaked on Aug 27, 2013 at 16:31 GMT using Bojote's automated FSX Tweaking & Tuning Service
// Your 'original' fsx.CFG file was backed up at http://www.venetubo.com/fsx/5b1e43539bf27bd98a7a5728c77eb010/backup/fsx_backup.cfg
// This file is optimized as follows: 4 core(s), CPU speed 3, HT 0, GPU 4, PREF 2
// You can visit Bojote's FSX Tweaking & Tuning service at http://www.venetubo.com/fsx.html
[bufferPools]
RejectThreshold=131072
[VirtualCopilot]
VirtualCopilotActive=0
[sOUND]
AmbientUI=0
AmbientUIMusic=FSX01
AmbientUIMusicVolume=-6.000000
PrimaryDevice={00000000-0000-0000-0000-000000000000}
SOUND=1
SOUND_FADER1=0.280000
SOUND_FADER2=0.350000
SOUND_FADER3=0.270000
SOUND_FADER4=-0.500000
SOUND_LOD=1
SOUND_QUALITY=2
UISound=0
VoiceDevice={00000000-0000-0000-0000-000000000000}
[slewTextInfo.1]
AirSpeed=1,5
Altitude=1,3
Heading=1,4
Latitude=1,1
Longitude=1,2
[DISPLAY.Device.AMD Radeon HD 6900 Series.0]
Anisotropic=1
AntiAlias=1
Mode=3840x1080x32
[AContain]
LabelColor=FFFF0000
LabelDelay=1000
ShowLabelAirline=0
ShowLabelAirlineAndFlightNumber=0
ShowLabelAirspeed=0
ShowLabelAltitude=1
ShowLabelContainerId=0
ShowLabelDistance=1
ShowLabelFlightPlan=0
ShowLabelHeading=0
ShowLabelManufacturer=1
ShowLabelModel=1
ShowLabelTailNumber=0
ShowLabels=1
ShowUserLabel=0
[ATC]
AutoOpenAirTrafficWindow=1
COMM_MSG_AI_ATC_COLOR=FFFF7840
COMM_MSG_ATC_AI_COLOR=FF00FF00
COMM_MSG_ATC_USER_COLOR=FFB6FFB6
COMM_MSG_NONE_COLOR=FFFFFFFF
COMM_MSG_USER_ATC_COLOR=FFFFD21B
PilotVoice=0
ShowATCText=1
UsePilotVoice=0
[TextInfo.1]
AirSpeed=1,5
Altitude=1,3
Heading=1,4
Latitude=1,1
Longitude=1,2
WindDirectionAndSpeed=1,6
[AccelerationPack]
ControlsFirstRun=0
HomePageFirstRun=0
[iNTERNATIONAL]
ASLAT=2
ASLON=0
MEASURE=2
[CONTROLS]
Controls_Current=Standard
Controls_Default=Standard
KBDAIL=64
KBDELEV=64
KBDRUD=64
force_master_gain=10000
force_stick_force_enabled=1
force_stick_shaker_enabled=1
force_gear_bump_enabled=1
force_crash_enabled=1
force_ground_bumps_enabled=1
[FACILITIES]
CITY=Munich
COUNTRY=Germany
GTL_BUTTON=1501
STATE=Munich
[TextInfo.3]
AirSpeed=1,5
Altitude=1,3
FrameRate=2,1
FuelPercentage=2,4
GForce=2,3
Heading=1,4
Latitude=1,1
LockedFrameRate=2,2
Longitude=1,2
WindDirectionAndSpeed=1,6
[PointOfInterestSystem]
CycleSetting=0
[GRAPHICS]
AC_SELF_SHADOW=1
AIRCRAFT_REFLECTIONS=1
AIRCRAFT_SHADOWS=0
ALLOW_SHADER_30=1
COCKPIT_HIGH_LOD=1
EFFECTS_QUALITY=2
GROUND_SHADOWS=0
HIGHMEMFIX=1
IMAGE_QUALITY=0
LANDING_LIGHTS=1
NUM_LIGHTS=8
See_Self=1
TEXTURE_MAX_LOAD=1024
TEXTURE_QUALITY=3
Text_Scroll=1
D3D10=1
MultiSamplesPerPixel=4
SHADER_CACHE_PRIMED_10=1693500672
[TrafficManager]
AIRPORT_SCENERY_DENSITY=3
AirlineDensity=20
FreewayDensity=20
GADensity=20
IFROnly=0
LeisureBoatsDensity=40
ShipsAndFerriesDensity=40
[DynamicHeadMovement]
HeadMoveTimeConstant=1.000000
LonAccelOnHeadLon=-0.020000
LonAccelOnHeadPitch=-0.010000
MaxHeadAngle=5.000000
MaxHeadOffset=0.300000
RollAccelOnHeadLat=0.010000
RollAccelOnHeadRoll=0.100000
YawAccelOnHeadLat=-0.100000
[REALISM]
AllowEngineDamage=False
AutoCoord=True
AutoTrim=False
CrashDetection=False
CrashTolerance=0.000000
CrashWithDyn=False
GEffect=False
General=0.000000
GyroDrift=False
GyroEffect=0.000000
ManualLights=False
PFactor=0.000000
RealMixture=False
StressDamage=False
Torque=0.000000
TrueAirspeed=False
UnlimitedFuel=True
[Weather]
AdjustForMagVarInDialog=1
CLOUD_COVERAGE_DENSITY=8
CLOUD_DRAW_DISTANCE=3
DETAILED_CLOUDS=1
DisableTurbulence=0
DownloadWindsAloft=0
DynamicWeather=2
MaxGustRampSpeed=200
MaxGustTime=500
MaxVarRampSpeed=75
MaxVarTime=50
MinGustRampSpeed=1
MinGustTime=10
MinVarRampSpeed=10
MinVarTime=5
THERMAL_VISUALS=0
TurbulenceScale=1.000000
WeatherGraphDataInDialog=0
WeatherServerAddress=fs2k.zone.com
WeatherServerPort=80
WindshieldPrecipitationEffects=1
[Misc]
Com_Rate=7
[Main]
HideMenuFullscreen=1
HideMenuNormal=0
Location=1400,130,2440,908,\\.\DISPLAY1
Maximized=2
SimObjectPaths.0=SimObjects\Airplanes
SimObjectPaths.1=SimObjects\Rotorcraft
SimObjectPaths.2=SimObjects\GroundVehicles
SimObjectPaths.3=SimObjects\Boats
SimObjectPaths.4=SimObjects\Animals
SimObjectPaths.5=SimObjects\Misc
User Objects=Airplane, Helicopter
ProcSpeed=8735
PerfBucket=7
[Trusted]
C:\Program Files (x86)\IVAO\IvAp v2\ivap_fsx_bootstrap.dll.rnhtlruureqhrcnkunnzonwkaaobilkwciqrcztz=1
E:\Flight Simulator X\Aerosoft\Flight Recorder\AS-FlightRecorder.dll.ooqhuahricobbezkknwwzqiahueotiokoouokblt=1
E:\Flight Simulator X\FS2Crew2010\Versions\AerosoftAirbusX\Gauges\FS2CrewAirbusVoice.GAU.chilleozbhnnozbtkekeeoqhlhwknlwruzirllzq=2
E:\Flight Simulator X\GAUGES\../SimObjects/Airplanes/Aerosoft Airbus X Extended Base/Panel_Fallback/DLLs/AsInput.DLL.kzceeuhrbwchzhwutqocobtnaueqccoenoqtncoo=2
E:\Flight Simulator X\GAUGES\../SimObjects/Airplanes/Aerosoft Airbus X Extended Base/Panel_Fallback/DLLs/FBW.DLL.tzcuwbkeilntctqohhannuebuuqbtccbnnkktbzc=2
E:\Flight Simulator X\GAUGES\../SimObjects/Airplanes/Aerosoft Airbus X Extended Base/Panel_Fallback/DLLs/FMGS.DLL.tcnkrcertboleaatczawwqnlbnoozuhqkinunqia=2
E:\Flight Simulator X\GAUGES\../SimObjects/Airplanes/Aerosoft Airbus X Extended Base/Panel_Fallback/ND/AB_ND_GDI.DLL.uktwaiknkhlcnrcarqtneeblbweuccocoillbwoh=2
E:\Flight Simulator X\Modules\FSCopilot.dll.eeqozqacqqbzizhwokhruibawcwelclaikqnkocz=1
E:\Flight Simulator X\Modules\FSUIPC4.dll.ieknlorkhirwbqbtkhcqhtbbaaolablnownhuntq=1
E:\Flight Simulator X\PMDG\DLLs\PMDG_HUD_interface.dll.lqwiuooebulrzcbctweobickraqeeiilkhnewall=1
E:\Flight Simulator X\RAASPRO\RAASPRO.dll.qonnzbbwwenbiotqntnqrqtnatnntqnqwnitueoi=1
E:\Flight Simulator X\SimObjects\Airplanes\Aerosoft Airbus X A320 Extended CFM\panel\ASC.DLL.iwtqanqblzczalzrelekouhlcuqhrrzoclcnnwoo=2
E:\Flight Simulator X\VistaMare\ViMaCoreX.dll.ahoheitoulqnqltztnruurrqcnrlbcuhqnzuoacn=1
E:\Flight Simulator X\fsdreamteam\couatl\couatl.exe.nlzlzbhinbrwewnuikkuhizoizrrneznihtbibba=1
E:\Flight Simulator X\bglmanx.dll.qnqzcrhniwqiaarhwauzznahlhcbuzbkqeuhcchk=1
E:\Flight Simulator X\Aerosoft\Flight Recorder\AS-FlightRecorder.dll.wbhltqqhknetcelecuqoohrozruokkzukcztqazc=1
E:\Flight Simulator X\Modules\FSUIPC4.dll.hlqqqothtoqeqrtkechzqbouhelqkiqewwzuilwq=1
[TextInfo.2]
FrameRate=1,1
FuelPercentage=1,4
GForce=1,3
LockedFrameRate=1,2
[uSERINTERFACE]
Map_Orientation=0
OpenATCOnCreate=0
PAUSE_ON_LOST_FOCUS=0
PROMPT_ON_EXIT=1
PageID=1
SHOW_MISSION_CAPTIONS=0
SITUATION=FLIGHTS\OTHER\FLTSIM
SelectAircraftManufacturer=Alle
SelectAircraftPublisher=Aerosoft
SelectAircraftType=Alle
ShowAllACPaintSchemes=1
[sIM]
SYSCLOCK=1
[Display]
ActiveWindowTitleBackGroundColor=0,28,140,64
ActiveWindowTitleTextColor=255,255,255
BLOOM_EFFECTS=0
ChangeTime=4.000000
InfoBrakesEnable=True
InfoLowerLeftBackGroundColor=255,0,0,128
InfoLowerLeftTextColor=255,255,255
InfoLowerRightBackGroundColor=255,0,0,128
InfoLowerRightTextColor=255,255,255
InfoOverspeedEnable=True
InfoParkingBrakesEnable=True
InfoPauseEnable=True
InfoSlewEnable=True
InfoStallEnable=True
InfoUpperRightBackGroundColor=0,0,0,0
InfoUpperRightTextColor=255,0,0
NonActiveWindowTitleBackGroundColor=24,33,87,64
NonActiveWindowTitleTextColor=255,255,255
SKINNED_ANIMATIONS=1
TEXTURE_BANDWIDTH_MULT=40
TextureMaxLoad=30
TransitionTime=4.000000
UPPER_FRAMERATE_LIMIT=0
WideViewAspect=False
[JOBSCHEDULER]
AffinityMask=14
[slewTextInfo.3]
AirSpeed=1,5
Altitude=1,3
FrameRate=2,1
Heading=1,4
Latitude=1,1
LockedFrameRate=2,2
Longitude=1,2
[PANELS]
DEFAULT_VIEW=0
IMAGE_QUALITY=1
PANEL_MASKING=1
PANEL_OPACITY=100
PANEL_STRETCHING=1
QUICKTIPS=0
UNITS_OF_MEASURE=1
[sTARTUP]
DEMO=0
LoadWindow=1
SHOW_OPENING_SCREEN=1
STARTUP_DEMO=0
[slewTextInfo.2]
FrameRate=1,1
LockedFrameRate=1,2
[TERRAIN]
AUTOGEN_DENSITY=3
DETAIL_TEXTURE=1
LOD_RADIUS=4.500000
MESH_COMPLEXITY=75
MESH_RESOLUTION=20
SWAP_WAIT_TIMEOUT=2
TEXTURE_RESOLUTION=25
WATER_EFFECTS=4
[sCENERY]
DAWN_DUSK_SMOOTHING=1
IMAGE_COMPLEXITY=4
LENSFLARE=0
MAX_ASYNC_BATCHING_JOBS=3
SmallPartRejectRadius=4.0
[DISPLAY.Device.AMD Radeon HD 6900 Series.0.0]
AntiAlias=1
[MULTIPLAYER]
condAccoutPassword=0
VoiceVolume=-1.000000
 

 

Hope you have got a clue.

 

Cheers uhecht

Share this post


Link to post
Share on other sites

What I just found out a couple of minutes ago:

 

I put all ATI settings back to FSX managed. These settings I normally use on DX9. The improvement of fps has enhanced from 12 to 19 @Aerosoft Munich airport. Hope DX10 is not being affected.

Share this post


Link to post
Share on other sites

ok, here are your frame killers !

 

AirlineDensity=20

FreewayDensity=20

GADensity=20

LeisureBoatsDensity=40

ShipsAndFerriesDensity=40

 

waaay too much traffic ! lower these settings (I fly with AirlineDensity=10 and FreewayDensity=10 only to get good fps, nothing else (and my system is quite good)!

 

Also it´s good to let fsx rebuild a new stock fsx.cfg !

Share this post


Link to post
Share on other sites

ok, you are right. My mistake. After rebuilding a clean fsx.cfg I forgot to put the settings for AirlineDensity / ... back to zero.

 

Now I did another try. And it works for me so far!

I didn't toggle the shadow boxes inside the installer and it rocks. @ Aerosoft Munich Airport cockpit view about 20fps (Airbus EXE, REX Ess, FS2Crew, FSinn) // Outside 30fps Brilliant.

 

Will toggle shadows step by step to the point of dropping fps.

Share this post


Link to post
Share on other sites

I see you are slowly getting back on track already, but here's my reply anyway: you shouldn't have created a completely new cfg imho. On my PC I use the exact same cfg for both: I only use different profiles for my GPU (using nVidia Inspector but you have an ATI card so I don't know how things works with that one). You might want to see what happens if you reinstall your original cfg and then enable DX10 again with all the options using the Fixer.

 

BTW You say you used Bufferpools=0 but I don't see that in your cfg. (I do see you used bojote's tool... I would never ever do that but that's another story...). So try it with Bufferpools=0: that is the only real tweak I use and it makes a world of difference.

Share this post


Link to post
Share on other sites

Hi Jan,

 

after disabled shadows I have had (that's normal) problems when it got dark. So I re-enabled the shadows but configured the single shadows' sliders more to the left. And here we go: I have a really good balance in having fine fps during departure or even arrival of Mega airports and using DX10. So it works pretty good for me.

 

Steve: Sorry for that at the beginning. What an amazing tool! I have never seen FSX in such a good shape before. Perfect.

 

One issue remains but is not caused by the DX10 fixer. Aerosoft airport vehicles aren't displayed correctly. But that's another story.

 

All in all: Great job and it is worth every single cent.

Share this post


Link to post
Share on other sites

Please change the title of the thread. Without reading the replies, people will assume the fixer is bad.

  • Upvote 1

Share this post


Link to post
Share on other sites

Please change the title of the thread. Without reading the replies, people will assume the fixer is bad.

How does it work?

Share this post


Link to post
Share on other sites

You can't edit topit titles on this forum. You could ask a mod to do it though.

Share this post


Link to post
Share on other sites

Never mind, a quick read will soon show any doubters that the problem was  yours and not the Fixer.

 

(Only one s in disappointment by the way)

 

Regards,

Nick

Share this post


Link to post
Share on other sites

Hi uhecht,

 

I have an ATI 5870 card too and I could not get AA to work in DXT10. Everything else seems to be fine and it looks very good, but the missing AA is a show stopper for me and I went back to DX9 because of that.

 

Care to share how you managed to get AA to work?

 

Cheers

Nizar

Share this post


Link to post
Share on other sites

Also it´s good to let fsx rebuild a new stock fsx.cfg !

 

How do you do that?

 

I bought the Fixer yesterday and I'm still new and trying to learn the inner secrets of FSX :).

Share this post


Link to post
Share on other sites

Simply rename the existing one to something like fsx.cfg.old and restart FSX.

 

Regards,

Nick

  • Upvote 1

Share this post


Link to post
Share on other sites

Hhm, impossible to edit the title. Not such an option down the first article :-(

I edited your topic title.  If there's a problem, let me know.

 

Best regards,

Share this post


Link to post
Share on other sites

Hello,

I thought I give this dx10 fixer a try. After installing the libs I used 4xAA but I have no luck with AA . Normally the plane on the freeflight page is without any edges, so my planes and the world after loading a plane and scenery. With DX10 fixer switched to DX10 there def. no AA. Do some of you arehaving any idea?

Cheers and thnx Tom

Win7 64bit Nvidia Gtx 580, Driver 314.22

 

Ps. Is it possible to switch back to DX9 without deinstalling the libs?

Share this post


Link to post
Share on other sites

Hello,

I thought I give this dx10 fixer a try. After installing the libs I used 4xAA but I have no luck with AA . Normally the plane on the freeflight page is without any edges, so my planes and the world after loading a plane and scenery. With DX10 fixer switched to DX10 there def. no AA. Do some of you arehaving any idea?

Cheers and thnx Tom

Win7 64bit Nvidia Gtx 580, Driver 314.22

This thread should help: http://forum.avsim.net/topic/426219-proper-nvidia-inspector-settings-wiht-dx10-fixer/

 

It's normal to have the plane look jaggy with no aa in the aircraft preview, but it's not when you fire up the flight.

Share this post


Link to post
Share on other sites

Hello,

after following very carefully and precisely (in my POV) the above mentioned ToDo list the field GENERAL SHADER in DX10Fixer is greyed out and I cannot open the configuration. Does anybody knew if this is ok - or what to do?

Thnx and Cheers Tom

Share this post


Link to post
Share on other sites

Hello,

after following very carefully and precisely (in my POV) the above mentioned ToDo list the field GENERAL SHADER in DX10Fixer is greyed out and I cannot open the configuration. Does anybody knew if this is ok - or what to do?

Thnx and Cheers Tom

 

Found the reason by myself. I used the Shader Release 3.2.2. as mentioned in the todo list. But if I change the original Shader HSL in any way I cannot control it via DX10 Fixer. Now I ask myself what is better: 1. to control it via DX10Fixer or 2. to use the Shader Release 3.2.2. with there extras for light and water?

What is your opinion or experience.

Thnx and Cheers Tom

Share this post


Link to post
Share on other sites

Grab this, Tom, place it in the FSX root folder (where FSX.exe lives).. Delete your old ShadersHLSL folder completely and then unzip this one in its place. This is the stock folder. Do not forget to also delete the Shaders10 cache folder - which you will find at :-

 

"C:\Users\pj\AppData\Local\Microsoft\FSX\Shaders10 "

 

Any time you physically change anything in the ShadersHLSL folder - you must do this. OK!

 

All the Best,

 

pj

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this