Sign in to follow this  
Jari Junior

I paid but didnt received the 777 :T

Recommended Posts

I know its a duplicate post but it smy day off and I REALLY want to use the bird!
 

Hi. My paypal balance as been reduced but I got no e-mail and the product is not listed in my previous purchases history. Since I already send a e-mail and got no answer, i'm hoping you can read this.

 

thank you!

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I know its a duplicate post but it smy day off and I REALLY want to use the bird!

 

Hi. My paypal balance as been reduced but I got no e-mail and the product is not listed in my previous purchases history. Since I already send a e-mail and got no answer, i'm hoping you can read this.

 

thank you!

 

It may be your day off, but no need to purposely keep posting. Someone will get round to you eventually...

I believe In this case submitting a ticket is the answer....

 

 

Share this post


Link to post
Share on other sites

It may be your day off, but no need to purposely keep posting. Someone will get round to you eventually...

I believe In this case submitting a ticket is the answer....

 

 

 

sorry but when I posted I received the "service unavailable" message so unfortunately the post was duplicated :(

Share this post


Link to post
Share on other sites

sorry but when I posted I received the "service unavailable" message so unfortunately the post was duplicated :(

 

I may be looking through the wrong lens here but it seems to me you've been posting all day....with different messages, not just a case of repeatedly tapping "post".

Not that I want to be grumpy or anything...

Like I said, I think a ticket is what must be sent...

 

 

 

 

Share this post


Link to post
Share on other sites

 

 


Since I already send a e-mail and got no answer, i'm hoping you can read this.

 

support.precisionmanuals.com is the best bet to getting an answer.  Someone should be back to you relatively quickly.

Share this post


Link to post
Share on other sites

 

I may be looking through the wrong lens here but it seems to me you've been posting all day....with different messages, not just a case of repeatedly tapping "post".
 

Lie. I just posted 2 times, 1 here and 1 in 777 forum.

Share this post


Link to post
Share on other sites

Lie. I just posted 2 times, 1 here and 1 in 777 forum.

 

He was referring to the fact that you've intentionally posted the same request multiple times, instead of the forum error where things are accidentally being posted multiple times.

 

Intentional multiple posts:

http://forum.avsim.net/topic/429590-i-paid-but-didnt-received-the-777-t/

http://forum.avsim.net/topic/429568-purchase-problem-already-paid/

http://forum.avsim.net/topic/429574-purchase-error/

(these are not really appreciated - those who are trying to help may post in any one of the three, and if everyone is posting to a different thread it's hard to keep track which one everyone is using)

 

Unintentional internal server error posts:

http://forum.avsim.net/topic/429590-i-paid-but-didnt-received-the-777-t/

http://forum.avsim.net/topic/429592-i-paid-but-didnt-received-the-777-t/

(these are just a glitch in the system, though you can avoid them by not pressing back and resubmitting - the error is not saying the posts aren't submitting, btw :wink:, it's simply an error saying that the server is overloaded to send data back to you)

Share this post


Link to post
Share on other sites

He was referring to the fact that you've intentionally posted the same request multiple times

 

 

THATS WHAT I WANTED TO SAY! Yeah, no cares in your posts, sure! ^_^

Share this post


Link to post
Share on other sites

And of course just to add another idea.  Did you check your junk mail for the PMDG order confirmation message?  If its not there then go with Kyle's suggestion and contact PMDG support.

Share this post


Link to post
Share on other sites

Why am I not surprised ?

I am having the same issue. I purchased the pmdg777 via PayPal today.

I got the confirmation e-mail from PayPal and from pmdg.

 

When I click on the download link, I get the message that I am not permitted to view this order.

 

Ok I thought, maybe that's because I was not logged in to my pmdg account, while paying with PayPal.

So I logged in to my account at pmdg, which is llinked with a differnt e-mail than my PayPal e-mail, though.

 

But no matter what, the download link I got from pmdg is a dead link. I have no permission to view this order.

 

Now while writing this, I found out, PayPal causes problems when the PayPal Express Checkout was used for payment.

And that's exactly what I did. ....  :(

 

Ok, I already submitted a support ticket ...  Hopefully this is gonna be solved soon ...   ;)

 

http://support.precisionmanuals.com/News/35/continued-problems-with-paypal.aspx

Share this post


Link to post
Share on other sites

But I have to agree, that this is very much frustrating.

Buying a product and to not have it. And 90 bucks is a lot. It's probably worth it, but still it's a lot of money for at least a few of us.

You all remember how long we've been waiting for release, right ?

See, since release finally now I can afford buying the 777, and bang I am not able to use it because there are issues between PayPal and pmdg.

I am a patient person, but this is really a mess.

Re-thinking the payment methods is surely a win.

PMDG should remove the option paying with "PayPal Express Checkout" if its not working properly, and offer the PayPal standard payment option only, instead.

Or any other payment method than credit card or PayPal ...

 

Just my two cents ....  while still waiting.  :(

Share this post


Link to post
Share on other sites

I noticed recently on Aerosoft forums that they had some problems with PayPal as well. Perhaps its the holiday shopping season, PayPal can't keep up.

Share this post


Link to post
Share on other sites

Same problem- just bought the 737NGX, PayPal shows as paid, and the order shows as processed...but the download link doesn't work at all.  What the heck, guys...

Share this post


Link to post
Share on other sites

Same here too with the 777. I opened a ticket immediately, let's hope it gets solved quickly as I see it's not a standalone issue so I hope the team already has a standard workaround.

 

I wonder if it has been solved for you guys already?

 

Cheers,

Share this post


Link to post
Share on other sites

For anyone having the same issue: after submitting a ticket to PMDG support team, the issue was sorted out without any hassle within hours. Very nice support, indeed!

 

Cheers,

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this