Sign in to follow this  
sslazio 1900

Blurries, Low frames but with a good Hw... need help!

Recommended Posts

Hi guys, i'm wirting after 1 yeay with my PC, following various guides like Word Not Allowed's, Fsx settings demistified, or the Avsim one. With any kind of settings i obtain the same result flying my NGX: low fps on ground (complex addon sceneries) and blurry scenery while cruising.

 

My hW:

- i7 3770k @ 4.5GHz

- GTX 660Ti

- FSX on a Samsung 840Pro SSD

- RAM 8gb DDR3 1600MHz

 

My actual settings FSX.cfg can be found below.

 

It's frustrating to fly in this conditions. Always on ground in scenery like Olbia X, Bergamo X or Dublin X i get FPS NEVER greater than 25.

The strange thing is my GPU, that works alway around 20%. I think if i get an harder work on the gpu i can get enough from my HW.

 

 

Thanks a lot to anyone can and wants help me :D

[BUFFERPOOLS]
Poolsize=0 
Usepools=0


[JOBSCHEDULER]
AffinityMask=84

...

[GRAPHICS]
HIGHMEMFIX=1
D3D10=1
TEXTURE_MAX_LOAD=1024
NUM_LIGHTS=8
AIRCRAFT_SHADOWS=1
AIRCRAFT_REFLECTIONS=1
COCKPIT_HIGH_LOD=1
LANDING_LIGHTS=1
AC_SELF_SHADOW=0
EFFECTS_QUALITY=2
GROUND_SHADOWS=0
TEXTURE_QUALITY=3
ForceWindowedVsync=1

[Display]
InfoOverspeedEnable=True
BLOOM_EFFECTS=0
MAX_TEXTURE_DATA=770
TEXTURE_BANDWIDTH_MULT=40
UPPER_FRAMERATE_LIMIT=30
WideViewAspect=True

...

[Main]
FIBER_FRAME_TIME_FRACTION=0.22
...


[SCENERY]
LENSFLARE=1
DAWN_DUSK_SMOOTHING=1
IMAGE_COMPLEXITY=5

[TrafficManager]
AirlineDensity=0
GADensity=0
FreewayDensity=0
ShipsAndFerriesDensity=12
LeisureBoatsDensity=8
IFROnly=0
AIRPORT_SCENERY_DENSITY=0


[TERRAIN]
LOD_RADIUS=6.500000
MESH_COMPLEXITY=82
MESH_RESOLUTION=24
TEXTURE_RESOLUTION=28
AUTOGEN_DENSITY=3
DETAIL_TEXTURE=1
WATER_EFFECTS=4
TERRAIN_MAX_AUTOGEN_TREES_PER_CELL=1376
TERRAIN_MAX_AUTOGEN_BUILDINGS_PER_CELL=907

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I would try these things:

 

- Turn off HT, and make affinity mask 14 instead of 84. I don't think HT helps FSX because the virtual cores eat up cycles on the actual cores.

 

- Remove Fiber frame time fraction. All this does is limit the amount of time FSX is given to load scenery and will cause more blurries/popping autogen.

 

- LOD back to 4.5. The more resources the system gives to loading scenery the less it can give to texture loading. Remember that the perimeter of a 6 mile circle is much longer than that of a 4 mile circle, so FSX is forced to load more autogen at once.  

 

- You might also want to think about changing Max Texture Data and Texture Bandwidth Multi to stock. If these are not optimized for your system, it can slow down texture loading. Better to figure out the problem, then reintroduce these tweaks one at a time. 

Share this post


Link to post
Share on other sites

First of all: thanks a lot for your posts.

 

Replying step by step:

 

I would try these things:

 

- Turn off HT, and make affinity mask 14 instead of 84. I don't think HT helps FSX because the virtual cores eat up cycles on the actual cores.

 

- Remove Fiber frame time fraction. All this does is limit the amount of time FSX is given to load scenery and will cause more blurries/popping autogen.

 

- LOD back to 4.5. The more resources the system gives to loading scenery the less it can give to texture loading. Remember that the perimeter of a 6 mile circle is much longer than that of a 4 mile circle, so FSX is forced to load more autogen at once.  

 

- You might also want to think about changing Max Texture Data and Texture Bandwidth Multi to stock. If these are not optimized for your system, it can slow down texture loading. Better to figure out the problem, then reintroduce these tweaks one at a time. 

 

You're right, but i think using these setting is a downgrade on the quality of my system, due to the high end hardware i bought.

 

- LOD back to 4.5 is very frustrating while flying at high levels. Yuo will fly in a clear range of 4.5nm sharply visibile in front of you. That's the reason while I'd choose to take 6.5.

- HT off and affinity 14: i will try. Initially, when i bought my PC, it was my setting, then rolled back to HT On when i get X-Plane10 for flying VFR with General Aviation. XP is a great software, written much better than FSX or P3D, and takes great andvantage of my i7's 8 logical cores.

- FFTF: removing this section gives me a default FFTF value of 0.33. Since last week this is my setting. The scenery is good with 0.33 but my frames are not good enough while on ground or on final, then i tried to lower FFTF value, obviously FPS are risen but the scenery comes more blurried than before.

- MTD and TBM are calculated by FSX Texture Calculator tool, and cross-checked manually following a famous thread of another forum "FSX Settings Demistified".

 

So: for shure FFTF 0.33 gives me a better scenery view lowering a little bit my FPS. My target is to get 29/30FPS in NGS's VC and a good scenery at high levels (i'm writting a good scenery, not asking about perfection). Looking to my HW i think is reasonable.

 

This evening I'll try to get back FFTF 0.33 and to disable my HT. About LOD i will not get it back 4.5, it's too low. About MTD and TBM: where i can calculate with more precision its values?

 

What are your nvidia inspector settings?

 

Sorry, i fogot to post.

 

I currently have my FSX's Inspector Profile setup as follows:

AA 4xS

AnisotropicFiltering  4x or 8x (now i don't remember... i'm at work :) )

Vsync 1/2

Share this post


Link to post
Share on other sites

Are you using Nvidea Inspector?  I just updated my rig and had to make some tweaks in it to get my sim straightened out. 

Share this post


Link to post
Share on other sites

Ok guy, these are my Inspector Settings. I'm obviously running in DX10 mode with DX10 Fixer v2 and on the fixer I have AA set to 4x

 

il37.jpg

Share this post


Link to post
Share on other sites

  • If you're running hyperthreading your affinity mask should be 254 using 7 cores...if HT is off then use 14. 84 means you're running FSX on three hyperthreaded cores...not good.  (I run hyperthreaded 254 myself.)

I'd turn water effects down and ships and ferries off and see what the affect is.  Those things come with a heavy toll. 

Looks like you've got AA off in both FSX and in NI?  I don't run the DX10 fixer...maybe that's how it's supposed to be?

SGSS is pretty heavy on my system, though it keeps the lines looking sharp. 

What's your screen resolution? 

You're only running one FSX view, right?  E.g. you don't have a tower view and a cockpit view at the same time?  Also, you don't have any undocked windows, right?

Share this post


Link to post
Share on other sites

 

  • If you're running hyperthreading your affinity mask should be 254 using 7 cores...if HT is off then use 14. 84 means you're running FSX on three hyperthreaded cores...not good.  (I run hyperthreaded 254 myself.)
  • I'd turn water effects down and ships and ferries off and see what the affect is.  Those things come with a heavy toll. 
  • Looks like you've got AA off in both FSX and in NI?  I don't run the DX10 fixer...maybe that's how it's supposed to be?
  • SGSS is pretty heavy on my system, though it keeps the lines looking sharp. 
  • What's your screen resolution? 
  • You're only running one FSX view, right?  E.g. you don't have a tower view and a cockpit view at the same time?  Also, you don't have any undocked windows, right?

 

  1. I will try... but i remember 254 is a setting i'd tried weeks ago with no gain. My target might be to use only 3 of the 4 physical cores, leaving Core 0 to the OS, Weather and so on.
  2. Whater effects are now set to the minimum to have a good water apparance. I wuold try to not set a lower value.
  3. I don't have AA on FSX and NI because using DX10 scenery fixer seem are not working. This tool provides itself an AA setting, and seems to be good ;)
  4. SSGS is expensive, but is work for the GPU and its work load seems weak.
  5. 1680x1050 (max for my monitor)
  6. No undocked windows, only the main one, in windowed mode, flying always in VC. Looking for max reality i don't like external views and any undocked win ;)

Share this post


Link to post
Share on other sites

 

 


I will try... but i remember 254 is a setting i'd tried weeks ago with no gain. My target might be to use only 3 of the 4 physical cores, leaving Core 0 to the OS, Weather and so on.

 

If you're hyperthreading then, with 8 virtual cores you are only running on three leaving 5 for other cores (84 is equivalent to  01010100).  Your system is better than my old one (but I had my water and boat settings lower) and mine was performing better.  254 (e.g. 11111110) helped a lot.  As I mentioned, if you turn hyperthreading off then you need to set affinity mask to 14 (e.g. 1110) to run on three threads.  Still, even with that change, there's something else going on.  Your machine should be doing better.

Share this post


Link to post
Share on other sites

660 Ti is not going to be great pushing 8x SGSS .....way too much for that card

Share this post


Link to post
Share on other sites

Hi guy! During last week end i've done some tests about my tweaks. Results are GPU working at about 40% with peaks at 60/70%, FPS increased to 35/37 in Mega Airports.

 

What kind of tweaks?

- Updated Steve FX DX10 Scenery Fixer to V2

- Removed Max Texture Data

- Texture Max Load to 1024 (seems ok, sharp texture with a proper and balanced workload)

- Water Effects to 5 (yes, increased... my REX4 water needs to be awesome)

- FPS from 30 Limited to Unlimited

- Inspector AA moved back to 3x3

 

Now, next days will follow some flights with NGX, but from tests done during last two days seems to be aq good config.

Share this post


Link to post
Share on other sites

Hello everyone,

 

My rig is comprised of (CPU & GPU) i7 4770K (4.2 GHz) & GTX 760 - and from what I could get my bottleneck is the CPU, right? No matter what setting I apply to the GPU (nVidia Control Panel), either all maxed out or at minimums the frame rate is still the same. Funny thing is that I can't even notice a change in quality of the graphics/textures within FSX, considering that I'm using internal Anti Aliasing + Anisotropic Filtering and DX10.

 

What are your thoughts?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this