Jump to content

Archived

This topic is now archived and is closed to further replies.

Sesquashtoo

My HyperThread Affinity Mask setting:

Recommended Posts

I think what was a large part of my success to bring P3D to great performance results this morning, was adding the following to my P3D.cfg file:

 

[JOBSCHEDULER]
AffinityMask=84
 
This setting would open up all 8 virtual cores in HyperThread mode to use by P3D.  This was one of my main weapons to bring FSX up to fabulous output. So, if you are running in HyperThread mode, or would wish to check that mode out...you do need this tweak. Put this at the top of your P3D.cfg file (but only if you are in hyperthread (8 virtual core) mode.))

I wanted to add on my custom.nip N.I. settings to this post, as a zip file. How do you do that?

Share this post


Link to post

I'm confused, as usual. Decimal 84 is 01010100 in binary. To me, that means only 3 cores are being used. I've been using 85 (01010101), probably incorrectly since others have said that Core 0 should be reserved for the operating system.

 

Frans

Share this post


Link to post

This has worked very well for me in FSX and now as well as P3D since early this morning...stellar in fact!

Share this post


Link to post

I'm confused, as usual. Decimal 84 is 01010100 in binary. To me, that means only 3 cores are being used. I've been using 85 (01010101), probably incorrectly since others have said that Core 0 should be reserved for the operating system.

 

I'm also using 85 on 4 cores and 8 threads. Then it shows in taskmanager that every second (1,3,5,7 or 2,4,6,8 dont remember) thread is working.


i9 9900k - 32 gb RAM @ 3200mhz - 2070 RTX 8gb

Share this post


Link to post

On my now "old" computer, 85 worked better than 84. As to enabling *all* cores, both the prime and virtual cores are used when the prime cores are enabled, as I understand it.

 

Frans

Share this post


Link to post

For my 4770K, I found that the best setting is AffinityMask=242. This reduces both blurries and stutters to a minimum for me, and was what Beau at LM suggested using in this LINK. Here is his explanation:

 

A few other observations we have made in our testing:

- For some processors core 0 is clocked a bit higher. There isn't actually a dedicated windows core. Windows and other windows applications may schedule work on any core at any time. The OS does however try to load balance work, so if you leave a core open, it is much more likely to schedule work on that core. I don't think it considers a core open unless both HT cores are open. This is why masking off an entire core tends to help with stutters. We haven't done a lot of testing to back this up, but some initial findings suggest that you can leave open whichever core you choose. It might be better to use the first core and leave open a different core:

eg for a quad core with hyper threading try: 241/242 ( 11110001 / 11110010 ) or 61/62( 00111101 / 00111110 ).

We also noticed that the AMD Phenom processor doesn't like having any cores masked off as anything but using all cores caused odd stutters which seemed to be related to hardware and OS rather than simply having one less core to play with.

Beau Hollis

Rendering System Lead - Prepar3D® Team

I'm running with Orbx's PNW (plus FTX Global, Vector, and FS 2010 global mesh) and Active Sky Next.


~ Arwen ~

 

Home Airfield: KHIE

Flight section of my Website

Share this post


Link to post

Well for me 85 seems to work best with a 4770K and HT enabled. This was also the default in P3D 1.4 without tweaks.

 

This allocates all physical cores for the sim. Using all virtual+physical cores introduces stutters for me, but using less than 4 cores causes blurries, especially over OrbX scenery.


Asus Prime X370-Pro / Ryzen 7 1800X / 16 GB DDR4 3200 MHz / Asus GTX 1070 Turbo
Fractal Design XL R2 / Phanteks PH-TC14PE / Corsair CX650M
2 TB SSD / 4 TB HDD

Share this post


Link to post

I found 242 to be the best on an i7 4770k also. 85 is nearly as good for me; 84 and 255/254 introduce more stutters. I think this is one setting that really does depend on your system, and requires experimentation (there have been many threads on this topic). However, many people are reporting best results by enabling at least one virtual core per physical core: the old advice to leave one physical core free doesn't seem to be so applicable in the latest version.

Share this post


Link to post
×
×
  • Create New...