Sign in to follow this  
flying engineer

Windows 7 Pro 64 default beep on shutdown

Recommended Posts

Getting the Windows 7 Pro 64 default beep when shutting down FSX since installing MCE version 2.6.0.6

Reinstall does not stop the problem.

MCE also not responding anywhere near as expected on attempts to talk to ATC with USB headphone/mic setup.

Have had this poor ATC problem since 2011.

Have asked for help through e-mail to FS++ but no reply yet.

Edwin Brown Keremeos BC Canada

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Anyone else getting the Windows alarm sound on shutdown?

Haven't been able to find out what is causing his since installing v 2.6.0.6.

Share this post


Link to post
Share on other sites

Edwin, what settings have you selected in the MCE options?  have you got Optimisations ticked?  anything else you can share?

Share this post


Link to post
Share on other sites

this could be somthing very simple, in your sound setting
from the sound schema drop menu; select windows default and apply
 

Windows_7_No_Sound.png

Share this post


Link to post
Share on other sites

I fly single engine aircraft and don't want a copilot.

 

Here is what I have checked off in the tabs:

   General Tab --- Talk to ATC controllers

   ATC Tab --- use btn1: ch flight sim yoke USB 

   Options Tab --- Enable optimization & More responsiveness

   Other Option Panel --- Show Commands in FS

 

The error I'm getting on shutting down FSX is;

   Microsoft Visual C++ Runtime Library

   Runtime Error!

   Program: F\Microsoft Flight Simulator X\fsx.exe

   R6025

   pure virtual function call

 

The Event Viewer data seems to point to a problem in the FSX panels.dll which I don't understand at all.

 

All this is much beyond my limited computer knowledge.

 

Thanks for the interest.

Share this post


Link to post
Share on other sites

 

 


The Event Viewer data seems to point to a problem in the FSX panels.dll which I don't understand at all.

All this is much beyond my limited computer knowledge

 

This suggests FSX isn't closing down properly as a result of some add-on not releasing resources properly.

 

You can rule out MCE as follows...

 

Go to FSX installation folder and rename "fsInsider.dll" to "disabled-fsInsider.dll".

 

Next time you run FSX, not a single fsInsider.dll line of code will run inside the sim. You won't be able to run MCE though.

 

If you still have the issue, it's someone else's problem (look at every add-on you have installed).

Share this post


Link to post
Share on other sites

Went into the FSX installation folder and renamed "fsInsider.dll" to "disabled-fsInsider.dll" as suggested.

Started FSX and set up options to run as prior to MCE installation.

Brought in Active Sky Next for real weather.

Flew the FSX Cessna Skyhawk from Kingman (KIGM) to Laughlin, Bullhead Int'l (KIFP).

All ATC worked as it should with all text coming up and audio through the USB headphone.

Parked at the assigned spot and shut the Skyhawk down to cold & dark.

Saved the KIFP spot as default for next start up.

Shut down FSX as I normally do using the "End Flight" option, checked the log book and then "X" out of FSX.

No error popup this time ??

Shut down Active Sky Next as usual.

 

Now see that the "disabled-fsInsider.dll" has disappeared and am wondering what to do now?


My bad --- the "disabled-fsInsider.dll" has not disappeared. Got moved in the folder of course!!!

Share this post


Link to post
Share on other sites

Went into the FSX installation folder and renamed "fsInsider.dll" to "disabled-fsInsider.dll" as suggested.

Started FSX and set up options to run as prior to MCE installation.

Brought in Active Sky Next for real weather.

Flew the FSX Cessna Skyhawk from Kingman (KIGM) to Laughlin, Bullhead Int'l (KIFP).

All ATC worked as it should with all text coming up and audio through the USB headphone.

Parked at the assigned spot and shut the Skyhawk down to cold & dark.

Saved the KIFP spot as default for next start up.

Shut down FSX as I normally do using the "End Flight" option, checked the log book and then "X" out of FSX.

No error popup this time ??

Shut down Active Sky Next as usual.

 

Now see that the "disabled-fsInsider.dll" has disappeared and am wondering what to do now?

My bad --- the "disabled-fsInsider.dll" has not disappeared. Got moved in the folder of course!!!

 

Thanks

 

Check fsInsider.dll version in FSX folder. Should be V2.6.0.6

 

A while back, in one of the updates, fInsider.dll caused that sort of behaviour on exit, which was reported and fixed around 2.5.x.x.

 

If using V2.6.0.6 I suggest you persevere with a few more tests with fsInsider.dll disabled.

 

To all forum members....

 

Anyone else having that message on FSX exit using fsInsider.dll V2.6.0.6?

Share this post


Link to post
Share on other sites

MCE license was renewed April 16 2014 in an attempt to fix other problems.

MCE V2.6.0.6 install date shows 6/5/2014.

fsInsider.dll properties shows version 2.6.0.6 dated 6/5/2014.

 

Tried my favorite Quest Kodiak on identical flight from KIGM to KIFP and had no error popup on shutdown.

 

Will make a few more flights with fsInsider.dll disabled.

Share this post


Link to post
Share on other sites

Made a number of flights with several default FSX aircraft and fsInsider disabled.

No errors on shutdown of FSX.

 

Today I enabled the fsInsider and got the Windows error beep on shutdown of FSX.

Just the beep --- no other error popup window.

Also had the very same poor ATC voice connection as before.

 

Part of the event viewer data description shows:

"faulting application name: fsx.exe, version: 10.0.61637.0, time stamp: 0x46fadb14"

"faulting module name: panels.dll, version: 10.0.61637.0, time stamp: 0x46fadb50"

 

I have no idea what this means but obviously I have a problem when trying to use MCE.

 

Not sure what to now?

Should I e-mail FS++ with the event viewer data as an attachment? (Don't know how to copy and paste here).

Share this post


Link to post
Share on other sites

Thanks for the heads up.

I used to be on the MCE e-mail notification some time ago but maybe they have stopped this practice.

Downloading now.

Share this post


Link to post
Share on other sites

Believe I have found the reason for the shutdown error message etc.

Active Sky Next has an option to install their X Gauge and I had elected to install this on ALL the FSX aircraft.

As soon as I uninstalled these through the ASN options panel I got no more shutdown errors.

 

ASN must have gone into the panels.dll and made the changes that caused the problem as far as I can tell.

 

Thanks to all and specially the FS++ Support Crew.

 

Edwin Brown Keremeos BC Canada

Share this post


Link to post
Share on other sites

Sorry to report that the same error beep is back and I have no idea why?

Went through the Active Sky Next x-gauge uninstall again but no luck this time.

No error shows if I don't start/use MCE?

Event viewer data same as before -- fsx.exe & panels.dll.

No big deal but it means something is not right and I'd like to find out what it is.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this