Sign in to follow this  
danieirch

P3D V2 not seeing Nvidia GPU

Recommended Posts

Hello, boys and girls! I have P3D V2 and have done for quite some time. I had it on my desktop, but now that it is sold, i have installed it on my brand new laptop. 

This is no slouch, MSI GS70 Stealth Pro with an i7 4700hq, 16GB RAM and a GTX 870m 3GB. FSX sees the Nvidia GPU clear as day, however P3D will only see the Intel Integrated graphics!

Here is a picture to illustrate my point:

Argh_zpsc54c4cd6.jpg

I want to go with P3D full time as FSX is not the most stable program out there, and P3D works for me consistently well. Any suggestions?

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

You have to assign P3D to use the nvidia gpu instead of the on-board gpu.

    - Open the nvidia control panel.
    - Under Manage 3D settings/Global settings/ select the nvidia gpu as the default. All programs will use the nvidia gpu.
That should do it.

You could also select P3d to use the nvidia gpu by selecting P3D under the Program settings tab. If P3D isn't shown on the list, click the Add button, and point it to the P3D.exe in your install folder. Then selecting the nvidia gpu.

 

  Hope that helps.

regards, Jazz

Share this post


Link to post

Won't work ^

 

He has same laptop as me, in that it is running with an intel onboard card, and the nvidia card runs THROUGH this card. Ie you cannot disable the intel onboard card..

 

This method you mentioned doesn't work in p3d for these set-ups using nvidia the awful Optimus software, which you are locked into and cannot disabled

 

Some games will recognise the nvidia card, others, like p3d will not. And while your nvidia card will be running, the application thinks it's running on a very limited intel card. Therefore you get the artefacts and flashing screens that plague all laptop users with this setup..

 

Many many threads on lockheeds forums about this..

 

Here's a test: run Dxdiag and see what it shows in there..

Share this post


Link to post

Wow... for the price you paid for that laptop, I'd expect better.

Share this post


Link to post

My apologies, I wasn't aware, of this. Truthfully, I use P3D on my desktop, not my laptop. :blush: Thanx for the clarification.

 

  regards, Jazz.

Share this post


Link to post

Nah, no problem, it's an absolute joke that such powerful laptops can't run p3d.

 

And it's not that they can't run it- as games like crysis etc can run fine on it, and most importantly show the nvidia card in the graphics settings in game.

 

But unfortunately, some apps, like p3d, for some strange reason, only ever see the HD3/4000, and even though the nvidia is being utilised, the program thinks it's using the much poorer intel card.

 

This seems to be reflected in Dxdiag with dx10, at least in my system anyway.

 

And so while it is an issue with our laptops, it's either due to a non-profile provided for p3d from nvidia, or there's some sort of issue with o3d, in which it checks the card with dx11, and is told there's only a intel card.

 

I've raised it with Les on the Lockheed forums, and he believes that there is nothing else they can do with the program to fix it.

 

I managed a kind of workaround (search ptgar1 on their forums), by using much older drivers, and doing some weird combo of installs..

Share this post


Link to post

You can force the laptop to use the graphics card by using the control panel. However setting the global default doensn't work. You have to set it up per game, or right-click the EXE and select the graphics processor you want to use.

Share this post


Link to post

Doesn't work for the majority of people with these affected laptops, in P3D.

 

Gets very, very frustrating when we keep getting told to do that, but clearly it doesn't work.

 

No ones fault, just frustrating that no one has a solution beyond this "fix", which doesn't work for us.

Share this post


Link to post

Hey guys! I've forced the P3D to run on the 870m through the nvidia control panel and it now works perfectly! Much better frames than my old FX8350 PC! I do have one little issue now though... Every time i fly in Airbus X (I am in training to fly the A320's in real life), the sim freezes after a while. The sound works fine, even when switching views, it just baffles me! I will create a separate thread for that though... Thanks for all your help!

Share this post


Link to post

Hey guys! I've forced the P3D to run on the 870m through the nvidia control panel and it now works perfectly! Much better frames than my old FX8350 PC! I do have one little issue now though... Every time i fly in Airbus X (I am in training to fly the A320's in real life), the sim freezes after a while. The sound works fine, even when switching views, it just baffles me! I will create a separate thread for that though... Thanks for all your help!

 

How???

Share this post


Link to post

I just selected "high performance NVIDIA processor from the drop down box under the P3D settings in Nvidia control panel... Works a treat!

Untitled_zps8d305647.jpg

Share this post


Link to post

Right-click on Prepar3d and click 'Run with Graphic Processor' and then 'Change default Graphics processor' and you will be on the NVIDIA Control Panel

Share this post


Link to post

This post is over 3 years old brother!  I’m sure the OP has moved on by now!!

😀😎

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this