Sign in to follow this  
rufowler

EZdok not saving certain settings on exit

Recommended Posts

I've been using EZdok for a few days now, have read through the manual, have figuring out how to set it up, and I think I have the basics down.  Almost everything runs very well except for two things that have been driving me crazy!

 

Certain settings don't save after I shut down & restart FSX.  Specifically, it's not saving the DHM settings in any of the cameras (the button remains selected/highlighted for a specific view, but the dials all revert to zero).  And the cockpit walls are not saving either; the little "L" icon becomes deselected and all of the previously saved parameters are gone, so after a restart, my head wanders outside of the plane when I look around.  What is going on?   :(

 

Couple of things to keep in mind:

  • I'm using version 1.16 of EZdok, the one offered on their download page, but not 1.17 which seems like it never left the beta stage and which I've read has caused a lot of problems for some users.  But perhaps the fix I'm looking for is in the newer version?
  • I'm running Windows 8.1 / 64-bit.  And as per the suggestions of a few other folks in the forums, I'm running the EZCA.exe and the config.exe as an Administrator and also in Windows 7 compatibility mode (both via the files' Properties > Compatibility tab).  That didn't seem to help though.
  • I have a registered version of FSUIPC; no buttons are conflicting with that nor with the default FS controls, including the joystick's hat switch which only EZdoc handles.  (Not really sure if that matters though.)
  • I've added all executable FSX and EZCA files to the exceptions list in my Norton antivirus.
  • The DHM camera & cockpit walls only not saving for the few Carenado GA I use, but they are working in all the default FSX planes.  The settings I'm using are basically the exact ones I imported from similar default planes that EZdok already had cameras for; again, they do work when I initially import & tweak them, but not after I exit.
 

Any suggestions?  Thanks in advance.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Maybe try exporting the perimeters and re import them....maybe it budges. Mine save pretty good. Also there is a 1.17 try to update

Share this post


Link to post
Share on other sites

Maybe try exporting the perimeters and re import them....maybe it budges. Mine save pretty good. Also there is a 1.17 try to update

 

Well I already exported them from the default aricraft and imported them to the newer aircraft, tweaked them, and saved them (which I supposed it automatically does anyway).  But just the DHM & walls won't save from one restart to another.  Do you mean tweak, export/save as separate files for that plane, then re-import?  I will try that.  Does it matter where I put the exported settings?  There are a couple of EZCA folders it created on install, but I'm assuming it doesn't matter where I put exported files. (Honestly, I'm a day confused about where its database is and what files is uses to determine the settings.)

 

Also just curious.  Are you running Window 8 / 64-bit?  (From you're PC specs, it looks like no.)  Apparently this is a combo that lots of folks have had problems with trying to run EZdok.  :-/

Share this post


Link to post
Share on other sites

I'm running 1.17 and Window 8 on my laptop. Works fine 85% of the time. I reboot the laptop to once to make Ezdok work that 15%.

Share this post


Link to post
Share on other sites

I'm running 1.17 and Window 8 on my laptop. Works fine 85% of the time. I reboot the laptop to once to make Ezdok work that 15%.

 

And you're running 64-bit version of Windows 8?  Threads like this one -- and believe me, there are a lot of similar ones -- make me apprehensive.

 

Also, when you say, it doens't work 15% of the time, do you mean it simply doesn't appear in the FSX menu (& I'm guessing is disabled), or does it do something else weird?

Share this post


Link to post
Share on other sites

Yup, 64 bit win8.

 

It does something weird. Mainly camera view change buttons don't work or they work but I get only 3rd person skeleton view of plane.

Share this post


Link to post
Share on other sites

I get that too, though a little less often -- maybe one in 10 times -- and as with you, it seems that restarting it corrects things.  Weird.

 

But this saved settings things is driving me insane.  I'm going to uninstall it, reboot, and reinstall just for the hell of it.  Though I can't imagine it got "broken" by anything I did or installed since.  If anyone has any idea, please let me know.  At this point I'm considering giving it up for something else.  I hear Opus is a competitor, though not as good.  UUgh. :-/

Share this post


Link to post
Share on other sites
Well after spending way too many hours trying to figure this out, and after resisting the urge to get 1.17 because of the many issues people seem to have running it with Win 8 / 64-bit, I went ahead an installed the newest (beat?) version.  Happily, it cleared this issue up right away.

 

Unfortunately, I'm having problems with zooming and with using the mouselook feature, but that's a problem for another post.

Share this post


Link to post
Share on other sites

Cool.  Thanks, Stofvel.  I'm glad you got it fixed! ... I sure would have felt bad since I was the one who basically talked you into getting it!  ;)  Looking at your other post now.  Cheers.

Share this post


Link to post
Share on other sites

Hello rufowler,

 

As I mentioned in another post some time ago regarding the Spitfire, I now have another fave (aside from the Phenom) and a short video to prove it. I acquired the RealAir Spitfire Mk IX and XIV - 2008. An incredible plane to fly and I used EZdok Worldview for some of the incorporated shots. Thanks for the heads-up.

 

Enjoy

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this