Jump to content

Sign in to follow this  
TheFiddler

EZCA (EZdok) no longer loading after installing add-on plane

Recommended Posts

Hello All,

 

I have used the splendid EZCA a.k.a. EZdok (v.1.1.7.0) for a long time now, and cannot imagine flying in FSX without it.

Unfortunately, precisely that seems now to be the prospect. :unsure:

 

So far, never a problem, and EZCA has worked just fine for all aircraft and with all setups I created.

 

Yesterday, I installed a new add-on plane (the Aerosoft DA20 Katana). I then conducted a first short test flight, using EZCA (and even creating a new EZCA profile for this plane), and all still was perfectly OK.

 

Later I discovered various issues with the DA20 (it turned out that the installer did not do its job properly).

These are now more or less fixed, but at some point I discovered that EZCA was actually no longer loading when FSX started.

This makes FSX in effect unusable for me, as no plane can be controlled any more unless I re-assign all joystick input etc. directly in FSX again -- which I don't want to do, I'd prefer to stick with EZCA.

 

Some details:

  • exe.xml checked; the EZCA entry there is still OK (compared with known good backup copies);
    file validated as well-formed XML.
  • dll.xml also checked and found OK (just in case; I don't think it is really relevant here)
  • fsx.cfg entry for EZCA in the [Trusted] section was the same as before, when everything was still OK:
    Now I changed it minimally, so that I am currently prompted each time on FSX start if it is OK to run EZCA (to make sure that FSX at least tries).
    I then give permission, but refuse permanent Trusted status (so that I am prompted again next time.)
  • It seems clear that EZCA really does not load at all: Not only is the FSX Add-ons Menu entry missing, but there is also no EZCA icon in the taskbar (Windows 7), nor can ezca.exe (which has admin privileges) be found anywhere in Process Explorer.
  • I have of course searched this forum (and others) for info, and have seen references to SimConnect issues.
    However, that is something I really don't want to touch:
     -- Firstly, I really don't think it is the issue here (it would perhaps be if EZCA were loaded and then didn't
         work
    , but apparently it does not even start.)
    -- Secondly, messing with SimConnect seems quite dangerous, so I would first have to see a different proof
        that it really doesn't work before I even consider fiddling with it...
  • For similar reasons, I would not consider re-installation of FSX, SP1, SP2, or indeed Windows 7... :o
  • Re-installing EZCA might be an option, but can it be done without running into "activation counter" issues and such?
    (I do have a backup of the F1 Installer as downloaded, not just the unpacked installer; and I haven't installed it more than once so far. But still...)

As said, without EZCA, FSX is practically dead for me, so all ideas and tips would be greatly appreciated.

Thanks in advance!

 

Cheers,

Martin

Share this post


Link to post
Share on other sites

Did you rerun the config utility after you added the new aircraft?

Yes I did, and then checked that an EZCA camera definition ("Title=EZdok Aircraft Universal camera") had indeed been added to the aircraft.cfg of the plane.

But could that utility (or failure to use it) do anything else at all which might go so wrong that EZCA doesn't even load?

 

Thanks for the reply!

 

Cheers,

Martin

Share this post


Link to post
Share on other sites

I'm sorry, I don't know about that. All I know is that I had a similar problem, which was solved by rerunning the configuration utility (as it's described in the manual, so it was my own mistake).

 

Sorry I can't help you further. :(

Share this post


Link to post
Share on other sites
Sorry I can't help you further.

Thanks anyway, I do appreciate the will to help! :smile:

 

From what I have read, I could understand that EZCA does not work with a specific aircraft (probably due to forgetting to run the config tool indeed), or even that EZCA is missing from the add-on menu.

 

But what stumps me is that even though FSX prompts me for, and gets permission to run it (which proves exe.dll is also OK), it is then actually not even loaded.

 

Cheers,

Martin

Share this post


Link to post
Share on other sites

My EZDOK isn't even thinking about loading up with FSX at all.
Here's how i still use it:

1. Start FSX

2. Load bird and set location

3. "Fly now" and wait for the sim to load out.

4. Open the ezca.exe as administrator.

 

That's why my taskbar looks like this:

a816857aad507d420118edd6511ec3e0.png

 

 

I can easily start EZDOK after fsx has started :)

And if it freezes/crashes, quickly end ezca.exe with task manager and re-run it.

For me EZDOK runs really stable.

Share this post


Link to post
Share on other sites

After using EZCA for many, many years, I started to have problems with it (whatever the most recent version is ... 1.18.7?) a short time after a recent Windows 10 update. I followed all of the advice on the support forum (excludes of the folder and the process in Defender, etc.), and I still had problems. Like Domini99, I had to start EZCA after everything else, and even then, I would still get not only simconnect timeout issues but also camera weirdness--e.g., the view spinning uncontrollably as soon as I applied the throttle.

 

I was so frustrated with EZCA that I ended up trying OpusFSI ... and really liking it. I bought it, even though I use ASN for weather.Opus FSI has a learning curve, but in the end, I find it easier to set up views than I did with EZCA. I also feel that the DHM is more realistic, but of course, that's a personal preference, so YMMV.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...