Jump to content

Sign in to follow this  
OhItsJustJake

Fsx SP2 Error. (Out of Ideas)

Recommended Posts

Recently, I have moved house and am now using a different computer than I was previously using for FSX.

 

I remember having a hard time getting FSX to install correctly on my previous system but I am now encountering a new problem.

 

 

Following many guides I have reinstalled FSX a total of 8 times in the past 48 hrs in an attempt to get Service Pack 2 to install..

 

Each time I reinstall FSX, I make sure it is completely wiped off my computer (all folders, files, and reg. entries)

 

Each time: I install FSX RTM. I have the Deluxe version. I make sure that FSX does not install to the default location but instead a location that is directly in the C drive (C:\AFSX). After the RTM FSX is completed, I activate, start FSX, Load default flight, fly, exit flight, exit FSX. Reboot.

 

Then I install Service Pack 1.  After its done installing, I load FSX, load default flight, fly, exit flight, exit FSX. Reboot.

 

Now, each and every flippin time I go to install Service Pack 2, I get the error that "Microsoft Flight Simulator X Service Pack 2 requires the English version of Flight Simulator X."

 

I've searched the interwebs far and wide and come across the same thing over and over again about the Registry issue and making sure that it points to my FSX folder, and each time it is set to the CORRECT location. 

 

I've tried every thing I can possibly think of. Each and every time I have reinstalled FSX I get the exact same problem. I've downloaded multiple of SP2 from different sources, none work, all give the same error message. I have looked at the Log file created by the installer but I can't understand where it goes wrong. 

 

 

My registry looks exactly the same every time I do a fresh install as well.

 

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\microsoft games\flight simulator\10.0

Contains:

(Default) REG_SZ    (value not set)

CDPath  REG_SZ    F:\

LangID   REG_DWORD   0x00000409 (1033)

PID        REG_SZ     83884-104-0269317-70865

SetupPath  REG_SZ    C:\AFSX\

 

 

My HKEY_Current_user path

Contains:

(Default) REG_SZ  (value not set)

SetupPath   REG_SZ     C:\AFSX\

FIRSTRUN  REG_DWORD    0x00000001 (1)

 

I'm running out of ideas.

 

Both of the computers I have installed FSX on were running Windows Vista.

 

Anyone have any ideas? I'm desperate for some guidance.

 

 

Share this post


Link to post
Share on other sites

Jake,

 

You've probably seen this link about your problem.   Most of it describes ensuring you use your original disks, which you've done.   Have you had a look at editing the Registry (the second part of the workaround)?   As well, make sure you don't have any add-ons copied onto your disk, all programs are closed and your a/v is disabled when installing SP2.

 

http://www.microsoft.com/Products/Games/FSInsider/tips/Pages/FSXSP2-BogusErrorMessageonSetup.aspx

 

Chris

Share this post


Link to post
Share on other sites

Saim, I have not yet gotten it to install.

 

 

Chris, I did see that and from what I can see, the registry is correct every time I fresh install and go to check it.

 

 

N60JBravo, My OS is 32 bit.

 

 

If anyone can read the installer log for SP2, I can copy and paste it here for review.

Share this post


Link to post
Share on other sites

Have you tried my suggestion from the other forum about right-clicking the SP2.exe and

 

run as ADMIN?

Share this post


Link to post
Share on other sites

Charlie, when you download SP2 it downloads as fsx_sp2_ENU.msi

 

Its a msi file not an exe. So the right click doesn't allow a run as admin.

 

However, I did google instructions to force msi files to run as admin, I followed instructions and the "Run as Admin" option now shows up when I right click the msi file, but nothing happens.

Share this post


Link to post
Share on other sites

I haven't found anyone who has fixed this problem or has posted the results of his/her "fix". The suggestions above are great and the recommendation by Chris (post #4) with the Microsoft link should have resolved it for you. But then, the author of that "fix" wasn't really sure the fix was going to work for everyone. It is possible the editing of your registry was incorrect because, if the correct folder is shown in the registry, then SP2 should find the language.dll. If it cannot find the language.dll, then you will get the error you have been receiving.

 

You indicate you have done a complete uninstall and cleaned all the files, folders, and registry entries. Wonder how you did that? Did you do it all manually or did you use a registry cleaner like CCleaner? I also recommend you use the installation guidance from PMDG - http://support.precisionmanuals.com/kb/a87/how-to-uninstall-and-reinstall-fsx.aspx. The only thing missing from this guide is using a registry cleaner after the uninstallation.

 

Are there other users using your computer? After installing FSX/SP1, go to the main FSX folder, right click it, select Properties, and make sure it is being shared with all users. Maybe after rebooting after installing each part, you were signed in as another user?

 

If you do eventually find a solution, please post how you did it so that others in the future will not have to suffer like you did.

 

Best regards,

Share this post


Link to post
Share on other sites

Jim,

 

 

I have been been searching for anyone to post what they've done to fix it, and it seems that everyone links to that, and if it doesn't work, they don't ever post how they did (probably from the excitement of figuring it out). 

 

 

When I look into the log file for the installer for SP2, I notice that it is looking in the correct place for the Language.dll. Now I don't know exactly what I am reading, but it does look like it finds it, and then the installer tells itself that it is "Ignoring disallowed proporty ACESVERIFYLANGUAGEFILE" . The installer looks like it I identifies the "ACESVERIFYLANGUAGEFILE=C:\AFSX\language.dll" Which is exactly where the file is located, so I don't understand where the problem is..

 

 

Each time I do a clean uninstall I do follow that PMDG guide to uninstalling. The only thing I haven't done is run my CCleaner, which I can't believe I haven't thought to do.  Although, I do make sure I go into the registry and look for any trace of FSX in the only places I know them to be (although maybe there are places I don't know they make entries). I should try again, making sure I run my CCleaner.

 

As far as Users go, there is just the main user, and a guest user. I suppose I could go in and delete the option for a guest user. I did go in and retry the installation of SP2 after I read what you posted about adding permissions to all users.

 

I will post the latest SP2 install try's Log file.

 

 

After that I will try a fresh install making sure my entire computer is absolutely void of FSX.

 

 

I will be sure to post my results.

 

Thanks all!

 

Here is the Log file.  <..........>

Share this post


Link to post
Share on other sites

I have no idea if this will work or not.

 

If you already have SP1 installed, uninstall it.

 

Make a copy of the language.dll on your Desktop.

 

Install SP1

 

Replace the SP1 language.dll with the RTM language.dll from your Desktop.

 

Try to install SP2.

 

And for the record, you are not trying to do anything with Acceleration, correct?

 

regards,

Joe

Share this post


Link to post
Share on other sites

I'm sorry if this sounds silly, but I just ask to make sure...Are you positive you have an English version?  There are multiple language versions of SP2.  I would try the other versions just to see what happens.  Also, and I know this is not recommended by some using Vista, but try installing FSX to the default directory and see how it reacts.  Sorry if this doesn't work, but these are things I would try.

 

 

Share this post


Link to post
Share on other sites

Just as an update, after trying everything I had read, I decided to just find a copy of FSX Gold. It installed all the service packs and I activated it with my FSX Deluxe Serial, and It works wonderfully..

 

I knew the computer I was using wasn't at the same level as my previous computer, but it struggles to run my favorite add-ons.

 

Sucks that I went through all that to see a massive performance dip, but oh well.

 

I'll be getting myself a better computer in the short future here.

 

 

Thanks for all the help y'all, I really appreciate it! 

 

 

Jake

Share this post


Link to post
Share on other sites

Glad you have a fully working FSX now. Still very puzzled as to why none of the suggestions regarding the language.dll did not work. Ah! Computers!

 

Best regards,

Share this post


Link to post
Share on other sites

You do way too many steps, all that restarting of FSX and rebooting between installation and service packs is absolutely not necesary.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...