Sign in to follow this  
McGraw

Trying to pinpoint the settings that introduce micro stuttering in turns

Recommended Posts

Hello.

 

I'm trying to get to the point where I know my FSX setup/install is as good as it will get so I can forget about tweaking and get on with flying.

 

My system is 4790k @4.6, Nvidia GTX 970, 2400mhz C11 RAM (2x8gb), 256 mx 100 SSD. This is a fresh Acceleration install.

 

First of all, I'm more than happy with my frames and general smoothness but I feel the need to try and find out whether my turn stutters are normal as these are the only think I can't get rid of.

 

So, I set to native 1080p resolution with a fresh cfg and turn everything down (I mean everything, I'm quite suprised how bad you can make FSX look). I retain my Nvidia inspector 1/2 refresh and 30fps settings as they are staying regardless.

 

I fly the default aircraft at Nuggs for minimal scenery.

 

With everything at the lowest possible setting I can bank around with no stutters. I know this is not really surprising but you never know with FSX.

 

Next comes changing settings to Anisotropic, allowing inspector to AA.

 

At this point, pools=0 helps but affinity 84 doesn't (I know this is really only necessary once you start using the payware stuff).

 

So, completely avoiding clouds, autogen and traffic, I start to turn up texture details gradually and note when the stutters come.

 

I didn't have time to test on every slider setting but it seems that once I put in a reasonable level of detail and mesh settings that the stutters appear.

 

So on my rig I can't avoid microstutters in the turn whils having decent terrain detail.

 

Once I start adding weather, complex scenery, aircraft and autogen the stuttering never really gets any worse.

 

Can this base level of stuttering in turns ever be eradicated then?

 

Thanks a lot.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

For me the thing that stopped the microstutters was using the correct affinitymask setting (14 for my quad core).  It took me ages and a lot of mucking around at the time to identify it.

 

Usepools=0 was the second thing that improved my smoothness and framerates.

 

Also worth shutting down all un-needed background services, especially antivirus and anti malware scanners just to see if they are causing issues.

 

Some say that superfech can also have an impact - again worth turning off to experiment - it can always be turned back on again.

 

Finally, a look at your own settings - could try reducing things like ground traffic - that causes a few stutters for me and maybe a bit less AI traffic and of course a little tweaking of the anti-aliasing and filtering settings in Nvidia inspector - does slightly lower AA for example improve things?

 

IAN

Share this post


Link to post
Share on other sites

Thanks I've tried all those things and these stutters still happen with no traffic or autogen.

 

It's increasing the complexity of the landscape that introduces them for me.

 

I can crank the AA and settings right up and those micro stutters are still there but nothing gets worse. Fps remain good.

 

For that reason I don't believe it's an AA issue.

 

Is the FSX engine not capable of allowing smooth turns with only decent mesh and texture details or is my rig flawed spec wise?

 

Thanks.

Share this post


Link to post
Share on other sites

I don't think it has anything to do with your computer.  FSX is an old sim and sometimes even the best hardware in the world does not seem to help.  You might try playing with the frame rate limiter.  My experience has been that the best FSX performance sometimes occurs with unlimited frame rates, and other times it is smoothest with frame rates limited to 24 or 30 fps.

Share this post


Link to post
Share on other sites

Thanks.

 

To be honest I am very impressed overall with how my pc handles fsx but it does seem such a shame that I can't iron out those tiny stutters that stop my banks being smooth.

 

Oh well I think I will give up now and fly, knowing that they probably can't be got rid of and my rig seems to run things as well videos I've seen on youtube.

Share this post


Link to post
Share on other sites

FSX is a bit of a compromise.  Nothing will run it completely stutter free, especially with a few scenery and PMDG addons.

 

You really end up with a choice.  You either turn the in game and videocard settings down or you keep the eye candy and accept the odd hic-up and stutter.  I think most of us go for the latter.

 

IAN

Share this post


Link to post
Share on other sites

Currently i am fiddling my Antialiasing settings...

I am encountering those annoying stutters too...setting AA to 8xQ (or lower) and disabling Supersampling removes almost all stutters for me.

 

By the way: Using an external FPS limiter set to 61FPS did a great job on my system as well.

 

Best regards,

Tom

Share this post


Link to post
Share on other sites

Are you running DX9 or DX10.  I was getting annoying stutters when I would change my view with TrackIR.  The stutters went away when I switched to DX10 (with Steve's DX10 Fixer).

 

i3770k @4.3, GTX670.

Share this post


Link to post
Share on other sites

I'm using dx9 but may consider the switch to dx10 as some point as I just get the urge to mess with things.

 

Let me try and explain again the stutters I'm talking about.

 

At 1920x1080 and regardless of AA and AF, I get tiny turn stutters with everything turned right down apart from mesh settings and complexity.

 

If I have all those settings at minimum I get smooth banks.

 

If I load up with scenery, autogen and aircraft, the stutters remain the same so I have this nagging feeling that they could be tweaked out.

Share this post


Link to post
Share on other sites

It's very simple: turning a plane will cost performance (it's just the way FSX was built) and the only time you won't see any stutter is when your hardware can handle the current settings and add-ons being used.

 

 

I was getting annoying stutters when I would change my view with TrackIR.  The stutters went away when I switched to DX10 (with Steve's DX10 Fixer).

That just because you boosted performance overall.

Share this post


Link to post
Share on other sites

It's very simple: turning a plane will cost performance (it's just the way FSX was built) and the only time you won't see any stutter is when your hardware can handle the current settings and add-ons being used.

 

My system should be able to handlle zero autogen, weather, ai and scenery without stuttering in turns with only good mesh settings.

Share this post


Link to post
Share on other sites

I feel that there is a balancing act.  You can get into a situation where the CPU is producing data faster than then video card can render it.  The result will be stutters.  Unfortunately, maintaining a perfect balance is nearly impossible as the loads placed on the computer will can vary greatly during a flight.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this