Sign in to follow this  
corkery

1-2 Sec freeze in FSX at same points in sim every time!

Recommended Posts

Taking off on Rwy 02 at EGHI I get to 200ft and the sim will freeze for a couple of seconds. This is even with default 172 and Orbx EGHI disabled. I have tried:

 

- deleting and rebuilding shaders

- deleting and rebuilding sceneryindexes

- disabling Orbx Vector

- removing all cfg tweaks except highmemfix=1

- no external weather

- running at solid 30fps immediately before and after freeze.

I am out of ideas so any suggestions gratefully received. I would rather not do a complete reinstall as I have only just rebuilt after getting a fast rig and it takes ages!

 

Cheers

Tony

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

This happens with Ultimate Traffic 2 building the traffic. Do you have it newly installed?

Share this post


Link to post
Share on other sites

This happens with Ultimate Traffic 2 building the traffic. Do you have it newly installed?

 

I am aware of the UT2 traffic pause but I load UTServices outside of exe.dll to conserve VAS and I don't have it running during these issues.

Share this post


Link to post
Share on other sites

I saw a thread where someone was saying ASN was causing pauses.  I'm getting a few lately but I can't say what's causing it.  (I have the latest ASN).

Share this post


Link to post
Share on other sites

Did it just start happening?

This is difficult to answer. I have a lot of addons including all things Orbx which I have recently re-installed to a fast rig.  As I installed each addon I did a test flight to check correct installation but whether that included this scenario I don't remember.  I was prompted to look here because Orbx have recently released updates to a number of their other UK airfields that changed the way they control their scenery (ie a single Objectflow.dll rather than individual airfield dlls.  I noticed some freezes when when test flying these areas so went back to EGHI which had been updated previously and then discovered this issue. Unfortunately I have flown the same profile with ALL orbx dlls removed and the issue remains. Also, US Orbx airports work absolutely fine.  Some weird results:

 

If I take off on rwy 02 I get the freeze at exactly the same point everytime.  If I overlfy the rwy on the rwy heading at cct height I get the same freeze at the same point.  If I do an approach to rwy 20 and therefore fly over the same point on approach - no freeze!!

 

I thought it might be related to generation of autogen but still the same with autogen off.

I saw a thread where someone was saying ASN was causing pauses.  I'm getting a few lately but I can't say what's causing it.  (I have the latest ASN).

Yes, that's were I first asked for help but this still occurs even with asn disabled and as-connect module disabled. Others seem to have an issue where pauses are related to asn operation.

 

Do you have Orbx global base, vector and any of the regions? I'm wondering if there maybe some corrupt files.

Share this post


Link to post
Share on other sites

If you have AutoSave ticked in FSUIPC, you will get a momentary pause each time it saves a situation.

Bob G.

Share this post


Link to post
Share on other sites

If you have AutoSave ticked in FSUIPC, you will get a momentary pause each time it saves a situation.

Bob G.

Thanks, I did have this checked but both auto save and gps out are disabled but still same issue. I'm now suspecting Orbx England as it doesn't occur in Orbx Wales, Scotland or North America, as far as I can tell.

Share this post


Link to post
Share on other sites

I just loaded up your scenario...I have England and EGHI.  I get this long pause as well.

 

Gregg 

Share this post


Link to post
Share on other sites

I just loaded up your scenario...I have England and EGHI. I get this long pause as well.

 

Gregg

Thanks for that, it's driving me mad! At least it can be repeated. I started a topic on Orbx forums but have had no replies. My next test is to set FTX Central to 'Global', disable FTX Eng and EGHI in the scenery and re-enable UK2000's EGHI from England Vol 1 V2. I'll post results later.

 

Edit: setup up with FTX Global base, FTX Open LC EU and UK2000 EGHI still pauses in same place but 'seem' to be shorter!

Share this post


Link to post
Share on other sites

Started getting this today after updating my PMDG B777 and ASN last night and is now unflyable.  At a loss!!

Share this post


Link to post
Share on other sites

I do wonder if this is ORBX-related. I have Global Base 1.30 (recently updated from 1.20), Vector 1.15 and OpenLC Europe. A few weeks ago, some other users on the ORBX forums with a similar setup to mine were reporting an area of sudden poor performance in the vicinity of the Clacton (CLN) VOR. I myself saw this happen on a recent flight from EGLL to EHAM - just before overflying Clacton, my frame rates suddenly dropped from the mid-thirties to about 3 FPS, then the sim froze completely for about 8 seconds. I thought it was going to CTD, but it did recover, and once past CLN, performance returned to normal, with no further issues.

 

I wonder if something similar might be happening near EGHI? In the case of the freeze near CLN, I don't think there was any official confirmation of a problem by ORBX. I have not flown that way since updating Global Base textures to 1.30. All those reporting the problem were having the freeze at almost exactly the same location in relation to CLN, which sounds similar to your issue near Southampton.

 

I see you did still have the problem after disabling the ORBX scenery, so perhaps that is not the cause of your issue. I do run ASN on all my flights, but have never had any freeze problems anywhere but in the SE UK

Share this post


Link to post
Share on other sites

The only thing I can't disable is FTX Global Base 1.3 (not without a load of hassle anyway!) so I haven't been able to try a stock version of FSX.  I do experience short pauses elsewhere but these could be standard FSX texture loading pauses.  I may have unrealistic expectations for smoothness after updgrading to an i7 4790 @4.4ghz running FSX + scenery from a 1TB SSD. If I focus on this anymore it will just drive me mad.  Luckily the prevailing wind usually means that rwy 20 is used at EGHI :-)

 

Thanks all for your input and maybe someone will have a eureka moment!

Share this post


Link to post
Share on other sites

 

 


The only thing I can't disable is FTX Global Base 1.3 (not without a load of hassle anyway!) so I haven't been able to try a stock version of FSX. I do experience short pauses elsewhere but these could be standard FSX texture loading pauses. I may have unrealistic expectations for smoothness after updgrading to an i7 4790 @4.4ghz running FSX + scenery from a 1TB SSD. If I focus on this anymore it will just drive me mad. Luckily the prevailing wind usually means that rwy 20 is used at EGHI :-)



Thanks all for your input and maybe someone will have a eureka moment!

 

Have you posted anything at Orbx forum?

Share this post


Link to post
Share on other sites

Have you posted anything at Orbx forum?

I have a post about a freeze over EGHI train terminal which has been there for a few days (pre-avsim post) but still hasn't had any replies. If you've experienced the same perhaps another customer with the same issue may elicit a response?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this