Sign in to follow this  
Nduru

Help please with bufferpools

Recommended Posts

Help please, i have set BP=0 and Poolsize=100000 under [bufferpools] in my CFG and my fsx is making my graphics card run at 99% load and this makes my sim stutter, tear and get frame spikes. Is there any settings I can mess around with to fix this?

 

GTX 750ti 2gb,8gb ram, i7 4790k @ 4.0ghz

Edited by firehawk44
First and Last sentence edited to remove ALL CAPS - Shouting. Not allowed here.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

If you have BP=0 set, then you shouldn't have any Poolsize= value or entry.

Try removing the Poolsize value and just having :-
 

[bufferPools]
PoolSize=0

Share this post


Link to post
Share on other sites

For a start, you should either have:-

 

[bufferpools]

BP=0 

 

*This instructs FSX not to reserve any video memory which usually results in a lot of flashing textures etc.

 

OR

 

[bufferpools]

Poolsize=[insert number here]

 

*This instructs FSX to reserve video memory and allows FSX to better manage texture loading, or so the theory goes.

 

Try removing the BP=0 entry and seeing if it makes as Benneton above says.

 

If all else fails, give this a read http://airdailyx.blogspot.co.uk/2013/02/fsxcfg-tweak-review-bufferpools.html

 

Best of luck. B)

Share this post


Link to post
Share on other sites

I have tried that but didint work,i am soo anoyed, the only solution i have is to lock my frames but i dont want to that because my frames are lower

Ok i will try thanks

Share this post


Link to post
Share on other sites

If you are getting spiking with the Bufferpools entry, then it is more than likely to be eradicated by setting your Water slider in FSX to: High 2.x I have never been able to use the Bufferpools setting without this change to the water setting. There is a slight irony, in that by setting the water setting higher, you lose a lot of what you gain in performance by adding the Bufferpools tweak. However, where you do gain, is by getting a smoother sim.

Share this post


Link to post
Share on other sites

So solution one: remove poolsize value and set water slider to high x2

 

Solution two: remove BP=0 and set poolsize value to 0 if that does not work try to use different poolsize values

Share this post


Link to post
Share on other sites

With BP=0 and Water set to Low 2.x I get irregular texture flashes with my GTX780. If I set Water to High 2.x the flashes disappear but frame rates take a big hit.

 

For that reason I'm prepared to take the texture flashes. There isn't a fix that doesn't have a downside unfortunately. But with BP=0 I do get very smooth performance with virtually no stutters.

Share this post


Link to post
Share on other sites

What bp=0 does it makes my gpu run at 99% load which makes my sim get frames spikes eg getting 60 fps then jump to 120fps then down to 20.

 

The first ventubo tweak i done did not work because the rejectthreshold was at a bad value

 

I will try setting different settings because normmally the load should not go over 75%

Share this post


Link to post
Share on other sites

You said that fixing your fps solved it.

 

Based on that, I would lock fps at 30 in FSX, and leave the whole bufferpools thing out.

 

Then use nvidia inspector to set vsynch at 1/2 monitor refresh rate, and you are done.

Share this post


Link to post
Share on other sites

Nduru, it would help if you included your computer spec in your profile. My GTX780 doesn't get even close to 99% so clearly your card is working very hard to cope with what FSX is throwing at it.

 

For that reason BP=0 may not be suitable for you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this