Sign in to follow this  
sionalford

Help with OpusFSI and P3Dv2.4

Recommended Posts

Hello everyone. Posted this over on the LM site with no help. Thought I would try here.

 

Before I explain, the system was running perfectly until I did a fresh install of OS (Win7) and P3Dv2.4.

Here is what is happening:

Software runs fine until I add OpusFSI. When I execute the Opus server during the p3d startup scenario screen, P3D locks up and crashes to desktop. It ONLY happens when I have “live cameras” option checked in OpusFSI config. So, apparently p3d does not like it when Opus tries to connect with p3d via simconnect.

Couple of things to note:

Opus is the FIRST add-on I installed after a clean installation.
All default settings are used in p3d.
If I launch into a flight (starting on runway or parking) and then start the Opus server, everything works fine. It only crashes when trying to do this while p3d is at the scenario screen.
As long as I don’t activate the “live camera” option in the config menu of Opus everything works fine.
I tried it without the supplied simconnect file from Opus.
I tried it with the supplied simconnect file from Opus.
I tried it with the supplied simconnect files from p3d.
This all worked fine until a clean install.

Any help would be appreciated.

Sion

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

This is a known problem. You can only start Opus while a flight is loaded. Opus claims that it's a p3d problem. No word on a fix to date.

Share this post


Link to post

I load it inside of my P3d v2.4's EXE.XML and I have no problem. I first load trackIR and then opusFSI and Aivlasoft server and client

 

I'm presented with the scenario screen from which I can either click OK and use it or load a previous flight ,and I have no problems.

 

Just sayin

 

chas

Share this post


Link to post

This is a known problem. You can only start Opus while a flight is loaded. Opus claims that it's a p3d problem. No word on a fix to date.

 

Yes, this is what I have learned. Steven over at the Opus forum has been actively engaged with me concerning this. BTW, their support is awesome and responsive. 

 

What bothers me is that it once worked on my system. Not until I got a new HD, did a fresh install of v2.4 did this problem arise. I understand that it may be a p3d problem, however, it did work at one time.

 

My previous working version was an upgrade version from v2.3. Maybe that had something to do with it? 

 

I guess it is the old programmer in me...I just can't let it rest until I know why it doesn't work.

 

Thanks,

 

Sion

I load it inside of my P3d v2.4's EXE.XML and I have no problem. I first load trackIR and then opusFSI and Aivlasoft server and client

 

I'm presented with the scenario screen from which I can either click OK and use it or load a previous flight ,and I have no problems.

 

Just sayin

 

chas

 

Hey Chas,

 

Same here until I did a fresh install. Had it in my exe.xml. That is the mystery.

 

BTW, once flight is loaded I can run Opus and all works. Just a major hassle. 

 

Looks as though something in p3d gets hung. Error report shows app hanging on dxdiag.

 

Sion

Share this post


Link to post

Yes, this is what I have learned. Steven over at the Opus forum ... BTW, their support is awesome and responsive.

 

...I guess it is the old programmer in me...I just can't let it rest until I know why it doesn't work.

 

Thanks,

 

Sion

 

 

Hey Chas,

 

Same here until I did a fresh install. Had it in my exe.xml. That is the mystery.

 

BTW, once flight is loaded I can run Opus and all works. Just a major hassle.

 

Looks as though something in p3d gets hung. Error report shows app hanging on dxdiag.

 

Sion

Moi aussi to a renamed SSD...LEMME KNOW WHAT I CAN COMPARE FOR YOU...

 

C

I refunded FSi, Get ASN

Wayyyy too quick judge... IMHO

 

C

Share this post


Link to post

I refunded FSi, Get ASN

 

I mainly need it for the buttkicker use. Live camera was great and wasn't planning on using EZDOK again but had to go back to it. Just don't have my buttkicker now. Miss the immersion.

 

BTW, I don't use the weather from Opus at all.

 

Sion

Moi aussi to a renamed SSD...LEMME KNOW WHAT I CAN COMPARE FOR YOU...

 

C

 Sorry Chas, I have no idea what you are asking  :mellow: . Do you mean you are doing a fresh install to see if you can regenerate the issue?

 

Thanks,

Sion

Share this post


Link to post

On a recent install of V2.4, I had a similar issue with Linda no longer loading from exe.xml as it had done originally. I went into the properties and selected "Run as Administrator" and everything back to normal. Just a thought.

 

Cheers.

Joe

 

EDIT: "Run as Administrator" set in properties for Linda.exe as well as prepar3d.exe.

Share this post


Link to post

Just as an aside here, I have found that on many occasions, setting "run as admin" in properties does NOT work as well as right click and "run as admin".

 

So if you run into an issue, try the right click.

 

I have NO idea why this happens but I've seen it enough to know it's no fluke.

 

Vic

Share this post


Link to post

Sion, I had similar crashes on the startup screen. Manual workaround: I 've found starting Opus first and letting it launch fully, then launching P3D next, works...

Share this post


Link to post

 

 


I mainly need it for the buttkicker use. Live camera was great and wasn't planning on using EZDOK again but had to go back to it. Just don't have my buttkicker now. Miss the immersion.

 

That is why I will never get rid of OpusFSI, buttkicker immersion. That is what separates it from ASN etc. 

Share this post


Link to post

That is why I will never get rid of OpusFSI, buttkicker immersion. That is what separates it from ASN etc. 

 

Looking for the day when SimVibe will support P3D/FSX. They say it is coming. Check it out at www.simxperience.com. It is ridiculous for sim racing.

 

Sion

Share this post


Link to post

I also have simvibe and you are correct, it is excellent and works exactly for car simulations as OpusFSI does for P3D/FSX flight simulations. If Simvibe had supported P3D/FSX, my options for weather engines would have increased. It maybe just me, but I can live with an average (not to say OpusFSI is average) weather engine and buttkicker support. in fact even if it was the best weather engine the world has ever seen, for me, it is no substitute for the immersion you get with the buttkicker (runways, flying, landing, engine etc... you can physically feel everything).

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this