Jump to content

Sign in to follow this  
Fi5kuS

ai_player.dll crash and no idea why...

Recommended Posts

Hi folks!

 

I remember I had this problem in FSX:Steam edition, but it magically went away somehow. Now I finally switched to P3D and this smacks my face. I have turned off all AI traffic with no luck and even installed the latest FSUIPC. I also followed a advice on reinstalled addon manager but that didn't help either. 

 

Anyone else seen this? I can load a scenario but the sim CTDs within 10 seconds.

 

 

Log Name:      Application

Source:        Application Error

Date:          15.03.2015 23:44:45

Event ID:      1000

Task Category: (100)

Level:         Error

Keywords:      Classic

User:          N/A

Computer:      

Description:

Faulting application name: Prepar3D.exe, version: 2.5.12943.0, time stamp: 0x54e39da6

Faulting module name: ai_player.dll, version: 2.5.12943.0, time stamp: 0x54e39da2

Exception code: 0xc0000005

Fault offset: 0x00045d19

Faulting process id: 0x10fc

Faulting application start time: 0x01d05f713e000f5c

Faulting application path: D:\Prepar3D\Prepar3D.exe

Faulting module path: D:\Prepar3D\ai_player.dll

Report Id: dff62111-cb64-11e4-ae65-e03f49b2e014

Event Xml:


  <System>

    <Provider Name="Application Error" />

    <EventID Qualifiers="0">1000</EventID>

    <Level>2</Level>

    <Task>100</Task>

    <Keywords>0x80000000000000</Keywords>

    <TimeCreated SystemTime="2015-03-15T22:44:45.000000000Z" />

    <EventRecordID>1985</EventRecordID>

    <Channel>Application</Channel>

    <Computer>Brynjar-PC</Computer>

    <Security />

  </System>

  <EventData>

    <Data>Prepar3D.exe</Data>

    <Data>2.5.12943.0</Data>

    <Data>54e39da6</Data>

    <Data>ai_player.dll</Data>

    <Data>2.5.12943.0</Data>

    <Data>54e39da2</Data>

    <Data>c0000005</Data>

    <Data>00045d19</Data>

    <Data>10fc</Data>

    <Data>01d05f713e000f5c</Data>

    <Data>D:\Prepar3D\Prepar3D.exe</Data>

    <Data>D:\Prepar3D\ai_player.dll</Data>

    <Data>dff62111-cb64-11e4-ae65-e03f49b2e014</Data>

  </EventData>

</Event>


38.jpg

Brynjar Mauseth 

Share this post


Link to post

Same for me Guy ! after trying a lot of solutions i needed to make a fresh install of P3D ... i was using traffic360 and orbx traffic tools ..

 

Jean Luc

Share this post


Link to post

There has do be other solutions to this problem besides complete reinstall. The problem will just occur again.

I recall that my problem disappeared in FSX:SE when I installed the latest version of FSUIPC, but not working in P3D. 

 

Also, I don't have any AI traffic program running so it could be one of the addon airports. Strange indeed.


38.jpg

Brynjar Mauseth 

Share this post


Link to post

Never had this error in P3D, but it occurs in FSX SE. It doesn't crash the sim however (the error is listed in the Maitnance section ), and to me it seems it only happens if i load up the default flight.


Ivan Majetic

MAXIMUS X HERO, i7 8086k 5,0 Ghz, NZXT KRAKEN Z73, ASUS STRIX GTX1080Ti OC, G.SKILL TridentZ DDR4 32 Gb, WD HDD 2TB, SAMSUNG 840PRO, SAMSUNG 850EVO, SAMSUNG 970EVO Plus, ASUS PG348Q

Share this post


Link to post

Ivan, for my concern it was not on a default flight but on a save flight that has finished without any problem ... and on p3d ...

Share this post


Link to post

After 4h of troubleshooting and trying to find the needle in the haystack I forfeited and did a complete reinstall of Win7, again. Words can't express how much this sucks  :mad:


38.jpg

Brynjar Mauseth 

Share this post


Link to post

Here's what the AVSIM CTD Guide, page 10 recommends the following:

AI_Player.dll - The faulting module was the ai_player.dll which is the module that controls your AI (a commercial AI program or the default).

• Could be something wrong with an AI model or object. If you have MyTrafficX, you can disable AI in the Scenery Library to see if this fixes the problem. If so, then this is the problem. If you have another AI program installed, then disable that program to see if the program is causing your crashes.
• Problem occurs occasionally in the Seattle area with FTX/Orbx Pacific Northwest. This may have been fixed by now but check the FTX/Orbx forums and search for AI_Player.
• Caused by freeware airports in the area that has static aircraft or their own AI aircraft and flight plans. Disable the add-on airport and see if problem is gone. If you have any FSDT, Flight Beam airports, do not disable them. They are not the problem.
• AI programs like MyTrafficX has AFCAD's for hundreds, maybe thousands of airports in the MyTraffic/Scenery folder. Anyone of these could be the cause of the ai_player crash. In this case, make sure you have the latest version of your AI program installed.

 

Best regards,


Jim Young | AVSIM Online! - Simming's Premier Resource!

Member, AVSIM Board of Directors - Serving AVSIM since 2001

Submit News to AVSIM
Important other links: Basic FSX Configuration Guide | AVSIM CTD Guide | AVSIM Prepar3D Guide | Help with AVSIM Site | Signature Rules | Screen Shot Rule | AVSIM Terms of Service (ToS)

I7 8086K  5.0GHz | GTX 1080 TI OC Edition | Dell 34" and 24" Monitors | ASUS Maximus X Hero MB Z370 | Samsung M.2 NVMe 500GB and 1TB | Samsung SSD 500GB x2 | Toshiba HDD 1TB | WDC HDD 1TB | Corsair H115i Pro | 16GB DDR4 3600C17 | Windows 10 

 

Share this post


Link to post

Also, FWIW, I believe the latest version of P3D is 12944

 

Vic


 

P3D#1 - 7700K 5.0g ROG X270F 3600 15-15-15 - EVGA RTX 2080ti 1000W PSU 1- 850G EVO SSD, 2-256G OCZ SSD, 1TB,HAF942-H100 Water W1064Pro
40" 4K Monitor 3840x2160 - AS16, ASCA, GEP3D, UTX, Toposim, ORBX Regions, TrackIR
P3D#2 - 3770K 4.7g Asus Z77 1600 7-8-7 GTX1080ti DH14 850W 2-1TB WD HDD,1tb VRap, Armor+ W10 Pro 2 - HannsG 28" Monitors
 

Share this post


Link to post

Here's what the AVSIM CTD Guide, page 10 recommends the following:

Hi Jim. Yes, I did go through the AVSIM CTD guide, but it did not help either. 

 

Also, FWIW, I believe the latest version of P3D is 12944

 

Vic

 

Yes I realized that but it didn't work updating to 12944 (hotfix). This is by far the worst dll. error or CTD I've EVER encountered. 


38.jpg

Brynjar Mauseth 

Share this post


Link to post

Hi guys,

 

I have just completed a full rebuild of Win 7 X64 with FSX SE. Tested the vanilla install as I went and there was no issues. As each layer of OXBX went in I tested at different locations around the world. The only region the post sim close error occurs is indeed the Pacific north west. I only have FTX Global and FTX Vector and library installed at this point. Based on findings by other folk here at Avsim and elsewhere I performed a file search for "KSEA" I located several KSEA BGL files ORBX had added to the sim. I removed each File in turn and tested the sim until the crash stopped. I found the offending BGL and have proven the sim is stable for several hours and on exit without it. Place it back in and the Sim errors on exit with the ai player dll. If you use a vanilla install with only ORBX Global/Vector this may cure your setup. I went on to install all my Airport addons and there has been no issue. Drop the FTX file back in and it crashs on exit. But the issue does seem to revolve around the SEA area. I will test with some freeware SEA afcads and see will this improve SEA without the FTX file loaded.

 

The file to look for is APT_KSEA.bgl and its 69KB

 

James

Share this post


Link to post

Did you ever conduct a search at the FTX/Orbx forums for 'AI_Player.dll' as I suggested above and in the AVSIM CTD Guide - http://www.orbxsystems.com/forum/search/?q=ai_player.dll&type=forums_topic

 

Best regards,


Jim Young | AVSIM Online! - Simming's Premier Resource!

Member, AVSIM Board of Directors - Serving AVSIM since 2001

Submit News to AVSIM
Important other links: Basic FSX Configuration Guide | AVSIM CTD Guide | AVSIM Prepar3D Guide | Help with AVSIM Site | Signature Rules | Screen Shot Rule | AVSIM Terms of Service (ToS)

I7 8086K  5.0GHz | GTX 1080 TI OC Edition | Dell 34" and 24" Monitors | ASUS Maximus X Hero MB Z370 | Samsung M.2 NVMe 500GB and 1TB | Samsung SSD 500GB x2 | Toshiba HDD 1TB | WDC HDD 1TB | Corsair H115i Pro | 16GB DDR4 3600C17 | Windows 10 

 

Share this post


Link to post

Hi Jim, I had solved the issue before finding this thread..CTD guide is in my Library now thank you.

 

James

Share this post


Link to post

Hi Jim, I had solved the issue before finding this thread..CTD guide is in my Library now thank you.

 

James

Hello

 

JFYI, that was an error introduced in the ORBX PNW SP5 . (~ 2012)

 

Holger supplied Us with a replacement bgl from the previous SP4a.

I don't know which SP you have, but I thought it was fixed in latter SP's

Anyway, I have a copy, so if you need it, PM me.

 

Cheers.


Ramón.
Time, is the one thing no one can buy.
ovbe94a9nab0bbc6g.jpg

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    18%
    $4,710.00 of $25,000.00 Donate Now
×
×
  • Create New...