Sign in to follow this  
SKEWR

nvwgf2um.dll crash

Recommended Posts

Hello all;

 

Since the new year, I've been plagued with this crash. It causes FSX to shut down. I fly the complex airliners and usually before take off (after pre flight) I'll hear the CPU fan spool down and I'll know the crash has occurred.

 

My system is i3770k (OC to 4.5) with 8GB of RAM. Video card is GTX780ti (ASUS) with driver 347.88. I'm using Win 7 64 Pro. I use PMDG planes and I have the DX10 fixer. FSX is sp2.

 

What I've done:

Removed SweetFX and all associated files from FSX

Started FSX without Shade

Used a 3rd party driver uninstall to remove the nVidia driver and start fresh


Obtained and installed the latest version of FSUIPC

Repaired simconnect

Turned off Hardware acceleration in all internet browsers

Insured a specific KB (ending in 0838) that was known to interfere with DX10 was not installed


I've rebuilt my FSX config and added a few tweaks  it can be found below

 

 


[JOBSCHEDULER]

//AffinityMask=14

AffinityMask=84 //Hyperthread on

 

[bUFFERPOOLS]

//UsePools=1

//Poolsize=8388608

//RejectThreshold=126976

//Poolsize=0 

//BufferPools=1

//PoolSize=10485760

//RejectThreshold=524288

//RejectThreshold=131072

UsePools=0

 

[sOUND]

AmbientUIMusicVolume=-6.000000

SOUND_FADER1=0.500000

SOUND_FADER2=0.500000

SOUND_FADER3=0.500000

SOUND_FADER4=0.500000

AmbientUIMusic=FSX01

SOUND=1

SOUND_QUALITY=2

SOUND_LOD=0

UISound=1

AmbientUI=1

PrimaryDevice={DEF00000-9C6D-47ED-AAF1-4DDA8F2B5C03}

VoiceDevice={DEF00002-9C6D-47ED-AAF1-4DDA8F2B5C03}

 

[Display]

ChangeTime=4.000000

TransitionTime=4.000000

ActiveWindowTitleTextColor=255,255,255

ActiveWindowTitleBackGroundColor=0,28,140,64

NonActiveWindowTitleTextColor=255,255,255

NonActiveWindowTitleBackGroundColor=24,33,87,64

InfoUpperRightTextColor=255,0,0

InfoUpperRightBackGroundColor=0,0,0,0

InfoLowerLeftTextColor=255,255,255

InfoLowerLeftBackGroundColor=255,0,0,128

InfoLowerRightTextColor=255,255,255

InfoLowerRightBackGroundColor=255,0,0,128

InfoBrakesEnable=True

InfoParkingBrakesEnable=True

InfoPauseEnable=True

InfoSlewEnable=True

InfoStallEnable=True

InfoOverspeedEnable=True

BLOOM_EFFECTS=1

SKINNED_ANIMATIONS=1

TEXTURE_BANDWIDTH_MULT=80

UPPER_FRAMERATE_LIMIT=66

WideViewAspect=True

RUNWAY_LIGHTS_SURFACE_SCALAR=0.5 //Runway Lights

RUNWAY_LIGHTS_VASI_SCALAR=0.5 // VASI Lights

RUNWAY_LIGHTS_APPROACH_SCALAR=0.5 // Approach Bars

RUNWAY_LIGHTS_STROBE_SCALAR=0.5 // Strobes

TextureMaxLoad=12 //must be in mults of threes

ForceVCShadowMap=1

 

[Main]

User Objects=Airplane, Helicopter

SimObjectPaths.0=SimObjects\Airplanes

SimObjectPaths.1=SimObjects\Rotorcraft

SimObjectPaths.2=SimObjects\GroundVehicles

SimObjectPaths.3=SimObjects\Boats

SimObjectPaths.4=SimObjects\Animals

SimObjectPaths.5=SimObjects\Misc

SimObjectPaths.6=MyTraffic\Aircraft

HideMenuNormal=0

HideMenuFullscreen=1

ProcSpeed=10208

PerfBucket=7

Location=885,186,1925,964,\\.\DISPLAY1

Maximized=0

//HideInfoText=1 

DisablePreload=1

FIBER_FRAME_TIME_FRACTION=0.15 //defines the % of each frame devoted to loading scenery

 

[PANELS]

IMAGE_QUALITY=1

DEFAULT_VIEW=0

QUICKTIPS=0

PANEL_OPACITY=100

PANEL_MASKING=1

PANEL_STRETCHING=1

UNITS_OF_MEASURE=0

 

[Weather]

WindshieldPrecipitationEffects=1

MinGustTime=10

MaxGustTime=500

MinGustRampSpeed=1

MaxGustRampSpeed=200

MinVarTime=5

MaxVarTime=50

MinVarRampSpeed=10

MaxVarRampSpeed=75

TurbulenceScale=1.000000

WeatherServerAddress=fs2k.zone.com

WeatherServerPort=80

WeatherGraphDataInDialog=0

AdjustForMagVarInDialog=1

DynamicWeather=0

DownloadWindsAloft=0

DisableTurbulence=0

CLOUD_DRAW_DISTANCE=3

DETAILED_CLOUDS=1

CLOUD_COVERAGE_DENSITY=5

THERMAL_VISUALS=0

 

[CONTROLS]

Controls_Default=Standard

Controls_Current=Standard

KBDAIL=64

KBDELEV=64

KBDRUD=64

JOYSTICKS=0

 

[TextInfo.1]

Latitude=1,1

Longitude=1,2

Altitude=1,3

Heading=1,4

AirSpeed=1,5

WindDirectionAndSpeed=1,6

 

[TextInfo.2]

FrameRate=1,1

LockedFrameRate=

GForce=1,3

FuelPercentage=1,4

AverageFrameRate=1,2

 

[TextInfo.3]

Latitude=1,1

Longitude=1,2

Altitude=1,3

Heading=1,4

AirSpeed=1,5

WindDirectionAndSpeed=1,6

FrameRate=2,1

LockedFrameRate=

GForce=2,3

FuelPercentage=2,4

AverageFrameRate=2,2

 

[slewTextInfo.1]

Latitude=1,1

Longitude=1,2

Altitude=1,3

Heading=1,4

AirSpeed=1,5

 

[slewTextInfo.2]

FrameRate=1,1

LockedFrameRate=1,2

 

[slewTextInfo.3]

Latitude=1,1

Longitude=1,2

Altitude=1,3

Heading=1,4

AirSpeed=1,5

FrameRate=2,1

LockedFrameRate=2,2

 

[DynamicHeadMovement]

LonAccelOnHeadLon=-0.020000

LonAccelOnHeadPitch=-0.010000

RollAccelOnHeadLat=0.010000

YawAccelOnHeadLat=-0.100000

RollAccelOnHeadRoll=0.100000

MaxHeadAngle=5.000000

MaxHeadOffset=0.300000

HeadMoveTimeConstant=1.000000

 

[VirtualCopilot]

VirtualCopilotActive=0

 

[GRAPHICS]

HIGHMEMFIX=1

TEXTURE_MAX_LOAD=2048

NUM_LIGHTS=8

AIRCRAFT_SHADOWS=1

AIRCRAFT_REFLECTIONS=1

COCKPIT_HIGH_LOD=1

LANDING_LIGHTS=1

AC_SELF_SHADOW=0

EFFECTS_QUALITY=2

GROUND_SHADOWS=0

TEXTURE_QUALITY=3

IMAGE_QUALITY=0

See_Self=1

Text_Scroll=1

D3D10=1

MultiSamplesPerPixel=8

MultiSampleQuality=8

SHADER_CACHE_PRIMED_10=1693458432

ALLOW_SHADER_30=1

 

[uSERINTERFACE]

PageID=1

OpenATCOnCreate=0

SHOW_MISSION_CAPTIONS=0

PAUSE_ON_LOST_FOCUS=0

PROMPT_ON_EXIT=0

SITUATION=FLIGHTS\OTHER\FLTSIM

Map_Orientation=2

ShowAllACPaintSchemes=1

SelectAircraftManufacturer=All

SelectAircraftPublisher=PMDG

SelectAircraftType=All

DisplayFuelAsWeight=1

 

[ATC]

ShowATCText=1

COMM_MSG_NONE_COLOR=FFFFFFFF

COMM_MSG_ATC_USER_COLOR=FFB6FFB6

COMM_MSG_USER_ATC_COLOR=FFFFD21B

COMM_MSG_ATC_AI_COLOR=FF00FF00

COMM_MSG_AI_ATC_COLOR=FFFF7840

AutoOpenAirTrafficWindow=1

UsePilotVoice=1

PilotVoice=0

 

[PointOfInterestSystem]

CycleSetting=0

 

[sCENERY]

LENSFLARE=0

DAWN_DUSK_SMOOTHING=1

IMAGE_COMPLEXITY=4

MAX_ASYNC_BATCHING_JOBS=3

//SmallPartRejectRadius=4.0

 

[TrafficManager]

AirlineDensity=25

GADensity=0

FreewayDensity=6

ShipsAndFerriesDensity=9

LeisureBoatsDensity=11

IFROnly=0

AIRPORT_SCENERY_DENSITY=3

 

[TERRAIN]

LOD_RADIUS=4.500000

MESH_COMPLEXITY=100

MESH_RESOLUTION=24

TEXTURE_RESOLUTION=28

AUTOGEN_DENSITY=2

DETAIL_TEXTURE=1

WATER_EFFECTS=6

TERRAIN_MAX_AUTOGEN_BUILDINGS_PER_CELL=907

TERRAIN_MAX_AUTOGEN_TREES_PER_CELL=1376

SWAP_WAIT_TIMEOUT=30  //number of frames that terrain engine waits for terrain textures loaded //into video memory before forcing new tiles of terrain triangles to be rendered.

 

 

[AContain]

ShowLabels=0

ShowUserLabel=0

ShowLabelManufacturer=0

ShowLabelModel=1

ShowLabelTailNumber=0

ShowLabelDistance=1

ShowLabelAltitude=1

ShowLabelAirline=0

ShowLabelAirlineAndFlightNumber=0

ShowLabelFlightPlan=0

ShowLabelContainerId=0

ShowLabelAirspeed=0

ShowLabelHeading=0

LabelDelay=1000

LabelColor=FFFF0000

 

[iNTERNATIONAL]

ASLAT=2

ASLON=1

MEASURE=0

 

[REALISM]

PFactor=1.000000

Torque=1.000000

GyroEffect=1.000000

CrashTolerance=1.000000

General=1.000000

UnlimitedFuel=False

TrueAirspeed=False

AutoCoord=False

RealMixture=True

StressDamage=False

GEffect=False

ManualLights=True

GyroDrift=False

CrashWithDyn=False

CrashDetection=False

AutoTrim=False

AllowEngineDamage=False

 

[sIM]

SYSCLOCK=1

 

[sTARTUP]

DEMO=0

SHOW_OPENING_SCREEN=1

STARTUP_DEMO=

LoadWindow=1

 

[FACILITIES]

COUNTRY=

STATE=

CITY=

GTL_BUTTON=1272

 

[Misc]

Com_Rate=7

 

[Trusted]

G:\FSX\fsdreamteam\couatl\couatl.exe.wakracahrewqtnnaniowroklnzkrttkzbubwkber=1

G:\FSX\bglmanx.dll.cothoazeqekkbezkeclhobubrquabozhwcbzzcrz=1

G:\FSX\ORBX\FTX_AU\FTXAA_ORBXLIBS\Scenery\ObjectFlow.dll.etetiikczuobwiblkaakurcokbibbooncttbwkai=1

G:\FSX\PMDG\DLLs\PMDGOptions.dll.qicwllrceqeewcclnchitanlcrqqcubchkeqozke=1

G:\FSX\PMDG\DLLs\PMDGEvents.dll.nbzuitikbtoucqlrnzqkbezlcooriubqquikhwor=1

G:\FSX\PMDG\DLLs\PMDGSounds.dll.icrqebeklkbrritouwcbzehwtlkkciwhozqzhrhw=1

G:\FSX\PMDG\DLLs\PMDG_HUD_interface.dll.rcezzcziuniubqkrlihzchzlroouolaktobuctqe=1

G:\FSX\PMDG\DLLs\PMDG_Interface.dll.tablkibhhwwiibtbcaehuqrrcceekaqohqeiezuq=1

G:\FSX\RAASPRO\RAASPRO.dll.rcurooaclbiirlckanoezkarnleqnteiwoahtton=1

E:\FSrecorder\FSRecorder_FSX.dll.uiilizttlkhnqtrctzrnethznnhelqwhibkkhqzh=1

G:\FSX\Modules\FSUIPC4.dll.hkiqzizkwhalhwrtkuhelhweulqhhuowkocbheoo=1

G:\FSX\as_srv\as_btstrp.dll.tizarhalzurkqbtkittzkqieabbbtlutlqbhiczn=1

G:\FSX\GAUGES\PMDG_777X.DLL.huabooqilczotncnztbihbkaurkhtnubneenoowt=2

 

 

 

[FlightPlanMap]

LineWidth=2

SHOW_AIRPORTS=1

SHOW_VORS=1

SHOW_NDBS=1

SHOW_APPROACHES=1

SHOW_INTERSECTIONS=1

SHOW_VICTOR=0

SHOW_JET=0

SHOW_AIRSPACE=1

SHOW_FLIGHTPLAN=1

SHOW_WEATHERSTATIONS=1

SHOW_WEATHERSYSTEMS=1

SHOW_DATATAGS=1

SHOW_TERRAIN=1

show_waypoints=1

show_airways=1

show_markers=1

show_volume_boundaries=1

show_ac_twr=1

 

[MAPVIEW_MAP]

SHOW_AIRPORTS=1

SHOW_VORS=1

SHOW_NDBS=1

SHOW_APPROACHES=1

SHOW_INTERSECTIONS=0

SHOW_VICTOR=0

SHOW_JET=0

SHOW_AIRSPACE=1

SHOW_FLIGHTPLAN=1

SHOW_WEATHERSTATIONS=1

SHOW_WEATHERSYSTEMS=1

SHOW_DATATAGS=1

SHOW_TERRAIN=1

show_flight_history=1

 

[AccelerationPack]

ControlsFirstRun=0

HomePageFirstRun=0

 

 

[DISPLAY.Device.NVIDIA GeForce GTX 780 Ti .0.0]

Mode=1920x1080x32

AntiAlias=1

Anisotropic=1

[MULTIPLAYER]

condAccoutPassword=0


The error is found below


Faulting application name: fsx.exe, version: 10.0.61472.0, time stamp: 0x475e17d3

Faulting module name: nvwgf2um.dll, version: 9.18.13.4752, time stamp: 0x54d3aea2

Exception code: 0xc0000005

Fault offset: 0x005b6e72

Faulting process id: 0x16dc

Faulting application start time: 0x01d060cdd15503e0

Faulting application path: G:\FSX\fsx.exe

Faulting module path: C:\Windows\system32\nvwgf2um.dll

Report Id: 58bebbab-cccc-11e4-9b44-60a44cb05a0f


 

There doesn't seem to be much info for this crash and I've done the obvious (in my mind) of removing the driver completly and starting fresh.

Any help would be greatly appreciated.

Thank you!

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Your Nvidia video card driver is causing this crash - https://forums.geforce.com/default/topic/413110/geforce-drivers/the-nvlddmkm-error-what-is-it-an-fyi-for-those-seeing-this-issue/. It could be caused by too high or too low video card voltages or if you have a bad or PSU that is not very powerful, this would cause it too. Power supplies are needed to make other components run properly. It could also be your video card drivers as the ones you have installed are very old.

I see in your FSX.cfg you have several tweaks. The worse one is the Bufferpools tweak. I see more people coming to this forum with problems and see they have the Bufferpool tweak enabled and it simply is the worst tweak out there for computer systems like yours. Why you need a tweak to use the video card memory as the texture buffer is unknown. It could provide improvements but may produce artifacts, memory spikes, and many times crashes (as taken from Page 4 of the AVSIM FSX Configuration Guide). I would never use a Bufferpools tweak today in modern computer systems like yours.

Best regards,

Share this post


Link to post
Share on other sites

Hello Jim.

1) Thank you for trying to help me!

2) I did not touch the video voltage (or try to OC it) and have a 1000w power supply. Should I have higher?

3) I checked for current nVidia driver and it is listing the driver I have (347.88) as the most up to date. Is there a more up to date version elsewhere?

 

Thanks again!

Share this post


Link to post
Share on other sites

Update:

I noticed that a pause would occur when ATC was speaking. Usually FSX would crash during ATC speech or right after.

 

When I looked everywhere for a sound problem, I saw in my Event Viewer Logs (Audit logs (looking for failures))

 

\Device\HarddiskVolume2\Windows\System32\sxs.dll

 

Researching it seemed to be a problem with RealTek audio and the onboard sound of ASUS mother boards.I have AS40 headsets (SPDIF) and had them setup for 7.1 surround sound in the RealTek audio manager. I have gone from surround sound 7.1 to stereo and all is working thus far.

 

7.1 works in every other game I have thus far.

 

Hopefully this works.

Share this post


Link to post
Share on other sites

I checked for current nVidia driver and it is listing the driver I have (347.88) as the most up to date. Is there a more up to date version elsewhere?

This is your problem. You state you have 347.88 Nvidia drivers installed (and I did not see that) BUT your faulting module indicates the nVidia driver that failed is version 347.52.  Maybe you thought you have v 347.88 installed:

 

Faulting module name: nvwgf2um.dll, version: 9.18.13.4752, time stamp: 0x54d3aea2

 

The problem is with your nVidia drivers, not your sound.

 

The other problem with your sound is a known problem - http://www.simforums.com/forums/win7-securityauditing-failure-eventid-6281_topic47216.html. I do not know if that problem has been fixed yet.

 

Best regards,

Share this post


Link to post
Share on other sites

Hello again Jim.

 

The GeForce Experience reported the current driver.

 

I plan to:

1) clean uninstall the driver then reinstall

2) reinstall the Realtek and turn the sounds back to where they were and observe if the crashes/errors occur

 

I'll update this thread regardless of the outcome.

Share this post


Link to post
Share on other sites

Update:

Crash has reoccurred

 

Faulting application name: fsx.exe, version: 10.0.61472.0, time stamp: 0x475e17d3
Faulting module name: nvwgf2um.dll, version: 9.18.13.4788, time stamp: 0x5503046a
Exception code: 0xc0000005
Fault offset: 0x000a6b00
Faulting process id: 0x1388
Faulting application start time: 0x01d063e73c268251
Faulting application path: G:\FSX\fsx.exe
Faulting module path: C:\Windows\system32\nvwgf2um.dll
Report Id: 4e0ca1fb-cfdd-11e4-8835-60a44cb05a0f

Share this post


Link to post
Share on other sites

I would try commenting out the usepool tweak in your config. Other than that, I have no other suggestions. The nvwgf2um.dll is rare reason for a crash so there must be something in your computer system or FSX.cfg that is causing it.

 

Best regards,

Share this post


Link to post
Share on other sites

Thank you again Jim.

 

I'll try slashing it out. At least if it does not function I have a work around till I go full time P3D.

 

If anything not already mentioned in this thread occurs, I'll come back and update.

Share this post


Link to post
Share on other sites

How is the progress. I am having this issue too with the MilViz Phantom. My card is an old card but it runs 99% of the addons including JF Canberra, Avro Anson, B-52 Captain Sim, all Dino Cattenao's planes, RealAir Turbine V2, MilViz Stuka, Learjet 25B nd numerous freeware.

 

The thing is, my card only supports DX9/10 prorgams while milviz is using DX11 optimized feature in running the night lighting and the ACM. But they say as long as the card supports DX10,it should be ok. It turned out that whenever I load up the aircraft, the sim crash because of nvwgf2um.dll.

 

It seems no one has experiencing the same issue like mine. The next build should fix the issue but I am a bit worried that the issue is on my part. I tried most of what you did, rolling back to older drivers before 310 which is known to have causing the issue but it didnt work.

 

Iam 99.9% sure this is also related to dx11 nightlighting issue.

Share this post


Link to post
Share on other sites

The system in the F-4 uses DX10 or 11 depending on which one loads successfully. FWIW im using driver version 347.25.

Share this post


Link to post
Share on other sites

So far I'm testing the draconian method of renaming the offending file so it's not called. It has been a success so far but may be too early to tell.

 

Edit: Works once then stops. Still trying

Share this post


Link to post
Share on other sites

Throwing in the towel. I hope someone finds out what's going on... Pretty disappointed...

 

Focusing on the issue Jim bought up with it being a bad driver, I uninstalled and deleted the nVidia drivers. Went through the registry as well to remove all pieces. Reinstalled the latest driver, setup the flight and within a few minutes...crash with the same .dll...

 

Can't figure this one out

Share this post


Link to post
Share on other sites

Almost everyone who has FSX/P3D installed uses the same nVidia drivers you all are using.  So there is something different in your installation/configuration from everyone who has an nvidia card installed.  As I stated above, the usepools tweak directs texture buffering to your video card memory instead of your computer system.  Many people do not use this tweak.  There could be something wrong with your video card too but that is less likely.

 

DX11 can only be used for P3D and I thin X-Plane.  It is impossible for it to work in FSX.  FSX can only use DX10 Preview.  FSX-SE DX10 Preview only.  P3D can use DX11 and does use DX11.

 

You might want to scan your system for corrupted drivers too - http://pcsupport.about.com/od/toolsofthetrade/ht/sfc-scannow.htm.

 

Best regards,

Share this post


Link to post
Share on other sites

Hi again Jim.

I've tried the sfc /scannow... 100% integrity. Only thing I can think of is to re install FSX, but it looks like a driver issue so that wont help anything...

 

By the way, I play several other games and FSX is the only program giving this error...

Share this post


Link to post
Share on other sites

Jim, the DX10/11 in use in Gorky's problem with the Milviz Phantom is my custom rendering system for cockpit lighting and for the config manager UI. It would be correct to say that its DX11 interacting with DX9. FSX is still rendering its scenery and aircraft etc with DX9/10. The 2 run side by side quite happily on most systems.

Share this post


Link to post
Share on other sites

I understand. Your program still cannot run in DX11 mode even though you developed your product for DX11. This could be the OP's problem and reason for this module to crash. It's a rare crash and one of the reasons it was not included in the AVSIM CTD Guide.

 

Best regards,

Share this post


Link to post
Share on other sites

Yes, we are trying to fix the OP's issue(s) and many tag on to the same topic and do not start a new one causing all kinds of problems and wrong advice for the OP. I should have split these posts into two different topics a long time ago to avoid confusion.

 

Apologize for furthering the confusion.

Share this post


Link to post
Share on other sites

Uninstalled Realtek. Crash still occurs.

Default fsx config. Crash still occurs.

Completed a flight from lszh to OMDB but suffered OOM on landing using DX 9 (using PMDG 777)

Share this post


Link to post
Share on other sites

(Just in case others have the same issue)

 

Problem: FSX crashes appearing to suffer a driver crash.

 

Solution

1) Uninstalled Realtek driver

2) Uninstalled GEForce Experienece I think this is/was the problem. Flying as normal. No crash/no errors since.

 

Thanks for those who tried to help.

Share this post


Link to post
Share on other sites

Had this crash several times with P3D 2.5 all within 15 or so minutes after taking off. Uninstalled Geforce Experience and completed a 2 hour flight with no crash. Fingers crossed!

Share this post


Link to post
Share on other sites

I don't have the Realtek drivers installed but do have GEForce Experience and no CTD's with FSX/P3D. Strange. You would think this happens to everyone under the same scenario.

 

Best regards,

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this