Sign in to follow this  
bjratchf

How to DSR

Recommended Posts

Does anyone know how to use DSR- I believe I'm doing it incorrectly.

 

In the NVIDIA settings (global), I check the boxes for the available resolutions... Then in P3D, I select a higher than native resolution, 3840x2160 for example. Do I go into fullscreen mode now? The result is basically a slide show with 0.2 FPS- and I can only recover by taking it out of fullscreen.

 

Or... do I set my windows resolution higher and then in-game, set the resolution to native? 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

from another discussion - To set up DSR: With the NVidia Control Panel, Manage 3D Settings, Global Settings, DSR - Factors, check 1.2x, 1.5x, 2.0x for now. Also set DSR - Smoothness set 25% for now. Press Apply.

 

Next run up P3D, go into Display Settings, depending on the GPU card, there may be several extra screen resolution items higher than the maximum display screen resolution. Choose the first one, this corresponds to 1.2xDSR (or the first Factor checked in the CP). Back to the sim window press the key combination ALT+ENTER at least twice, and again finally to arrive back in the full screen window. The on-screen menu and warning texts should be smaller - the larger resolution than the monitor has been downscaled into the monitor screen resolution. Try the other P3D screen resolution settings going higher. If after pressing ALT+ENTER the menu and text is not appearing smaller still, then the DSR Factor is too great and has not worked - we must choose a DSR Factor that works with the GPU Card.

 

DSR actually tries to recreate the original image as accurately as possible smaller to fit the screen size, so we have to choose the DSR - Smoothness to get the antialiasing effect we want.

 

P3D has more to do graphically than similar FSX, so choosing to display at higher resolutions, with bigger monitors or using DSR Factors, decreases performance more readily than FSX.

 

...you can set DSR on the desktop but you might not want to alter that generally.

Share this post


Link to post

Ah I see.... it's working now- takes a few ALT+ENTER iterations to get it synced, and I see how there's a performance impact the higher resolution you go. Thanks for your help!

Share this post


Link to post

Sometimes alt+enter doesn't work and if you close P3D down and restart it will work had to do that a few times - great explanation Steve as always  :drinks:

Share this post


Link to post

DSR only helps with anti aliasing or it does something more?

Share this post


Link to post

DSR fools your GPU into thinking it has a bigger screen res, so the sim outputs a larger image with more pixels. Remember though that a larger image takes longer for the sim to produce. Then when this is scaled down onto the smaller monitor, the image is kept as true as it can be with less pixels to display it, which produces a kind of antialiasing. However the image is reproduced smaller and as accurately as possible, so a jagged image will be reproduced as a smaller jagged image, with slightly less jaggedness obfuscated by the reduction into less pixels. The higher smoothing settings take care of extra smoothing up in the image by taking wider samples from the bigger image, to render the pixels in the smaller image.

Share this post


Link to post

Steve - I mentioned it in the prior post but DSR doesn't work for me. Wondering whether it's the dual monitors or the SLI configuration.

 

I don't need it but just curious. I get the selections per monitor in P3D - they just do not "take".

 

Vic

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this