Sign in to follow this  
lionelr

777 Intermittently freezes in P3D

Recommended Posts

I have installed the 777 for P3D and find that it is easy and great to fly. A very nice product.

However, it will intermittently freeze when I fly her.

 

I have an i7 CPU 920@2.67ghz

12 GIG RAM with a 64bit windows instillation.

 

Hopefully there is an answer somewhere for this problem.

 

Yours truly & sincerely,

 lionelr

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

 

 


Yours truly & sincerely,
 lionelr

 

Welcome to the forum. It's a rule here to include full names in your signature. Please do so in the future.

Share this post


Link to post
Share on other sites

There is an AVSIM Prepar3D forum nearby, frequent posts on stutters and performance over there.

Share this post


Link to post
Share on other sites

Do you by chance also use Active Sky Next?

 

Try to set your AffinityMask setting in the FSX.cfg if you have not done so. It cured my stutters. A problem that also bothered me before.

Share this post


Link to post
Share on other sites

AffinityMask is not required by P3D, it will use all the cores available to it.

 

FSX/FSXSE is a different story.

Share this post


Link to post
Share on other sites

Success, I have made Auto Save in FCUIPC rung every 300seconds, no auto-saving on the ground and I re-installed in safe mode. Thanks for the heads up guys.

 

Yours truly & sincerely,

Lionel Rockman.

Share this post


Link to post
Share on other sites

do you run unlimited frames? I had freezes almost every flight with fps locked at 30 in game, changed to unlimited and 2 days straight of problem free flying.

Share this post


Link to post
Share on other sites

do you run unlimited frames? I had freezes almost every flight with fps locked at 30 in game, changed to unlimited and 2 days straight of problem free flying.

Full names in the PMDG forums please.

 

I run unlimited in-game with NI set to 32 fps limit without any stutter, except the micro stutters that are only noticed when looking out side window down at terrain... those seem to persist regardless.  Also, 30 limit is not good because it might interfere with 60 fps refresh rate of video buffers.  Best to use something like 32 or 35.

Share this post


Link to post
Share on other sites

I actually have it set to 20fps and have no problems. Will try unlimited but will be surprised if it makes a difference as the sim really reaches 20.

 

Lionel Rockman.

Share this post


Link to post
Share on other sites

 

 


the sim really reaches 20.

 

Lionel, assuming you have a mid-range or faster CPU, you should be seeing 30's in the PMDG cockpit.  Your problem is not stutters but something else, Have you set [sIM] OPTIMIZE_PARTS = 1 (default is 0) and also Introduction recommendations beginning page 22?

Share this post


Link to post
Share on other sites

Hi Dan,No I have not done the modification you are refering too. What file do you do this in the P3D.cfg or some other file?

 

Lionel Rockman

Share this post


Link to post
Share on other sites

Hi Dan,No I have not done the modification you are refering too. What file do you do this in the P3D.cfg or some other file?

 

Lionel Rockman

Lionel, you should read the Introduction that comes with the product.  There are only a few 'tweaks' required in the Prepar3D.cfg file but they are important including optimize parts and load all or something like that.  Starts on page 22 for P3D installation and 24 for the config file.

 

And if you have not read the introduction, you may not have flown the tutorial, which is also important.

Share this post


Link to post
Share on other sites

For others with this issue but who don't have FSUIPC auto-save turned on, I wanted to add the following:

 

My VA's ACARS utility apparently also has a flight auto-save feature turned on by default. The PMDG 777 was hitching every several minutes, often times at a critical moment in flight.  Indeed, it was the virtual airline's ACARS utility autosave which was the culprit for me. I just wrapped up a flight with the option turned off and had no interruptions at all.

 

Be sure to look at all possibilities if you're troubleshooting this issue - it might not be FSUIPC hitting you with an autosave!

 

-Greg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this