Sign in to follow this  
Sesquashtoo

W2XP frame-rate dump....er....

Recommended Posts

Well, I just loaded up a whole pile of European W2XP HD files, loaded up all or the USA and Canada, and then went for a flight. Have the latest WORLD Scenery Models as well..all that is required to run 0.7.2

 

Well...at Berlin...my system (with no parameter alterations that always gave me 30 plus FPS, with SimHeaven's regular OSM data files...etc) was stuttering and chunking along at 5-7 FPS.  So...here's the question...what are others running their XPX.35 setup with....detail levels...etc...to get a frame rate (at least 20) that you can use?!!??

 

...and there are no neighborhoods of densely packed houses,like any that I have seen in pictures and videos. This is what I am seeing upon rotation.  Is this right?:

 

Car_C337_5.png

 

 

 

Any suggestions?

 

Ses

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

OK...so I'm the only one running W2XP files...jeez..apparently...lol

 

(silence.......).

Share this post


Link to post
Share on other sites

Tony's in the UK and it's the middle of the night there so you'll need to wait for a professional opinion. 

 

I can't help with the frames issue (I'm not seeing any noticeable frames difference to 0.6), but as for the issue with blank areas, it's simply incomplete OSM data in the files you downloaded. You need to enable smart exclusions in the config file and you can find out how to do that here:

 

http://forum.avsim.net/topic/433700-introducing-world2xplane/?p=3075666

Share this post


Link to post
Share on other sites

Actually I'm in Poland, but only 1 hour difference :-).
 
Anyway Mitch, this is the problem with W2XP scenery in large cities. Basically, the major difference between this and the OSM Europe scenery is that W2XP tries to place a building which matches colour and height. This means in a large area there might be thousands of custom buildings used (which causes a massive hit in FPS), whereas OSM scenery makes use of a basic set of 5 or 6 facades. Also the gaps you are seeing might actually be realistic, there might simply be no buildings in the area. The problem is that ground textures don't match (but if you use photoscenery, they'd line up perfectly and look much more realistic). 

I think it's simply unrealistic on today's hardware to have every single building created with the correct colour,size and shape. But, fear not, I'm working on solutions to both of these problems using autogen. Here are some "very early" work-in-progress shots of Prague (a FPS killer):

Alabeo_R66_1.jpg

Alabeo_R66_2.jpg

The FPS hit is not bad at all for my laptop, 20fps is quite flyable over a city centre. 

 

The idea is not to trace every building with an exact shape but to place autogen in a believable way. e.g. W2XP works out where the city centre is, and also looks for things like "Old Town", "Stary Rynek", etc and places older European buildings based on the names or the areas. So you get cities and towns which are recognisable, i.e. You'll see the market square and old town, and the commercial district, etc..

 

I still have some way to go to get it looking nicer, i.e. Less randomisation of building types and corner/angled buildings, but I think the results will be worth it, so bare with me :-)

Share this post


Link to post
Share on other sites

Glad you are still working on this project Tony, I thought I read another post that said you'd given up. This and G2xpl are the best addons that can be had for XP. I only noticed about 2fps difference between running W2XP scenery using the regular and HD configs to generate, 30 became 28 which is perfectly usable. I suppose it depends on the machine it's run on. Having said that, Dublin doesn't have anywhere near as many buildings as shown in Prague, I can envisage problems when it gets to that stage alright.

Share this post


Link to post
Share on other sites

 

 


Glad you are still working on this project Tony, I thought I read another post that said you'd given up.

 

I have mostly, at least in regards to W2XP being a community effort and application for scenery development, people (and I mean other developers here) simply don't want to help out and work together. The autogen I'm doing is completely different than what W2XP was originally meant to do, and most probably (Just like GB Pro), I'll more than likely only release the scenery and not the actual program (Or should I say collection of scripts) to generate it unless someone knows what they're doing and wants to create scenery (Like Simheaven).

 

 

 


Dublin doesn't have anywhere near as many buildings as shown in Prague, I can envisage problems when it gets to that stage alright.

 

Yep, once every single building is mapped with height and colour information, it would suffer the same problems as Berlin or Prague. I guess you're not seeing much of a difference between HD and SD because there isn't much data in Ireland that the HD scenery would use.

Share this post


Link to post
Share on other sites

About 3 weeks ago. It's basically the same as 0.7.1 with some minor bug fixes, but nothing new. 

Share this post


Link to post
Share on other sites

my 980 4gb and 24gb of ram laughs in W2XP's face :lol: no fps issues, smooooooooth flying.....love it.

Share this post


Link to post
Share on other sites

Thanks Tony and all...will check my smart ex settings Thanks again. A lot explained for what I was seeing

 

Ses

Share this post


Link to post
Share on other sites

 

 


You need to enable smart exclusions in the config file and you can find out how to do that here:

 

----------------------------

 

Where are the locations of the config.xml file?!?!?!?   Can't find them...

 

Thanks...

Share this post


Link to post
Share on other sites

----------------------------

 

Where are the locations of the config.xml file?!?!?!?   Can't find them...

 

Thanks...

 

 

it is under Resources of W2XP app.

Share this post


Link to post
Share on other sites

In the resources folder that comes with W2XP. You need to open up config-hd.xml (or config.xml, whichever one you use), find the line that says <smart-exclusions>false</smart-exclusions> and change it to <smart-exclusions>true</smart-exclusions>

 

However, you will also need to regenerate the scenery yourself, and didn't you download the scenery pregenerated from Simheaven anyway? I thought their HD sceneries had this option already.

Share this post


Link to post
Share on other sites

In the resources folder that comes with W2XP. You need to open up config-hd.xml (or config.xml, whichever one you use), find the line that says <smart-exclusions>false</smart-exclusions> and change it to <smart-exclusions>true</smart-exclusions>

 

However, you will also need to regenerate the scenery yourself, and didn't you download the scenery pregenerated from Simheaven anyway? I thought their HD sceneries had this option already.

Hi Tony!

 

Yes, I did download the SimHeaven, xxx.osm-ag and the xxx.osm-hd, pre-generated.  So Tony, that would already have this enabled...and I'd be locked and loaded?   Thanks for your help.  BTW...the SimHeaven OSG-AG for the USA and Canada, looks great...   So...with the above loaded in...am I all set to go?  :))))  Thanks for all your help...and to all the others who are helping me to enjoy and use this!!!

 

Mitch

Share this post


Link to post
Share on other sites

Tony...this is REALLY GOOD STUFF!  I am now getting 30 FPS in Italy_osm_ag...and eveything looks great. Yes..there are some areas that lack buildings...but you have explained that...

 

Here is a snap...with the FPS popping out good numbers!

 

Thank you very much for this, your work....wow!

 

Car_C337_8.png

 

Mitch/Ses

Share this post


Link to post
Share on other sites

As the O.P., I declare this thread's topic..redundant.  I have it figured out...and am getting 20-30 FPS in all SimHeaven xxx_osn_ag scenery and full country files. The output is drop-dead gorgeous!  THESE files..were the ones I was waiting for, to bring osm-deprived USA and Canada to life.  

 

Wow....

 

Ses

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this