Sign in to follow this  
sidfadc

Cloud issue in DX10

Recommended Posts

Hi guys,

 

Since the upgrade to DX10 I can see clouds in the distance kind of drawing themselves as I get closer.  Difficult to describe in words.  So in the distance I can see half a cloud and it will draw itself piece by piece kind of like a jigsaw.  I used to use Rex as the weather engine but have recently purchased Active Sky Next and the same problem occurs so it can't be weather engine related.  I've tried adjusting cloud options in ASN, through the Weather tab in FSX itself and also in the DX10 configuration.  Admittedly I'm not sure what I should be changing to prevent this issue or whether its a known issue with DX10 or not? 

 

In FSX I have Maximum detailed clouds and in active sky I have the cloud coverage at 90 I believe.  I have played with the sliders but to no avail.

 

Any help appreciated.

 

Cheers

Thomas

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

You could try messing with visibility, although I have a feeling this is somewhat unavoidable. Happens occasionally to me as well. If someone has a fix, it's welcome.

Share this post


Link to post
Share on other sites

Yep I have fiddled with visibility settings but no joy.  I'm just hoping someone can suggest preferable slider settings to minimise the issue if possible.

Share this post


Link to post
Share on other sites

Do you have Cloud Cull ticked in the Dx10SF clouds dialog?  that can cause something like you describe.  Generally in FSX Dx9 and Dx10 dense clouds a cloud can pop where one appears in from of another but that doesn't sound like what you are describing here.

Share this post


Link to post
Share on other sites

Thanks Steve I have played with that option but will give it another go. Is there any other options I should be aware of to reduce the effect?

Share this post


Link to post
Share on other sites

I would actually suggest that start your testing by disabling the cloud shader - go into the debug  dialog and untick it - you are then using the default shader - if the problem still occurs then it has nothing to do with the fixer.

Share this post


Link to post
Share on other sites

thanks Steve I will give it a go and let you know.

 

Out of curiosity what are the negative effects of turning off the dx10 shader if any?

Share this post


Link to post
Share on other sites

If you disable the DX10 fixer changes in the debug dialog you will lose a little performance. 

 

However I am not suggesting that you leave it turned off.  I just want a quick and simple test to determine if what you are seeing is anything to do with me. 

 

If it is then we can explore further, however if it is isn't then it is probably just the way FSX is in which case re-enable the shader changes.

Share this post


Link to post
Share on other sites

Hi Steve,

 

I have flown from London to Vienna and back again and can co firm I have not encountered this issue with the cloud shader disabled. I probably need to do a bit more testing but so far so good.

 

Cheers

Share this post


Link to post
Share on other sites

Hi. 

 

Same problem here.

 

My cloud settings:

Disable MSAA OFF

Cloud clip ON

Cloud cull OFF

Discard fogged ON

Missing texture fix OFF

 

Duran.

Share this post


Link to post
Share on other sites

I really doubt it has anything to do with the fixer, I think what is being described is the injection of weather when flying between two weather stations.

Share this post


Link to post
Share on other sites

Hi Steve.

 

Sorry, no weather engine running... just the fair weather theme.

I just set the aircraft at the gate (EGKK for instance) and go to tower view.

Then, as EZDOK's tower view moves away, clouds artifacts  take place.

 

Duran.

Share this post


Link to post
Share on other sites

Hi again, Steve.

 

Maybe the clouds' artifacts are related to FSX camera's settings.

 

Take a look at the screenshots bellow.

 

1- https://drive.google.com/open?id=0B3Pq5EQeDYFiT25hUEwtTkN6Wms

2- https://drive.google.com/open?id=0B3Pq5EQeDYFiTmxwRFY4TTg2WTQ

3- https://drive.google.com/open?id=0B3Pq5EQeDYFiRE9pZGdZNlFEa0E

 

#1 and #2 are tower and flyby cameras.

#2 is a locked spot camera.

 

Artifacts in #1 and #2 occur only at zoom levels less than 0.4... as there was a mask concealing higher clouds layer.

 

There is no artifact at #3, no matter the zoom factor.

 

Looking at cameras.cfg file...

 

Tower and Flyby - Clip mode = Tower

Locked Spot - Clip mode = Spot

 

If this is the case, the artifacts are not related to the fixer, indeed.

 

 

Regards, Duran

 

 

[Edited #1]

 

I changed Flyby camera's clip mode to Spot and ...

 

https://drive.google.com/open?id=0B3Pq5EQeDYFiYWZFZjB6TmFBcVU

 

... the artifact (mask?) is gone... Why does this happen??? Have no idea.

 

 

Duran.

 

 

[Edited #2]

 

Download the images to your computer, so you can see them correctly.

Share this post


Link to post
Share on other sites

The clip modes are explained sort of in the SDK .  If you don't have the SDK then try googling for Microsoft ESP and read the equivalent SDK doc there.

 

Tower view is intended for viewing close up objects and sets the far clip plane at 20Km so anything beyond 20K including sections of the sky texture are discarded.

Share this post


Link to post
Share on other sites

Hi guys,

 

This is going over my head a little now. 

 

All I will say is I've done some extensive flying with the DX10 Shader turned off in Debug and I can confirm I have not experiencing any clouds "drawing themselves" in the distance.  So my question is if I turn the shader back on in Debug what troubleshooting steps can I take to resolve?  I'll be honest I can't really see what turning the shader off does, looks exactly the same as before and my performance hasn't really suffered so I'm more than happy to leave the shader off as a long term solution.

 

Cheers

Share this post


Link to post
Share on other sites

If you are happy and cannot see a difference then I would suggest leaving it the way that it is!

Share this post


Link to post
Share on other sites

I know this thread is a year and a half old, but I purchased Steve's Fixer and have been generally very pleased with it.  The only problem I've had is the one described in this thread by sidfadc.  I, too, turned Cloud Shader off in debug mode and the problem went away.  Has anyone solved this so that you could use the Cloud Shader?  I couldn't find anything else like it anywhere else. 

Share this post


Link to post
Share on other sites

The only option that should cause the effect is cloud cull which is only intended for people with low end GPUs.

 

So reenable the shader and turn off cloud cull.

 

If you still have the problem then disable all the options and test. If it's ok, turn them on one at a time and test although none of the others should cause anything like described.

 

Note one person in this thread was reporting a similar issue which is to do with the camera setup and had nothing to do with the fixer.

Share this post


Link to post
Share on other sites

Well, I might take your advice at some time in the future, Steve, but I think I'll just enjoy things the way they are right now.  The cloud issue is gone and by golly, everything looks pretty darn good the way it is with the Cloud Shader turned off.  Thanks, just the same.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this