Sign in to follow this  
mccurdypm

P3D v3 and TrackIR

Recommended Posts

Hello,

 

Has anyone been able to get TrackIR working with V3?

I've installed all the simconnect version that came with V3, it detects my TrackIR (both lights are on) but doesn't work.

 

So far, HDR changes are nice, VAS usage seems better, I cant really tell since I dont have any add ons.

thanks.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Worked without a problem here. I still have v2.5 installed and also Simconnect so I didn't need to install it manually. TrackIR worked right away. I only have the Simconnect SP2 installed.

Share this post


Link to post

J it does not work for me but I use EZDOC do you?, because you have to change simconnect files.

Share this post


Link to post

J it does not work for me but I use EZDOC do you?, because you have to change simconnect files.

 I also use EZDok, which is why it doesn't work. I've managed to get EZDok working in V3 now. TrackIR works beautifully along with ezca :)

Share this post


Link to post

 I also use EZDok, which is why it doesn't work. I've managed to get EZDok working in V3 now. TrackIR works beautifully along with ezca :)

 

How did you manage EZDOK to get it working on V3? I have 1.186 version.

Share this post


Link to post

 I've managed to get EZDok working in V3 now. TrackIR works beautifully along with ezca :)

 

Can you tell us how?

Share this post


Link to post

Can you tell us how?

I don't know if this goes against the sticky topic 'Installing 3rd Party Software into Updated Versions of P3D' since the changes are text files that ezca configure.exe would edit anyways, nothing more.

 

I just used configs (exe.dll to load ezca and cameras.cfg) from v2.5 user prefs (Appdata, roaming .....) to v3 user prefs, thats all.

Share this post


Link to post

Thanks Bob,

watched the vid and now have EZDOC and TrackIR working, even better its loading my camera setting made in 2.5. Happy days.

Share this post


Link to post

This seems to be the medicine for those that have 2.5 installed.

 

Does TrackIR and Ezdok work with V3 if you have never had any other P3D versions installed?

 

Jas

Share this post


Link to post

If it is a fresh install of Prepar3d v3 with no other versions or Prepar3D or FSX, then you need to install the following:

Program Files (x86) (or wherever you have installed Prepar3D v3)\Lockheed Martin\Prepar3D v3\redist\Interface\FSX-SP2-XPACK\retail\lib\SimConnect.msi

 

Once installed, TrackIR 5 should work.

Share this post


Link to post

Yesterday I was at FlightSim 2015 at Cosford RAF Museum, UK. There was a stand of trackhat.org company. They (or he, it look like one person company) produce kind of TrackIR device compatibile with open source tracking software. Anyone of you using it already in any simulator? Maybe in P3D v3? :)

Share this post


Link to post

Yesterday I was at FlightSim 2015 at Cosford RAF Museum, UK. There was a stand of trackhat.org company. They (or he, it look like one person company) produce kind of TrackIR device compatibile with open source tracking software. Anyone of you using it already in any simulator? Maybe in P3D v3? :)

 

I've got one on order. We'll see. My TrackIR Clip has always been a bit frustrating, so I'm hoping the active LED's of the Trackhat will offer better ... errr ...  tracking. I'll report back in a week or two. It'll be for Prepar3D plus some other games (Elite, Rise of Flight, ARMA)

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this