Sign in to follow this  
Nduru

API.dll crash when opening Vpilot on V3

Recommended Posts

I started getting this CTD after installing Immersion for the airbus x, so uninstalled it as well as reinstalling vpilot...still no luck.

I also tried a new CFG but that didn't work. Any advice would be great :)

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Has vpilot been made compatible with P3D?  You may have to wait for an update.

 

Best regards,

Share this post


Link to post
Share on other sites

How did you get VPilot installed into V3?

VPilot does not install directly into the simulator. It is a standalone program that communicates with the simulator via simconnect. As long as you have the legacy simconnect client for FSX SP2/Acceleration installed on your computer, Vpilot should work with any simconnect-enabled simulator - FSX, FSX-SE, P3D 2.5 or P3D 3.0

 

P3D does not install the older simconnect clients by default, but it does include the installers for them in a folder called "redist" located in your main P3D installation folder.

Share this post


Link to post
Share on other sites

My Vpilot was working last week and now it keeps on crashing the sim, looks like i have to wait for an update :(

Share this post


Link to post
Share on other sites

Nope. I installed it and I can connect and talk to ATC, but none of the traffic loads. If I load into LAX (on a busy day) there is no other traffic modeled, not even default. But I can still change radio frq's and communicate with the controllers. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this