Sign in to follow this  
buzzlite3

Blurry LCD screens in P3D v3

Recommended Posts

Hi

 

I have recently switched to P3D v3 which is going well so far.

 

My only issue is that the interior of my 777 particularly the LCD screens are blurry.

 

They are readable but not as clear as they were in FSX.

 

If I undock them they are crystal clear, but not when docked.

 

The rest of the flight deck is a bit fuzzy as well

 

Does anyone have any ideas to help?

 

 

Cheers

David

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Turn down the "Master Brightness" on the upper panel - the standard-setting ist to shiny during daytime

Share this post


Link to post
Share on other sites

Turn down the "Master Brightness" on the upper panel - the standard-setting ist to shiny during daytime

 

This may help some, especially if you have HDR on (as turning the brightness down cuts back on the high levels that HDR exaggerates to simulate glare), but it won't help too much if FXAA is on.

  • Upvote 1

Share this post


Link to post
Share on other sites

I think that the bluriness you refer to is related to the "Mipmap VC Panels" setting on the display options.

If you turn off VC mipmapping the bluriness will go away, but then lines & text on the displays will show somehow "broken"

Personally, I prefer it with mipmapping on.

Share this post


Link to post
Share on other sites

same problem here but with the NGX, tried all those solution, and tried to turn things on/off in the settings one at a time, non is getting me a good result, do I need to give Nvidia Inspector a try ?

Share this post


Link to post
Share on other sites

same problem here but with the NGX, tried all those solution, and tried to turn things on/off in the settings one at a time, non is getting me a good result, do I need to give Nvidia Inspector a try ?

 

Turn off FXAA.

Adjust your HDR Bloom settings (or turn off HDR).

 

Either way, you must do both.

Share this post


Link to post
Share on other sites

I prefer to keep the VC Mipmap Panels option unchecked... it might work in the default aircraft but not so much in the PMDG VCs.

Share this post


Link to post
Share on other sites

indeed it was FXAA but in my nvidia control panel.

thanks for your help !

Share this post


Link to post
Share on other sites

but i think there is still room for improvment it's not chrystal clear like the 2d popup, i'm using a .53 zoom, what can I make to improve the clarity of the displays in VC ?

Share this post


Link to post
Share on other sites

A zoom of .53 is like a very wide angle lens.  Goodness, I never use anything less than .70 and usually either .80 or .90.  You just have to learn how to pan and zoom.

  • Upvote 1

Share this post


Link to post
Share on other sites

but i think there is still room for improvment it's not chrystal clear like the 2d popup, i'm using a .53 zoom, what can I make to improve the clarity of the displays in VC ?

 

Not use a .53 zoom.

 

If you have a widescreen monitor (anything other than the old 1990s 4:3 screen), use the wideviewaspect mod in the display settings. This will give you a better perspective.

Share this post


Link to post
Share on other sites

ow yeah, that was it ! I didnot understood first time i turned the wide aspect ratio, thanks for you're help !!

I keep mipmap panel but turned off HDR, I think now it's quite ok to fly without killing my eyes :-)

 

thanks a lot for your help !!

 

(starting simming again since years back in FS9)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this