Sign in to follow this  
AnkH

halo.bmp again... or: how to have nice AI Traffic lights?

Recommended Posts

Hi there,

 

I finally decided to switch from my full blown FSX to P3D v3. This weekend, I worked hours on migrating or installing newly my FSX addons into P3D, either by simply copy + pasting or by using the migration tool or even easier, by re-downloading the P3D v3 compatible variant of the addon.

 

Biggest culprit and also the reason I waited so long for the switch was my UT2 installation, which is now hugely modified both in respect to the flightplans but also in respect to the many ai planes (FAIB as a prominent example). Good news first: I managed to migrate my UT2 installation from FSX into P3D without installing anything new. That is great. BUT: my AI Traffic lights are messed up.

 

Right after the migration, I realized that first, the AI traffic lights are enormous. The size of the nav lights are about the size of the engine from a distance, same goes for the taxi and landing lights. Then I recalled, that I already had some issues with FSX and that I was able to solve them by using a modified "halo.bmp". Fair enough, I thought, I copied the "halo.bmp" from my FSX installation into P3D and checked my AI Traffic. Bummer, while the size of the nav and taxi lights were back to perfect, the "halo.bmp" I use now results in a transparent black square around the lightsource. Now I know that I was already struggling to have a correct "halo.bmp" in my FSX, but is there a similar solution for P3D? Is there somewhere a "halo.bmp" I can download that does not add enormous lights or black squares? Or is it somehow possible to modify the "halo.bmp" manually to remove the transparent black square or make the lights smaller?

 

Thanks for any help regarding this issue.

 

regards

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

There's an addon by Michael Swannick (I think thats his name) that does really well in this regard. He frequents the forum too-

 

fsx_lights.zip is the file name. Give it a try! 

Share this post


Link to post

Actually I tried those "halo.bmp" files from this zip, but with the results that there were none nav or taxi lights anymore on my planes. Have to check his thread, could you point me there? Thanks for the hint.

Share this post


Link to post

I changed all my AI lights to the default P3D lights. They still look a bit large at times but I'm happy with them. They are all visible in the distance now which never was the case in v2.5.

Share this post


Link to post

Well, I do as well. The problem is not the shockwave lights alone. I have this monstrous lights independent if the ai plane is using the shockwave light fx file or the P3D default fx file. As it changes depending on which halo.bmp I use, there must be a correlation with this file...

Share this post


Link to post

try deleting your DX10 shaders and let them rebuild

Share this post


Link to post

try deleting your DX10 shaders and let them rebuild

 

You are aware that we talk about P3D v3 here? Where do I find the DX10 shaders for Prepar3d?

 

Well, anyway, I deleted the only shaderfolder I found which is not part of the corefiles, this did not change anything (besides a crash of P3Dv3 upon exiting the sim...).

 

Still looks like that:

 

light_issuel6qln.jpg

 

At least the size of the coloured part is ok now, but still a black box around it (also in daylight)...

Share this post


Link to post

shaders are here

%USERPROFILE%\AppData\AppData\Local\Lockheed Martin\Prepar3D v3

 

you must have moved the default Halo.bmp from FSX to P3D, they use different alpha!

restore your original P3D Halo.bmp; should work different :smile:

Share this post


Link to post

Provided you didn't disable system protection you could always browse to the file and restore a shadow copy of the original (restore previous versions) Also HDR will inflate the size of the lights in general.

Share this post


Link to post

Did you actually read what I was writing in the first post? Yes, I had inflated monster lights with the original Halo.bmp from P3D (so replacing it serves nothing) and yes, I replaced it with the one from FSX resulting in above issue, that's why I was looking for someone with working AI lights to help me out.

 

Anyway, deleting the Shaders together with a brand new installation of REX4 Texture Direct finally solved the problem. Do not ask me which of the two steps was the essential one, but my lights do not have black boxes anymore now. Thank you all for your help!

  • Upvote 1

Share this post


Link to post

Hello guys,

I know is an old topic, but in case that any of you are still struggling with this nonsense I developed a freeware that improve the AI lights under PD3 V4.0 and V4.1, if you guys are interested just search for AI Lights Reborn inside the forums or google.

Best Regards,

Simbol

  • Like 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this