Sign in to follow this  
Manny

Is Flight1 GTN 750 updated to P3D V3.2?

Recommended Posts

I downloaded the  F1 GTN750 yesterday and its not working with the 3.2

 

I have run out of reactivation and had to reset it.

 

Before I go and download it again..could someone please confirm the latest install would work with 3.2?

 

Thanks

 

I wish F1 would simply set it for 3.x and not be so specific about .x version  and also the page is not speciofic ..it doesn't say its for 3.1 or 3.2

 

 

http://www.flight1.com/products.asp?product=f1gtn

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Manny, you need version 1.05 of the GTN 750, it works just fine with 3.2. If you use the update tool which comes with the GTN it should tell you if you have the latest version and update it if necessary.

 

Hope this helps.

Share this post


Link to post

Manny, you need version 1.05 of the GTN 750, it works just fine with 3.2. If you use the update tool which comes with the GTN it should tell you if you have the latest version and update it if necessary.

 

Hope this helps.

 

Thank you Hans. Yeah..the update tool did it.. I didn';t know about it. :P

 

This is so much better. 

Share this post


Link to post

Manny, you need version 1.05 of the GTN 750, it works just fine with 3.2. If you use the update tool which comes with the GTN it should tell you if you have the latest version and update it if necessary.

 

Hope this helps.

any idea why I lost the GTN 750?...just updated to p3dv3.2

jyREAO4.png

 

cheers,

Chas

Share this post


Link to post

 

 


any idea why I lost the GTN 750?...just updated to p3dv3.2
found the update utility....but now, Ive LOST ALL my GTN Flight plans!!

 

Help!!

 

Chas

Share this post


Link to post

"It's always something" as they sometimes say, in disbelief.

Share this post


Link to post

is it normal everytime im opening my GTN in my plane after few minute my pc freeze then crash? as soon i undock it it freeze few time after 

Share this post


Link to post

Well I just installed trainer first - 1.14 F1 P3D Installer -  then on desktop launch f1update tool and it updates to 1.05 and seems to be working fine in 3.2 - only tried the Aero Commander 500 so far

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this