Sign in to follow this  
flytrumpet767

Black(slow loading) textures

Recommended Posts

Hello all,

 

Long time member of Avsim finally making the switch to P3D after using every sim sim since FS2000. I've been on and off, like a lot of you I'm sure. But I think I'm now ready to come back.

 

To my question. I installed V3.2 and with the help from many topics in this forum am able to run it pretty smoothly on my new machine I7 6700K  @4.6,GTX970. I installed a couple of airports I was using in FSX, FT CYUL, CYYZ, and although FPS are at a solid locked 30, I'm seing black textures on buildings and AI planes as I pan around. I tried a bunch of "tweaks" to no avail. I'm probably missing an easy fix somewhere.

 

Thanks in advance for the help on this topic, as well as previous and future issues.

 

 

Cheers

 

Richard

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hi, you could try TextureMaxLoad=? in your P3D .cfg file, it goes in the DISPLAY section.

I use TextureMaxLoad=33 and reduced the texture load you are talking about almost to perfection.

hope it helps

Sergio

Share this post


Link to post

Bonjour Richard,

 

As mentionned by Sergio, adding TextureMaxLoad=33 in your DISPLAY section helps in reducing the texture load time. It is not present by default so you must add it yourself in your Prepar3D.cfg

 

I personally use the value 30 (you may try different values, but it must be a multiple of 3). To make it even snappier, still in the DISPLAY section, I also modified TEXTURE_BANDWIDTH_MULT=120 (the default value is 30 i think). It gives me very good results at FT CYUL.

 

Best regards,

 

Normand

Share this post


Link to post

Merci Normand!

 

Thanks for the advice guys. I'll play with those values. So far I'm liking P3D a lot.

Share this post


Link to post

This was very recently discussed in some depth.

 

http://www.avsim.com/topic/485164-texturemaxload/

 

Unfortunately the TBM and TML tweaks may not work for everyone. This is something new in 3.2. I have them too and they can't seem to go away.

 

Edit : I have the same exact CPU and GPU as you, running at 4.7.

 

Regards,

Shanan

Share this post


Link to post

Thanks guys, if I can only get rid of stutters that would be great. Reinstalling FSX SE to get a side by side comparison. Those stutters are annoying. Tried a lot of continuations of AF, and NI settings, you name it. Good performance, not some smooth flying.

Share this post


Link to post

Are you using Windows7 by chance? If so change your desktop theme to Aero under personalization. It made a HUGE difference on my system. I struggled with stutters since V2 and never could get NI or Control Panel to do much good in that regard.

Share this post


Link to post

Nope, Windows 10. Still experimenting to find a cure for stutters. It seems lowering texture resolutions helps a bit. Definitely a WIP to find smoothness in P3D. Using 4SGSS also kills fps in bad weather with ASN. Another issue altogether I guess

Share this post


Link to post

Try reverting drivers to 361.43. Cured stutters for many.

Share this post


Link to post

Thanks for the info. I did a quick test, unlimited fps in p3d, and locked in nvi at 30.5. New nvi is pretty strange with .5 frames. Very short test was definitely smoother. I think I har Vsync and buffering. I'll keep testing.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this