Sign in to follow this  
jetsmell

FaceTrackNoir Question

Recommended Posts

I purchased the Track Hat and I have the webcam that came with it, then downloaded FaceTrackNoir . I also downloaded the Code Driver for the webcam.

The problem is I'm not getting an image of myself with and without the Track Hat on. When I start FaceTrackNoir on the left box where my image is to be seen I see UDP.

The following is what I have ;

 

When I start up FaceTrackNoir the following is what I have;
Profile > default.ini

Tracker Source ( 1st Master ) > FaceTrackNoir UDP

Tracker Source ( 2nd ) > FaceTrackNoir UDP

Filter > None
EWMA Mk2

Game Protocal (1st and 2nd ) > CSV
Flight Gear
FaceTrackNoir
Mouse Look

In the window on the left where my face is seen instead I see >  UDP

I cannot bring up an image.

Is there a plug -in or protocol that is needed ?

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I think source of UDP is for FaceTrackNoIR to receive 6DOF streamed from another application.

Try changing source to PointTracker for a IR clip or FaceAPI for facial recognition to use the camera.

Share this post


Link to post
Share on other sites

I have facetracknoir but I have made a 3 clip IR and I use Pointracker 1.1, but I have now switched to Opentrack which is very good.

Share this post


Link to post
Share on other sites

I did a clean install and the same thing happens. When I start it on the left where I should see my image I see UDP. I'm really disappointed since I paid for FaceTrackNoir and the Code Lab driver. It's not much, but I expected more from this. I guess I'll use Open Track now instead.

Share this post


Link to post
Share on other sites

I'm assuming that you have the PS3 Eye camera.  Did you run the CL-Eye Test program that came with the CL drivers first to make sure the camera is working and set correctly?

 

Todd

Share this post


Link to post
Share on other sites

I purchased the Track Hat and I have the webcam that came with it, then downloaded FaceTrackNoir . I also downloaded the Code Driver for the webcam.

The problem is I'm not getting an image of myself with and without the Track Hat on. When I start FaceTrackNoir on the left box where my image is to be seen I see UDP.

The following is what I have ;

 

 

When I start up FaceTrackNoir the following is what I have;

Profile > default.ini

Tracker Source ( 1st Master ) > FaceTrackNoir UDP

Tracker Source ( 2nd ) > FaceTrackNoir UDP

Filter > None

EWMA Mk2

Game Protocal (1st and 2nd ) > CSV

Flight Gear

FaceTrackNoir

Mouse Look

In the window on the left where my face is seen instead I see > UDP

I cannot bring up an image.

Is there a plug -in or protocol that is needed ?

To add to what Todd said, first, make sure that the camera is working. I think that the Track Hat webcam is a PS Eye. I'll assume you've installed the driver for it (CL-Eye driver) which should also have installed the CL-Eye Test app. Switch on the Track Hat and camera and run the test app. Open the Options menu and make sure that Preview is ticked - you should see three white dots. If not, or you see a lot of background rubbish, open Options, Video Capture Filter..., untick Auto for both Gain and Exposure and adjust them until you have a dark background with 3 clear white dots. If you still see nothing then there may be a problem with your webcam. Leave the camera and Track Hat switched on but close the test app.

 

Assuming the camera is working, run FaceTrackNoIR and select the following settings:

 

On the View menu, make sure that Video Widget is ticked.

Tracker Source (1st = Master) - PointTracker (it may say 1.0 - there is an update to PointTracker 1.1 available here: https://sourceforge.net/projects/ftnoirpt/ - after updating it will still say 1.0 in FaceTrackNoIR v17x)

Tracker Source (2nd) - None

Filter - Accela Filter Mk2

Game protocol - FSX SimConnect

Game protocol (2nd) - None

In the Global Settings, I have the Smoothing set to about 10 but you can play about with this once it's all working. I also have Invert Yaw and Invert X ticked.

 

In the GO! box click on Start and you may see 3 crosses appear in the Video Widget window and it may say "Tracking". Don't worry if there are lots of crosses (or none) or it doesn't say Tracking as you will adjust this next.

 

Go to Settings (immediately below PointTracker) and on the General tab and make sure that Show Video Widget and Dynamic Pose Resolution are ticked. Select the Model tab and click on the Cap tab (this selects the cap format as your LED model). Leave calibration for now and just select the Camera tab at the top of the box. Make sure that Device shows PS3 Eye Camera. I have the Resolution set to 640x480 and FPS set to 60 - you can set this higher but 60 seems to work fine for me. Under Point Extraction, start with the Threshold slider in the middle and move it left until the crosses in the Video Widget just disappear (or lots of crosses appear) and note the postion of the slider. Next move the slider right until the crosses in the Video Widget just disappear and note the postion of the slider again. Put the slider roughly in the middle of the two points (you may need to fine tune it later if the lighting in the room changes). Make sure that all 3 crosses still show when you turn your head as far as you can left and right whilst still being able to see the screen comfortably - if not, fine tune the slider. Now go back to the Model tab and click on Calibrate. WITHOUT moving your shoulders, turn your head left, right, nod up and down and roll your head left and right, each several times, until the numbers in the x, y and z boxes start to look fairly stable then click Calibrate again. Click Ok at the bottom to close the Settings box and you should be good to go. Now click on Stop and in the Profile box click on Save As... and call it something like FSX-hat. Click on Start again.

 

These instructions work with FaceTrackNoIR v17x. If you get the new version (v200 - now donationware) they should still work but I have found that if you run FaceTrackNoIR v200 in isolation to set it up, and FSX is not running, the crosses in the Video Widget are very slow to respond and the FPS shown is very low. Once FSX is running this speeds up and works nornally.

 

Fire up FSX with a flight which starts on the ground and move your head around to check everything is working. You may need to invert (or uninvert) an axis or transition to get the view moving in the correct direction.

 

Let me know if this all works.

Share this post


Link to post
Share on other sites

Tried what you suggested but still no luck. I un-installed FaceTrackNoir and installed Open Track. After about one week of trying I felt it was time to pull the plug. I have an image with that but haven't made the adjustments yet. You have been a lot of help and I'll let you know if there's a problem, thanks.

Share this post


Link to post
Share on other sites

Tried what you suggested but still no luck. I un-installed FaceTrackNoir and installed Open Track. After about one week of trying I felt it was time to pull the plug. I have an image with that but haven't made the adjustments yet. You have been a lot of help and I'll let you know if there's a problem, thanks.

 

Just out of interest, are you using FSX-MS or FSX-SE? If it's SE, have you installed all of the legacy SimConnects? Worth a try before you finally give up on FaceTrackNoIR. OpenTrack is a good piece of software but I found that it's not quite as smooth in FSX on my system as FaceTrackNoIR.

Share this post


Link to post
Share on other sites

I'm using FSX/Accelerator. I don't know anything about the  legacy SimConnects . If I need it where is it found?

Share this post


Link to post
Share on other sites

I'm using FSX/Accelerator. I don't know anything about the  legacy SimConnects . If I need it where is it found?

 

Won't do you any good if you don't have video first.  Let's take this one step at a time.

 

After running CL-Eye Test do you have a camera image?

 

Todd

Share this post


Link to post
Share on other sites

Yes, I do have an image from the eye test. It's dark but there. Under Devices > ps3eye is checked. Under Options > Preview is checked. I have Windows 10.


I forgot to add I installed the paid download from CODE Labs.

Share this post


Link to post
Share on other sites

OK run CL-Eye Test one more time and while viewing the camera image rotate the PS3 Eye camera lens left or right and make sure the image is set for the zoom setting.  You'll want to use the zoomed setting and not the wider angle view.  Once you have done that close CL-Eye Test as you won't need to use it again.

 

Now start the FaceTrackNoIR software.  You do not need to start FSX to make sure head tracking is working.  Also you said you have a Track Hat.  Do not use that for this test as FaceTrackNoIR works with face recognition also.  Once FaceTrackNoIR starts change the settings to the following:

 

Profile - default.ini

Tracker Source(1st = Master) - faceAPI V3.2.6   Now in the same section press the Settings button and most importantly make sure "show videowidget" is checked.  Also make sure all of the Axis are checked.

Filter - Accela Filter Mk2

Game protocol - FSX SimConnect

Tracker Source (2nd) - None

Game protocol (2nd) - None

 

Now in the GO! section press Start.  A window should appear in the location where you may or may not see UDP.  This window will look like a Windows program window and it will be titled FaceAPI_Tracker.  If you have that window you should see the PS3 Eye camera display a red light and your image will be displayed.  If all of that works move close enough to the camera until the yellow outline appears on your face on the camera image.  You will need good lighting on your face for the yellow outline to appear.  At that point you will have face recognition tracking.

 

Remember don't run FSX and don't use your Track Hat.

 

Report back with your results.

 

Todd

 

Share this post


Link to post
Share on other sites

I have only one option under Tracker Source ( 1st Master ) and that is FaceTrackNoir UDP. Under Filter again only one option and that is EWMA filterMk2. I didn't go any farther than that.

Share this post


Link to post
Share on other sites

OK there's your problem!  You need to download the Plugin Pack for FaceTrackNoIR from their website.

 

http://www.facetracknoir.nl/

 

Click the green button that say's "Free Download" and after installing repeat the steps I provided above.

 

Todd

 

Share this post


Link to post
Share on other sites

After the plug- in I have all the settings that you described. When I turned it on the red light came on the camera. On the left where my image should be I see the words ' Commercial Use '. It's a very dark screen and can barely see my hand when held in front of the cam about two feet in front of it. The lighting is pretty good over me, but the image is too dark. I'm half way there now and finally feeling more optimistic.

Share this post


Link to post
Share on other sites

The words "Commercial Use" on the camera image is normal.  The image should not be dark but I believe your version of the PS3 Eye camera has the IR filter removed to work with the Track Hat so I do not know if that affects the brightness of the camera image.  Try adding more light aimed at your face.  To continue testing you want to see the yellow outlines on your face.  Press Start and move your face close enough until the yellow outline appears on your face in the camera image.  If you get that far, the tracking is working.

 

If you like you can try using your Track Hat but change the Tracker Source(1st = Master) to PointTracker 1.1 and under settings make sure all of the settings are correct.  There are four tabs of settings for the PointTracker.

 

No matter which tracker source you use (faceAPI = Face Recogntion or PointTracker = InfraRed Tracking) once you press Start in FaceTrackNoIR if everything is working you should see the yellow square grid with a head icon in the black area above the camera image start moving as you move your head around.

 

Continue testing using only the FaceTrackNoIR software as there may be additional steps to get it working with FSX.

 

Todd

Share this post


Link to post
Share on other sites

The PS3 Eye for Track Hat is highly likely to have had a filter added to block visible light, which would explain why the image is so dark.

It is unlikely you will have success using a camera set up for IR Head Tracking with the Face Recognition that needs visible light and vice versa.

If your camera is working as you say it is, I suggest you turn on your Hat Track IR LED's, verify they show up, then you can work on fine tuning the camera in the Point Tracker settings.

Share this post


Link to post
Share on other sites

For FaceTrackNoIR to work best with LEDs, you want the background to be dark so that only the LEDs show clearly. You say you have a dark background, which is good, but do you see the 3 LEDs in the FaceTrackNoIR Video Widget screen? If you do, I would refer you to my previous post about setting things up.

 

With regards to "Commercial Use" showing on the camera image, this normally only appears when you use the faceAPI tracker source. To use FaceTrackNoIR with your Track Hat, you must select PointTracker as the tracker source.

Share this post


Link to post
Share on other sites

In FSX there's a lot of flickering or blinking. There's no up , some down and about forty-fives degrees right and left.

Share this post


Link to post
Share on other sites

In FSX there's a lot of flickering or blinking. There's no up , some down and about forty-fives degrees right and left.

 

Have you checked that the webcam is picking up ONLY the LEDs and that it continues to pick them up as you move your head? It sounds as if FaceTrackNoIR is losing tracking. Make sure that you set up and calibrate your webcam as described in my earlier post. Once you have smoothish movement in all directions you can look at adjusting the curves but get the basics working first.

 

Just in case it helps, here is a copy of the FaceTrackNoIR .ini file I use with my hat and PS Eye camera in FSX: https://www.dropbox.com/s/wmpttozj4f8lb2a/FSX_Cap.ini?dl=0 - you don't need to log in to Dropbox to download it. Copy it into your "Program Files (x86)\Abbequerque Inc\FaceTrackNoIR\Settings" folder. When you run FaceTrackNoIR, load it (FSX_Cap.ini) in the Profiles box. You'll need to re-calibrate for your hat and webcam at some stage.

Share this post


Link to post
Share on other sites

I believe I finally got it. No flickering or blinking in FSX. Everything was smooth. Right, and left was great. Up and down is very limited . I tried it with the Eaglesoft Citation X with no crashes. Next will be the PMDG Aircraft so that should be interesting.Can I use EZDOC in conjunction with it ? I will do some adjusting later since it's after midnight. All of you guys have been so helpful. You have no idea how much I really appreciate it. Thank you so much!

Share this post


Link to post
Share on other sites

I believe I finally got it. No flickering or blinking in FSX. Everything was smooth. Right, and left was great. Up and down is very limited . I tried it with the Eaglesoft Citation X with no crashes. Next will be the PMDG Aircraft so that should be interesting.Can I use EZDOC in conjunction with it ? I will do some adjusting later since it's after midnight. All of you guys have been so helpful. You have no idea how much I really appreciate it. Thank you so much!

 

Great news! To adjust the amount of up/down movement, go into the curves setting page and adjust the output (vertical scale) for pitch up and pitch down to get the amount of movement you want.

 

There are supposed to be some problems between EZDOC and FaceTrackNoIR but you could try the solution in the last post on this thread: http://www.simforums.com/forums/solved-facetracknoir-and-ezdok-117_topic41281.html - it's an old thread and I don't have EZDOK so can't confirm whether or not this still works.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this