Sign in to follow this  
Pe11e

HDR exposure lock?

Recommended Posts

Is there any chance to lock HDR exposure compensation? I really don't like when exposure raises quite a bit when looking down in the cockpit, and when you raise the view towards the windows (for example in the NGX) it wioll not compensate enough so the sky and clouds are ultra bright, everything outside is over-exposed. I must look through the side windows to let P3D to compensate and to set the exposure to the original value, then it is ok to switch to the default cockpit view.

 

Is there any chance to lock exposure compensation? If I set BRIGHTNESS to 1.20 to stay locked to that value all the time regardless the view angle, etc? I guess it can be done via editing some file in ShadersHLSL, but I really don't know which file, and which values to edit?

 

Rob? Anyone? Any ideas?

 

 

Huge thanks in advance guys!

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Found a temporary solution - set Bloom to 0 in the options. It minimized the exposure compensation effect , just tested it. But that is still not exactly what I would love to see, because Bloom is quite nice little feature, the sim looks much more realistic with it, especially at 0.80.

Share this post


Link to post

I had asked LM some time ago if they would provide an option to turn that effect on/off or allow it to be reduced.  As you discovered setting bloom=0, but that does prevent other effects from happening so it's not a desirable solution.

 

Since LM implemented HDR adjustments via UI, I haven't really explored the hlsl files from V3.x forward.  My hunch is it would need more than just modifications to HLSL files, think code changes.

 

Cheers, Rob.

Share this post


Link to post

But that is still not exactly what I would love to see, because Bloom is quite nice little feature

 

I agree, and would love to find a way to reduce the adaption effect without losing bloom completely.

 

We've come a long way, with LM adding the HDR control in the UI but it would be nice to have this additional feature to adjust, or turn off, adaption.

Share this post


Link to post

I had asked LM some time ago if they would provide an option to turn that effect on/off or allow it to be reduced.  As you discovered setting bloom=0, but that does prevent other effects from happening so it's not a desirable solution.

 

Since LM implemented HDR adjustments via UI, I haven't really explored the hlsl files from V3.x forward.  My hunch is it would need more than just modifications to HLSL files, think code changes.

 

Cheers, Rob.

 

Rob, I've found some values in HDR.hlsl related to compensation:

 

// Slowly adjusts the scene luminance based on the previous scene luminance
float AdaptLuminance( PsQuad vert ) : SV_Target
{
 
    float lastLum = exp(srcTex.Sample(samClamp, vert.texcoord).x);
    float currentLum = srcTex1.SampleLevel(samClamp, vert.texcoord, 9).x;
 
    float difference = (currentLum - lastLum);
    // Adapt the luminance using Pattanaik's technique    
    float adaptedLum = saturate(lastLum + pow(difference, 3) * (TimeDelta * AdaptationScalar));
 
    return log(adaptedLum);
}
 
// Show current AdaptedLuminance
float4 LuminanceTest( PsQuad vert ) : SV_Target
{   
    float adaptedLum = srcTex.SampleLevel( samClamp, vert.texcoord, 9 ).x;
    return float4( adaptedLum, adaptedLum, adaptedLum, 1.0f );
}
 
 
Don't want to touch this since I'm a sucker for C#, have no clue what values to change, but I'm sure there are few simmers that know this kind of stuff, like in a thread for P3D v2.x HDR.

Share this post


Link to post

float adaptedLum = saturate(lastLum + pow(difference, 3) * (TimeDelta * AdaptationScalar));

 

I thought I have a go, and changing the pow(difference, 3) to a lower number, or 0 as I have just tried, disables the adaption, but leaves bloom functioning.

 

I have needed to increase the brightness, and bloom values to compensate, as the starting brightness is now much lower, and I may need to raise the TONEMAP_NIGHT_EXPOSURE_KEY= in the cfg to make the night exposure a bit brighter. I had this set lower than default already though.

 

One nice thing about this is clouds do not seem to glow just after sunset as they did before.

 

Nice find Pe11e.

 

EDIT - It seems higher numbers reduce to amount of exposure latitude, and zero turns it off. Currently have pow(difference, 6) and seeing little, if any adaption.

 

It will be a case a playing with the values and finding a sweet spot.

 

Remember to back up the HDR.HLSL file before making any changes.

Share this post


Link to post

I thought I have a go, and changing the pow(difference, 3) to a lower number, or 0 as I have just tried, disables the adaption, but leaves bloom functioning.

 

I have needed to increase the brightness, and bloom values to compensate, as the starting brightness is now much lower, and I may need to raise the TONEMAP_NIGHT_EXPOSURE_KEY= in the cfg to make the night exposure a bit brighter. I had this set lower than default already though.

 

One nice thing about this is clouds do not seem to glow just after sunset as they did before.

 

Nice find Pe11e.

 

EDIT - It seems higher numbers reduce to amount of exposure latitude, and zero turns it off. Currently have pow(difference, 6) and seeing little, if any adaption.

 

It will be a case a playing with the values and finding a sweet spot.

 

Remember to back up the HDR.HLSL file before making any changes.

 

Thank you! I didn't wanted to fiddle with it before someone with some knowledge tested the change.

I will start with 0 for sure. One thing that is confusing is how 6 is similiar to 0, and 3 is default with strong adaption?

Share this post


Link to post

I will start with 0 for sure. One thing that is confusing is how 6 is similiar to 0, and 3 is default with strong adaption?

 

Yeah, other values may just break it. I'm not seeing any adaption using other numbers.

 

Using zero and tweaking the bloom and brightness gets you somewhere, but it is a balance of getting the terrain bright enough without burning the clouds out.

 

Maybe there is another section that will allow a reduction in exposure, without turning it off completely. I'll continue to poke around, but its a slow process, having to make changes then re start the sim, although I did find you don't need to delete the shader cache each time.

 

If anyone else finds something please post it.

Share this post


Link to post

Hmmm, tried both 0 and 6, no adaptation. BUT now the contrast is quite strong with the bloom, I'm sure the sim didn't looked like this before with HDR + Bloom. Now because I'm limited with my spare time, I will settle with HDR on but with Bloom at 0, got some good results in combination with SweetFX.

 

Oh yes I almost forgot, I did change TONEMAP_DAY_EXPOSURE_KEY to a higher value (0.380000), the brightness is back, but the contrast is still quite strong, and the clouds are burned quite a bit.

Share this post


Link to post

I hope to try this in a couple of days when I get some time. Just wondering if anyone else has had any other success.

Share this post


Link to post

Hì, has any solution been found about this issue? Thanks

Share this post


Link to post

I'd love to see this disabled as well...

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this