Sign in to follow this  
VeryBumpy

4k with game menu and text scaling issue

Recommended Posts

So loving my 4k monitor BUT everything is hard to read now since the pulldown menus and popup line text are so tiny.

 

Is there any way to improve on this?

 

This FSX btw. Not sure if other sims suffer the same.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I hate it too but live with it in P3d. They did fix it with Steve's DX10 Fixer with a option to size it for 4K.

Share this post


Link to post
Share on other sites

I wonder if Windows 'Ease of Access' would work? Might have to try that when I get a free moment.

Share this post


Link to post
Share on other sites

Have you tried to increase the scaling and check the dpi box of the .exe under properties?

Share this post


Link to post
Share on other sites

The general sizes of items, text, apps, menus, can be increased with the Windows Display Settings, Customise. Try 125%.

Share this post


Link to post
Share on other sites

I seem to remember DPI scaling causing problems in FSX. I can't say exactly what the issue was but I ended up having to turn it back off.

Share this post


Link to post
Share on other sites

Unless I'm mistaken, I thought that the Alt dropdown menu in FSX is hard-coded so you're stuck with the small/very small text size as you increase screen resolution.

Share this post


Link to post
Share on other sites

The general sizes of items, text, apps, menus, can be increased with the Windows Display Settings, Customise. Try 125%.

I have this at 200% within Windows but it does not work in FSX. Win10 automatically checks the "Disable display scaling on high DPI settings" checkbox each time I start FSX.

 

I wonder if Windows 'Ease of Access' would work? Might have to try that when I get a free moment.

This does work as long as I'm in windowed FSX. I have Magnify.exe bound to a key on my keyboard to start the magnified feature then can quickly turn it off with Winkey+Esc.

Share this post


Link to post
Share on other sites

Even the advanced size settings are ignored by FSX, seems immune to any changes.

Share this post


Link to post
Share on other sites

Increasing scaling beyond default can cause unwanted side-effects for example, the menu bar in P3D can become corrupted and almost unreadable when you do this.  Tested (and fixed) on Windows 10 by yours truly earlier today.  Try leaving scaling at default and just increase the zoom in your browser (control +) rather than blowing up the UI elements globally, many of which do not use vector graphics and were not designed for this.  For too small gauges and the like in-cockpit, control backspace to shift your eyepoint forward (P3D).  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this