Sign in to follow this  
Sesquashtoo

When 'push, comes to 'shove'...

Recommended Posts

2016_6_10_22_40_45_440.png

 

-------------------------------------------------------------------

 

...as I was exploring more of the sq miles around Bar Harbor, using P3D v3.2.3, it really brought home that this version of P3D, in hindsight, is the last version of P3D, that will run every piece of 3rP scenery, airports, aircraft, etc...that a user has purchased to date.  The only version that does not require a hot-fix hack, to hopefully, return the user's library of 3rP to full compatibility.

 

So...we all knew this was going to happen sooner than later, ....that LM would move on from a version that totally was back-compatible with a user's catalog.

 

We all knew it would happen...and with V3.3 (non hack), it did.

 

Crossroads....

 

Whether with v3.4, or a 64 bit version coming along the launch ramp....we finally are at a crossroads, and not merely lip-service to it...

 

Just musing...as I continue in my flight.  I really don't know if I am going to go past v3.2.3 at this point of time, It runs great, looks great, and runs everything I paid for.  If I don't decide to update my P3D experience past this last 'old guard'...I certainly won't be in a position to b*tch to anybody about it.  A user's decision, on what stays, and what is shed off...

 

Happy flights all, no matter which direction you fly....

 

Ses

  • Upvote 2

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Happy flights all, no matter which direction you fly....
 
Ses

 

 

I agree, it is the user's decision.

 

I suspect, however, that most of us here will continue with future P3d versions - there is no equivalent alternative.

 

I'm hoping that LM will consider allowing us to keep two copies (or two versions) on the same machine - this 'patched' hotfix v3.3 and a future version - both accessing the same scenery. I don't think a different config will do the job ?

 

I'm going to fly locally until the situation is sorted. I'm an optimist. I don't think many developers will let us down. Let's face it - many of them are enthusiasts too.

 

I think we must support them - if the hobby is to survive.

 

Regards

Bill

 

Share this post


Link to post

3.3.5 should really be it. The last "tick" (to use an Intel analogy). The next jump should be a "tock"  to V4.0 and that should be 64bit. I certainly don't want to be buying new scenery and then in the foreseeable future have to buy it once again for 64bit.

I also think the developers have probably reached their limit as to supporting LM "tick" updates.

Share this post


Link to post

I agree, it is the user's decision.

 

I suspect, however, that most of us here will continue with future P3d versions - there is no equivalent alternative.

 

I'm hoping that LM will consider allowing us to keep two copies (or two versions) on the same machine - this 'patched' hotfix v3.3 and a future version - both accessing the same scenery. I don't think a different config will do the job ?

 

I'm going to fly locally until the situation is sorted. I'm an optimist. I don't think many developers will let us down. Let's face it - many of them are enthusiasts too.

 

I think we must support them - if the hobby is to survive.

 

Regards

Bill

 

All good points...yes, it would be great if you could have v3.2.x alongside any other v3.x series...and the two would not confuse installers, or your Registry!  As you say, the best of both worlds...that looking back, and the looking towards the future of the franchise.

 

Cheers,

3.3.5 should really be it. The last "tick" (to use an Intel analogy). The next jump should be a "tock"  to V4.0 and that should be 64bit. I certainly don't want to be buying new scenery and then in the foreseeable future have to buy it once again for 64bit.

I also think the developers have probably reached their limit as to supporting LM "tick" updates.

...they probably have, or are about 'there'...but even Mr. 64...is going to be an incremental run...they had better get use to it, I guess...

Share this post


Link to post

I'm sticking with 3.2 Can't imagine anything running better or smoother. Haven't heard anything that 3.3 offers that sounds interesting. 

Share this post


Link to post

 

 


We all knew it would happen...and with V3.3 (non hack), it did.

 

A bit over dramatic and premature, I think. :wink: As I understand and see it LM simply made a little error and/or forgot to include something in 3.3 which they have been including for a long while already. If LM would have completely removed addon compatibility, they surely wouldn't have been able to solve it this quickly with a fix (which btw is something different than a hack). We aren't at a crossroad yet. That a crossroad will come goes without saying but it's not there yet.

Share this post


Link to post

Ah come on Ses,

you have been a stubborn enthusiast for fs2004 and you have been a stubborn enthusiast for fsx , yet you switched to P3d and you wouldn't move up to 3.3.5!

I am skeptical.

You know what they say: The proof is in the pudding" or the long version: "The proof of the pudding is in the eating"

Try it, you'll see.

Cheers mate

Share this post


Link to post

Ah come on Ses,

you have been a stubborn enthusiast for fs2004 and you have been a stubborn enthusiast for fsx , yet you switched to P3d and you wouldn't move up to 3.3.5!

I am skeptical.

You know what they say: The proof is in the pudding" or the long version: "The proof of the pudding is in the eating"

Try it, you'll see.

Cheers mate

 

 

I'll bite. Tell me what it does that is so much better than 3.2?  

Share this post


Link to post

I'll bite. Tell me what it does that is so much better than 3.2?  

I'm with you, Bob.  V3.2 runs smooth, looks fantastic...high 25-30 in dense cloud...(30 is top performance for my present system!)  What's to change up from this?

 

Like I said, I'll sit in the bush, and let other people's screenies convince

 

Ah come on Ses,

you have been a stubborn enthusiast for fs2004 and you have been a stubborn enthusiast for fsx , yet you switched to P3d and you wouldn't move up to 3.3.5!

I am skeptical.

You know what they say: The proof is in the pudding" or the long version: "The proof of the pudding is in the eating"

Try it, you'll see.

Cheers mate

It's only because I have never seen a sim look, or run as good as v3.2.3. None at, or past FSX.  

 

Like I said, I will no longer 'on faith'...update to a later version.  If, it truly adds value...and is stable...then sure, but the fact that v3.3,  has shown a clear move in the direction LM wants to take it...(and that is their total right and pervue!) I can be happy steppin' off the train at the v3.2.3 stop. No problem. :))))

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this