Sign in to follow this  
MindYerBeak

RTH broken ?

Recommended Posts

RTH  is not working for me anymore.  (beta4) Anyone  found a way to make  it work  with the latest beta ?

 

 

thx

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I heard the actual refs have changed for some of the art controls (I can't remember from where), so it will require an update from the developer. This is just one of many addons broken at the moment for me in the beta, including SkyMaxx Pro.

Share this post


Link to post
Share on other sites

 

 


I heard the actual refs have changed for some of the art controls (I can't remember from where), so it will require an update from the developer. This is just one of many addons broken at the moment for me in the beta, including SkyMaxx Pro.

 

Ok. Thanks !

Share this post


Link to post
Share on other sites

 

 


This is just one of many addons broken at the moment for me in the beta, including SkyMaxx Pro.

 

What's broken with SMP? For me it works fine...

Share this post


Link to post
Share on other sites

Just doesn't load at all. I have errors all over my screen about NULL exceptions and the like. It still works in 10.45

Share this post


Link to post
Share on other sites

Just doesn't load at all. I have errors all over my screen about NULL exceptions and the like. It still works in 10.45

 

Odd... My SMP seems to work well. Have you seen any talk about this at the X-aviation forums?

Share this post


Link to post
Share on other sites

Hmm, for me SMP , the Real Weather Connector and FSGRW now work fine with the beta 4. Even the new 727 v2 now works in the beta.

And RTH is broken by design. Since they are using Art controls that are only for internal purposes, they can´t complain if X-Plane changes some art controls.

Share this post


Link to post
Share on other sites

Not my fix, but user "Sparker". It works. I found this on X-Plane.org forums, RTH plugin comments:

It looks like they changed the dataref from 

sim/private/controls/skyc/sky_imm_end
sim/private/controls/skyc/sky_imm_start

to

sim/private/controls/skyc/sky_imm_max
sim/private/controls/skyc/sky_imm_min

SOLUTION:
I have changed the three places in RTH.lua where

sim/private/controls/skyc/sky_imm_end

is to

sim/private/controls/skyc/sky_imm_max

Hope it helps.  S!

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this