Sign in to follow this  
Jack_Sawyer

Saitek hardware

Recommended Posts

I just bought this and being an avid P3D user along with orbx I thought I'd give it a shot.  I got it set up nicely graphically thanks to Jordan King's nice YT tutorial but I can't get it to recognize some of my Saitek hardware, especially the toe brakes on the pedals.

 

I have this, all Saitek, Yoke & throttle quad, an extra quad, a TPM, and pedals.

 

I read a FAQ on their very limited "support" site that says I have to update my Saitek drivers to 64 bit.

 

My question, IF I do this will it mess up P3D?  P3D is way more important.

 

Thanks.

 

Jack

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I discovered I already have the 64 bit drivers installed.  Does anyone know why I can't get the program to see my toe brakes in the buttons and keys but can only in axis.  And when I do get it to see them they're always on, despite changing the null zone and sensitivity and even setting them to inverted.

 

I wonder if I wasted my money.  I'm not going to waste my time trying to fly this program with a mouse and keyboard.

Share this post


Link to post
Share on other sites

I just bought this and being an avid P3D user along with orbx I thought I'd give it a shot.  I got it set up nicely graphically thanks to Jordan King's nice YT tutorial but I can't get it to recognize some of my Saitek hardware, especially the toe brakes on the pedals.

 

Jack if everything is working correctly in P3D do nothing to change that fact dont go loading stuff to make this work - its working in P3D and FSX is a dead give away - has to be on DTG side of things - find a different answer because thats not it 

Share this post


Link to post
Share on other sites

Toe brakes and rudder pedals are both "axis" events, so that's why they don't show up in the buttons and keys assignment dialog.

Share this post


Link to post
Share on other sites

Thanks Bill! So how do I get this program to stop having the brakes always on? If I assign them in Axis they work but I get the red text that the brakes are always on. I have to manually use the mouse and turn the parking brake on and then off for the message to go away. I wonder if DTG has a problem with it because with the same settings my pedals work perfectly in FSX and P3D 3.2.

Share this post


Link to post
Share on other sites

Hi,

 

Go to your main setting screen.

 

From the main setting screen click on the sensitivities icon

 

From the Controller - Sensitivities page click on the drop arrow next to the box called 'Joystick Type' in the  upper right of the screen, when the arrow is pressed a drop down menu will appear listing the game controllers connected to your PC.  In this list you will see the Saitek Pro Flight Rudder Pedals.

 

Click on this controller, on the screen you will see Simple and  Advance radio buttons, make sure the simple radio button is selected.

 

Just under and to the right of the simple button you will see two sliders, one marked Sensitivity - all axes and the other marked Null zone - all axes.  Move the sensitivity slider ALL the way over to the right and move the Null zone slider about 3% to the left, click OK and the toe brakes should now work.

Share this post


Link to post
Share on other sites

Hi John, I just now got a chance to mess with this.

 

When you say to go to the main screen and click on sensitivities icon, that does not exist.  All I have is the icons along the bottom and one is the gears and the other is the Xbox controller icon.

 

The only way for me to access the sliders for the pedals is to go to the Xbox icon, and in the drop down I select my pedals.

Then I have three sliders.

 

Brake (left axis) - Sensitivity is now 10.00 - Null is now 3.00

rightBrake (left axis) - Sensitivity is now 10.00 - Null is now 3.00

Rudder axis - Sensitivity 5.00 - Null is 3.00.

 

But when I bring up the flight screen I see NO red BRAKE message, however, as soon as I touch a toe brake I get a permanent red BRAKE message that will not go away unless I use the mouse and set the parking brake then turn off the parking brake.

But if I so much as touch the toe brake I get the same red BRAKE message on the lower right.

I can't take off like this.

 

It's odd that my pedals work perfectly in FSX and P3D 3.2

Share this post


Link to post
Share on other sites

I assume you have to invert your brake axis in the settings.

 

Yes, tried that too.  Same behavior.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this