Sign in to follow this  
captain420

How to setup simconnect.cfg for multiple apps? (ie: Pro-ATC/X & Active Sky 2016)

Recommended Posts

I currently have AS16 installed and configured to run over the network. I have a 2nd computer that I use to run my 3rd party apps on. So my simconnect.cfg file looks like this:

 

[simConnect]

Protocol=IPv4
Address=192.168.1.x
Port=500
MaxReceiveSize=4096
DisableNagle=0
 
But now that I plan on installing and running Pro-ATC/X alongside AS16, it requires me to add another entry into my simconnect.cfg file on port 6811. Does anyone know how I can manage to get multiple apps running and what I need to do? Do I need to make another [simConnect] entry inside my current simconnect.cfg file or can I simply add Port=500,6811? 
 
UPDATE: Can I just put the simconnect.cfg file inside where my .exe file for AS16 and Pro-ATC is? instead of having it in my user/name/documents folder? I heard if you do it this way, each app can have it's own unique simconnect.cfg file.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

UPDATE: Can I just put the simconnect.cfg file inside where my .exe file for AS16 and Pro-ATC is? instead of having it in my user/name/documents folder? I heard if you do it this way, each app can have it's own unique simconnect.cfg file.

 

Yes, I have several apps on my second computer, each with their own simconnect.cfg in the application's directory.  I find it much easier to manage that way.

 

You will need to consolidate all the multiple port information into the simconnect.xml file on the simulator computer.

 

Ernie

Share this post


Link to post

Ernie, could you give me an example of how to consolidate the port on the server macine where the main flight sim is running?

 

I have 2 apps running over the network. Pro-ATCX which is using port 6811 and AS16 on port 5000... do I need to create 2 seperate simconnect.xml files?

Share this post


Link to post

I have 2 apps running over the network. Pro-ATCX which is using port 6811 and AS16 on port 5000... do I need to create 2 seperate simconnect.xml files?

 

No, you only need to create one simconnect.xml file, but it should contain entries for all of the simconnect.cfg files;

 

Below is an example of what is on my two computers;  I realize that it's for FSX, but it should be similar for P3D.

 

 ----------------------------------

 

simconnect.cfg files on second computer;

 

In AS16 application directory;

[simConnect]

Protocol=IPv4

Address=192.168.1.103

Port=500

MaxReceiveSize=8192

DisableNagle=1

 

In Plan-G application directory;

[simConnect]

Protocol=IPv4

Address=192.168.1.103

Port=4506

MaxReceiveSize=8192

DisableNagle=1

 

simconnect.xml file on FSX computer in AppData\Roaming\Microsoft\FSX; (You directory will probably be \P3D or similar)

NOTE: This is not all of the entries in my simconnect.xml file, but the others are just variants with different ports..

 

<?xml version="1.0" encoding="Windows-1252"?>

<SimBase.Document Type="SimConnect" version="1,0">

   <Descr>SimConnect</Descr>

   <Filename>SimConnect.xml</Filename>

   <Disabled>False</Disabled>

   <SimConnect.Comm>

      <Disabled>False</Disabled>

      <Protocol>IPv4</Protocol>

      <Scope>global</Scope>

      <Address>192.168.1.103</Address>

      <MaxClients>64</MaxClients>

      <Port>500</Port>

       <MaxRecvSize>8192</MaxRecvSize>

      <DisableNagle>True</DisableNagle>

   </SimConnect.Comm>

   <SimConnect.Comm>

      <Disabled>False</Disabled>

      <Protocol>IPv4</Protocol>

      <Scope>global</Scope>

      <Address>192.168.1.103</Address>

      <MaxClients>64</MaxClients>

      <Port>4506</Port>

      <MaxRecvSize>8192</MaxRecvSize>

      <DisableNagle>True</DisableNagle>

   </SimConnect.Comm>

</SimBase.Document>

 

Alternately, I could have consolidated the two simconnect.cfg files and placed the single file in my second computer's My Documents folder, by adding a number to the second and subsequent [simConnect].

 

[simConnect]

Protocol=IPv4

Address=192.168.1.103

Port=500

MaxReceiveSize=8192

DisableNagle=1

 

[simConnect.1]

Protocol=IPv4

Address=192.168.1.103

Port=4506

MaxReceiveSize=8192

DisableNagle=1

 

 

 

 

 

Share this post


Link to post

I think you should be using any ip port number over 1024 except 8080 for reliability. But any number like your 500 will work usually. My SimConnect Notes

 

Share this post


Link to post

I think you should be using any ip port number over 1024 except 8080 for reliability. But any number like your 500 will work usually. My SimConnect Notes

 

 

 

 

Thanks Steve,

 

HiFi Tech recommends port 500 in their ASN/AS16 docs.  I've not had any issues, but if there is a potential for problems then it is probably best for me to change it.

 

 

Ernie

Share this post


Link to post

I'm not a win ip expert but I think a lot of system stuff appears on those lower ports, so potentially could impact performance. Good idea to go for the recommended 1025+.

Share this post


Link to post

What does this entry do?

 

 <DisableNagle>True</DisableNagle>

 

Mine is set to False

 

This is what I have my simconnect.xml set to:

<?xml version="1.0" encoding="Windows-1252"?>

<SimBase.Document Type="SimConnect" version="1,0">
  <Descr>SimConnect</Descr>
  <Filename>SimConnect.xml</Filename>
  <Disabled>False</Disabled>
  <SimConnect.Comm>
    <Disabled>False</Disabled>
    <Protocol>IPv4</Protocol>
    <Scope>global</Scope>
    <Address>X.X.X.X</Address>
    <MaxClients>64</MaxClients>
    <Port>500</Port>
    <MaxRecvSize>4096</MaxRecvSize>
    <DisableNagle>False</DisableNagle>
  </SimConnect.Comm>
  <SimConnect.Comm>
    <Disabled>False</Disabled>
    <Protocol>Auto</Protocol>
    <Scope>local</Scope>
  </SimConnect.Comm>


 <SimConnect.Comm>
    <Disabled>False</Disabled>
    <Protocol>IPv4</Protocol>
    <Scope>global</Scope>
    <Address>X.X.X.X</Address>
    <MaxClients>64</MaxClients>
    <Port>6811</Port>
    <MaxRecvSize>4096</MaxRecvSize>
    <DisableNagle>False</DisableNagle>
  </SimConnect.Comm>
  <SimConnect.Comm>
    <Disabled>False</Disabled>
    <Protocol>Auto</Protocol>
    <Scope>local</Scope>
  </SimConnect.Comm>

</SimBase.Document>

Share this post


Link to post

I've been using ProATC and ASN/AS16 on a networked machine for years now and I'm pretty sure you don't need to change anything in simconnect.  If AS16 is already working, just install ProATC/X and make sure the correct network paths are set.  I'm not at home at the moment to verify; but I'm pretty sure ProATC/X does NOT require an additional port.

Share this post


Link to post

What does this entry do?

 

<DisableNagel>True</DisableNagel>

 

Mine is set to False

 

It enables/disables the Nagle packet optimization algorithms.  As you noted, mine is set to True, but should probably be changed to False, since it's purpose is to reduce small packet transmission. 

 

Apparently, that's not necessarily a good thing with real time applications.

 

 

I'm not at home at the moment to verify; but I'm pretty sure ProATC/X does NOT require an additional port.

 

Theoretically that's true for all of the applications on the second machine.  They could all use the same port.

 

The practice of assigning each application a different port is to reduce the possibility of conflicts. 

 

True, the effectiveness is impossible to prove without some type of port monitoring, but doing so falls into the category of "better safe, than sorry". :smile:

Share this post


Link to post

For those of you running Pro-ATC/X on a 2nd machine over a network. Is there a way to route the sound over to the main server machine that your sim is running on?

 

If I use a headset connected to my P3D machine, I would want the sounds from Pro-ATC/X coming through from the same machine as my sim.

Share this post


Link to post

For those of you running Pro-ATC/X on a 2nd machine over a network. Is there a way to route the sound over to the main server machine that your sim is running on?

 

If I use a headset connected to my P3D machine, I would want the sounds from Pro-ATC/X coming through from the same machine as my sim.

 

I'm doing exactly this. ProATC is on my laptop and I hear ProATC's sounds on a pair of headphones that are connected to my sim computer. Here's how I do it:

 

I have one end of a cable connected to the headphone output of my laptop. The other end is connected to my main computer's line-in. I then have setup Windows to monitor/listen to the line-in signal.

 

This way the line-in signal is mixed with the sim's sound and sent to my main sound output (which is a pair of USB headphones).

Share this post


Link to post

Here is a list of commonly used ports and reserved ports: https://en.wikipedia.org/wiki/List_of_TCP_and_UDP_port_numbers

 

I use 4506 (since I don't have "Salt Master" and it's unofficial) ... I'd avoid using "official" ports but they can still be used so long as you don't have software installed that uses your port of choice.

 

Whatever port you use, you'll need to make sure your firewall on all PC's involved are not blocking that port.

 

Cheers, Rob.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this