Sign in to follow this  
msagner

Cannot change focal setting of cameras

Recommended Posts

First of all - thanks, guys, for making this tool available at such an early stage!

 

I have now V0.1.19 installed (Win10-64Bit, P3Dv3.4)

I find it is not possible to change the focal setting of a camera, or any camera.

All the other degrees of freedom work perfectly, it's just the focal length that's giving me trouble.

 

This holds true on my machine for:

Aerosoft A319

Majestic Q400 Pro

A2A C172

 

FSUIPC full license installed, latest version

 

Selected view by right-click: On-board (chaseplane)

 

Something else I found, also concerning focal setting:

 

After starting up the sim, I'm in cockpit view with a wide-view focal setting.

If I switch to outside view using the icon in the chaseplane UI, and the switch back to cockpit view (also using the appropriate chaseplane icon), the focal setting changes to telephoto range.

 

Neither setting (before or after the switch to outside view) can be adjusted in chaseplane.

 

Anything I can do to help find the issue? Enable Logfiles?

 

Best regards

Michael

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I have the same problem with the focal setting in cockpit view, move slider up/down no function, all other sliders are working without any problem.

Curious, when I switch to the default Virtual Cockpit View from P3D, the focal works?????

 

I use P3D 3.4

Share this post


Link to post
Share on other sites

I'm having the same issue after 1.17. Im using P3dv3.4.9 and the issue occurs only with the Aerosoft Airbus. 

I also have a camera recovery issue when using the Aerosoft airbus.  My transition to exterior camera seems broke as well.

I'm now on CPv 1.22

Share this post


Link to post
Share on other sites

I am using FSX:Steam Edition. Current ChasePlane as of this morning is v 0.1.22.

 

The focal length adjustment now seems to be working OK.

Share this post


Link to post
Share on other sites

v0.1.25: focal setting working fine, BUT: It works only if the view setting is to "Virtual cockpit view", not the chaseplane view.

That means that if you switch to an outside view and then back, the chaseplane view will be selected, and this must then be changed to VC view.

Share this post


Link to post
Share on other sites

ChasePlane only has 3 working views in FSX/P3D.

They are On-Board (ChasePlane)Outside (ChasePlane) and Static (ChasePlane)

If you venture out of those views, the camera will not work as expected.

 

If you don't see them in your contextual menu in FSX/P3D, contact us through the alpha email and we'll look at it.

Share this post


Link to post
Share on other sites

I have some issues also with Chase Plane view selection.

 

When switching from cockpit view to external view or reverse (from ChasePlane hotkey):

  • with A2A Cherokee => the external view selected is not the Chase Plane one (but cockpit is good)
  • with Q400 Pro => the internal view is not the ChasePlane one but "MJC84 virtual cockpit" (external view is good)

In those wrong selection situations, the CP zoom is usually not working of course.

Share this post


Link to post
Share on other sites

I found a workaround for the Q400:

 

=> I commented out the [CameraDefinition.0] whole section from the Q400 aircraft.cfg

Share this post


Link to post
Share on other sites

I fixed the Q400 by changing the line Hotkeyselect=1 to //Hotkeyselect=1 in cameradefinition.0 in the aircraft.cfg. 

I believe former ezdok users don't have this problem. Because the cfg is already edited.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this