Sign in to follow this  
etopsbr

Joystick HAT

Recommended Posts

Hello guys, I can't figure out how can I put my joystick HAT to work with chase plane. In controls page I've tried to set in Tilt up, Tilt down and it doesn't work propely, I can pan left and right in spot view but can't look up and down..

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Have  the same  issue   can pan  left or  right ok  but  soon   as  i pan  down  the view  goes   down   not  in a  tilt  way ,   Unplugged  my joystick tried  using  the  key combination   and  everything  is  ok  so looks like  my joystick might  be  the issue.  Athough  got  no  issues  using the joystick not  using  chase  plane?

Share this post


Link to post
Share on other sites

this is the setup i'm using and it seems to work as expected:

lWK538O.jpg

 

maybe there are differences between how it detects the hat on some controllers or something?

i'm using a logitech 3d pro joystick

good luck

cheers

-andy crosby

Share this post


Link to post
Share on other sites

Could the problem be that you are using it in spot view? (A default FSX view)

 

Does the hat work correctly if you use the Chaseplane interface to switch to an external view instead? (Go to the "Camera" section on the left and use the icons to switch internal/external)

 

I've had similar behaviour when using F11 to get to spot view, the hat only pans left/right but not up/down. TrackIR has always been the same if enabled in spot view: it only pans left/right and not up/down.

Share this post


Link to post
Share on other sites

this is the setup i'm using and it seems to work as expected:

lWK538O.jpg

 

maybe there are differences between how it detects the hat on some controllers or something?

i'm using a logitech 3d pro joystick

good luck

cheers

-andy crosby

Same Joystick here. Tried this setup and still not working. Onboard camera and spot.

Share this post


Link to post
Share on other sites

I can't bind those POV270, POV90 (HAT buttons) etc. to individual views, which was how I used EZDOK. For some reason even after selecting the HAT button it still says Blank when I try to re-edit the preset hotkey.

  • Upvote 1

Share this post


Link to post
Share on other sites

 

 


Same Joystick here. Tried this setup and still not working. Onboard camera and spot.


 

Thx  for that  saves me  purchasing   another  joystick  if  you  still got issues, iam  using  a Microsoft  joystick

Share this post


Link to post
Share on other sites

Thanks for the post Spesimen now my hat is working. Now I just need to set-up the view speed if there a way.

Share this post


Link to post
Share on other sites

You guys have to delete the key binding on the fsx views tab. Delete the assignment that uses the hat switch. And assign it on CP. Hope that helps

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this