Sign in to follow this  
Pete Dowson

How stop P3D from automatically restarting after a crash?

Recommended Posts

I'm moving my main cockpit stuff to a new computer running Win10 (all Win7 before). I'm currently resolving all sorts of new problems this has caused, but one big one which is slowing thi down is that P3D (and FSX too for that matter) automatically restart on an error. I've not had this before. How do I stop it? Can anyone help? (The web reveals only how to stop Windows itself restarting on a crash).

 

The problem iwith automatic restarts is that the logging I'm adding to track the problems down is getting overwritten by the log produced on the next run. I need to get access to things after a crash, and resolve the issues, not run it again immediately without a fix!

 

Pete

 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

That must be related to Win10. Neither P3D nor FSX restart after an error (and never ever have) on my system running Win7.

Share this post


Link to post

That must be related to Win10. Neither P3D nor FSX restart after an error (and never ever have) on my system running Win7.

 

I know. Same here. I assume there's some setting defaulted differently in Win10, but I just can't find it. and the help just isn't. There must be others here running Win10 now?

 

Pete

Share this post


Link to post

Hi Pete,

 

I have been running Win 10 for some months with very few problems.

 

Pressing escape works for me. But I guess it depends on the crash.

 

Mick

Share this post


Link to post

Pressing escape works for me. But I guess it depends on the crash.

 

Pressing ESCape when? It's restarting so fast I don't have time to get to the keyboard from my cockpit!  It comes up with a message box briefly, then starts on the restart. I try to stop it using Task Manager but it's inevitably too late to avoid destroying the evidence / information I need. Of course, the Windows Event Viewer data is still there and useful, but there's other stuff I need.

 

Pete

Share this post


Link to post

Weird, I've had that in msfs since time out of mind, I mean the legitimate in-game crash in red letters: 'CRASH'.

 

Dirk.

 

PS: no OS-related crash restarts though in Win10  (almost 1 full year now)!!

Share this post


Link to post

Weird, I've had that in msfs since time out of mind, I mean the legitimate in-game crash in red letters: 'CRASH'.

 

Oh, I'm not talking about that!

 

PS: no OS-related crash restarts though in Win10  (almost 1 full year now)!!

 

 

No OS crashes. FS or P3D crashes like access violations -- mainly when trying to set things up on a new PC (as I am doing now), and when trying to make my own software work during development.

 

I too never get crashes normally. Just now I'm finding some software with definite Win10 incompatibilities (ObjectDock is one of them, though nothing to do with FS), and a couple of drivers I wrote for my own cockpit.

 

I'm certain there is a way to stop the auto-restarts. I just can't find it and I can find no relevant help on the web.

 

Pete

Share this post


Link to post

Pete ,

 

I wonder if this might help -

 

if you type in the Cortana search box - services.msc

 

select from the list > windows error reporting > right mouse click > select properties

 

the Recovery Tab has a number of options

 

e.g take NO action on first fail or restart

one of these is also run a program.

 

with your expertise this may be useful

 

 

Kevin H

Share this post


Link to post

if you type in the Cortana search box - services.msc

 

select from the list > windows error reporting > right mouse click > select properties

 

the Recovery Tab has a number of options

 

e.g take NO action on first fail or restart

 

Well, that gave me hope, but then the title of those options tells otherwise. it says

 

"Select the computer's response if this service fails"

 

If you check, EVERY service has those same options.

 

Shame FS /P3D isn't a service!

 

Anyway, thanks for the idea.

 

Pete

Share this post


Link to post
Follow these steps to disable the Automatically restart option:

In Windows, search for and open View advanced system settings.

Click Settings in the Startup and Recovery section. ...

Remove the check mark next to Automatically restart under System Failure, then click OK. ...

Restart the computer.

 

See if it helps.

 

Cheers,

Igor.

Share this post


Link to post

How about this option instead

 

I deliberately altered p3d to cause a sim crash and the following stopped auto solution finder/restart of the sim it changes the maintenance option - check for solutions to problem reports from ON to OFF

 

Open Regedit.

Navigate to:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Windows Error Reporting

Find the value named "Disabled"

or

add a new DWORD value with this name if it doesn't exist. I I added it)

The default value of this key is 0. Double click it to edit, change the value to 1 and save.

This disables the automatic appearance of the dialogue where Windows is searching online to try to find a solution.

You are instead shown a dialogue stating that the application has crashed, giving you the option to Debug.

 

However, unlike previous versions of Windows, no error code is provided in this dialogue. The specifics of the error must be accessed through:

Control Panel\All Control Panel Items\Security and Maintenance

 

Under the tab "Maintenance", you can click "View reliability history", which will show a list of all app crashes. You can then click "View technical details" beside each crash to get more detailed information, such as a the error code(s) thrown from the application on crash.)

 

Kevin H

Share this post


Link to post

As suggested above,

 

Enable Win10 GodMode, under System select View Advanced System Settings, (in Advanced tab) Startup and Recovery - click Settings button, under System Failure uncheck "Automatically restart".  Otherwise, some other chunk of code is forcing restart and you'll need to discover.

 

Cheers, Rob.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this