Sign in to follow this  
Tatave

FSX SP2 Language Issue

Recommended Posts

Hi all, 

 

I just uninstalled and reinstalled FSX (following PMDG's guide word for word). Everything works fine until I attempt to install FSX SP2, when a prompt appears saying "FSX SP2 requires the English version of FSX". I have reinstalled the sim numerous times over the past day to no avail. Microsoft was aware of this issue when SP2 came out, and provided a fix which does not work for me. 

 

Is there any known way to get around this issue? If not, is it safe and efficient to run highly complex addons (i.e. PMDG's NGX) on SP1? 

 

Thanks in advance. 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

far as i can remember sp2 is like having the accel pack for fsx you have one or the other so unless some one else chimes in you should be good to go, you could try to install the accel pack to see if it installs

Share this post


Link to post
Share on other sites

I'm actually running FSX Deluxe, therefore I don't have the option of installing Acceleration unfortunately. Thanks!

Share this post


Link to post
Share on other sites

I've re-downloaded SP2 numerous times from Microsoft and the Avsim Library, so I don't think that's it :(

Share this post


Link to post
Share on other sites

I have followed that, and the issue persists. So far, I've updated the registry both manually and using the Flight1 registry fixer, attempted to install in both C:\FSX and the default location, redownloaded SP2 numerous times and reinstalled FSX to no avail. 

 

Extremely frustrating issue this one. 

Share this post


Link to post
Share on other sites

I think he said he was using the Deluxe version without the Acceleration pack (eg. not FSX Gold).

 

Another thing you could try is to download Microsoft's Fix it programs uninstaller and see if that does anything. So instead of uninstalling it with PMDG's method, try this instead.

Share this post


Link to post
Share on other sites

Correct, I'm using FSX Deluxe without Acceleration. Jeff, I will try that out, thank you. :)

Share this post


Link to post
Share on other sites

The issue persists unfortunately. Microsoft Fix It found a problem in the registry and fixed it, however it went back to telling me I needed the English version of FSX. 

 

Any more ideas please? 

 

Your help is much appreciated. 

Share this post


Link to post
Share on other sites

It has been fixed! For future reference for anyone else who runs into this problem: 

 

The solution was to run the MSI as an administrator. Given SP2 is only available as an MSI, some modifications to the registry had to be done. 

 

http://www.sevenforums.com/tutorials/158118-run-administrator-add-msi-file-context-menu.html

 

This link explains how to run an MSI as an administrator. 

 

After following these instructions, I right-clicked the MSI, ran as admin and SP2 installed in a breeze. 

 

Thank you all so much for your help! 

Share this post


Link to post
Share on other sites

Windows security is a strange beast. If we still had XP, there would be no problem, because it didn't have UAC and such.

Share this post


Link to post
Share on other sites

Windows security is a strange beast. If we still had XP, there would be no problem, because it didn't have UAC and such.

No wonder I like XP so much! :dance:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this