Sign in to follow this  
ArjenVdv

VSync 1/2 tweak not working anymore

Recommended Posts

Hello people,

 

Maybe some of you can remember back in 2012, someone recovered a tweak for FSX, that allowed us to get a super smooth sim, without any (micro)stutters whatsoever. You just had to use NVIDIA Inspector, and use the VSync settings "Standard" and "1/2 refresh rate" (for 60 Hz monitors). Then you had to limit your FPS to 30 in FSX. This tweak had always worked perfectly for me until 2014 when I put FSX on the back-burner due to a lack of time. I sometimes touched FSX just for some flying, also installed Windows 10 in the mean time.

 

In the last few months, I kind of started picking up FSX again. I have done a few flights here and there, but didn't really bother with the settings. My fsx.CFG tweaks were still the same, but my NVIDIA Inspector tweaks were gone. I think this was due to a new driver I had installed in the mean time.  So I decided I wanted my NVIDIA Inspector AA settings and VSync settings back. I updated the NVIDIA drivers (fresh install), downloaded the newest version of Inspector, and put all the settings back in. I noticed the layout of Inspector changed a bit, but I just kept the new options there were added to off. 

 

I fired up FSX, put FPS to 30, and noticed my Inspector AA settings were applied, so I knew that was working. I also noticed VSync was doing something, but not what I wanted. The fluid motion was there, but it was only super smooth for a brief moment, instead of the constant fluid motion I was used to. Between these brief smooth moments, FSX would stutter a little for a brief moment. These stutter moments look like FSX is momentarily running at 15 FPS or so. But even though it looked like that, the FPS indicator showed 29.9 - 30.0 FPS all the time. I wondered why VSync only seemed to be working intermittently.

 

I checked my settings, and couldn't find anything wrong. I also deleted my fsx.CFG, and only used basic tweaks such as HIGHMEMFIX, BP=0, TBM=40, AF=14. In the scenarios in which I tested, FPS was always high enough to maintain 30 FPS, so there was no performance problem. It would easily go over 50 in PMDG planes. 

 

I could also remember that the refresh rate settings of the display screens in the cockpit in PMDG planes would influence VSync behaviour, so I made sure I set those to 30 Hz as well in the CDU. I could also remember, I had always been able to run the VSync 1/2 tweak without any FPS limiter whatsoever, as long as I was in PMDG planes. The only setting I needed was the 30 Hz setting inside the CDU for the displays. I think this kind of acted as an FPS limiter. So I tried disabling the FSX internal FPS limiter, like I had it in the past, and that didn't help either. In fact, I now saw FSX was running at 50+ FPS, even though VSync was enabled in Inspector. Yes, I know what you're thinking. VSync 1/2 needs an FPS limiter. Well... in the past VSync 1/2 would keep my FPS running at 30 FPS and make it perfectly smooth without and FPS limiter, as long as I used a PMDG plane and set the refresh rate of the displays to 30. But that doesn't work anymore.

 

Bottom line, the behaviour of VSync in FSX seems to have changed compared to 2014. Whether that is caused by my upgrade to Windows 10, a difference in the newer NVIDIA driver compared to 2014, or a mistake in my settings, I have no idea.

 

Maybe someone knows where I went wrong, and maybe someone got the VSync 1/2 tweak working in 2017, and knows what to do. 

 

 

nvidia%20inspector_zpsrpvc80se.png

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

EDIT:

 

Turns out VSync is not working at all. Tried forcing it off in Inspector. Still had similar results. Turns out the semi-smoothness was simply caused by the internal FPS limiter. It also struck me there is no input lag, so VSync is not being applied. All other Inspector settings are being applied though. Any help?

Share this post


Link to post
Share on other sites

Okay, tried VSync in another game (GTA V), and it works fine. 1/2 refresh rate too. So I can rule out my video card.

 

The problem is exclusive to FSX it seems. But all other NVIDIA Inspector options apply just fine. 

 

I know that VSync doesn't work in FSX in windowed mode, but I'm running fullscreen. Or is there maybe a bug in Windows 10.

I also tried NVIDIA Inspector default profile, with VSync 1/2 only, doesn't work either.

 

Then I tried a driver roll back to 331.65 (end 2013). I can remember VSync worked with these drivers. But rolling back didn't help either.

Share this post


Link to post
Share on other sites

 

 


I also noticed VSync was doing something, but not what I wanted. The fluid motion was there, but it was only super smooth for a brief moment, instead of the constant fluid motion I was used to. Between these brief smooth moments, FSX would stutter a little for a brief moment. These stutter moments look like FSX is momentarily running at 15 FPS or so. But even though it looked like that, the FPS indicator showed 29.9 - 30.0 FPS all the time. I wondered why VSync only seemed to be working intermittently.

 

Remember that vsync only prevents screen tearing. If you have stuttering this is likely to be a separate issue altogether, particularly if you're showing a steady 30 FPS.

Share this post


Link to post
Share on other sites

Remember that vsync only prevents screen tearing. If you have stuttering this is likely to be a separate issue altogether, particularly if you're showing a steady 30 FPS.

If it prevents tearing it will also smooth out the image, because it will render all frames at a steady rate.

 

Microstutters and short hiccups will always be there in any game unless we could run far above our monitors' refresh rate. I am not experiencing real stutters, with which I mean momentary lockups. The motion of FSX just isn't smooth, and it has never been on any system. I know that this is not a system problem, because FSX has run like that over five different systems and on a friends system as well. Strangely, most people perceive that as "smooth". When you turn on VSync, you prevent tearing and smooth out the motion completely as long as you can maintain the proper FPS. If you run standard VSync and cannot maintain 60 FPS then you will not notice the effect. But if you run VSync 1/2 refresh rate and maintain 30 FPS all the time, all motion in FSX will always be 100% fluid. If you get VSync to apply, that is...

Share this post


Link to post
Share on other sites

Anyone? 

I really need someone's help here. The problem seems exclusive to FSX. It works fine in GTA V, when applied internally or via Inspector. I just don't understand why I cannot get vsync to work in FSX only. 

Here's what I tried:

- Default FSX.cfg

- With and without FPS limiter

- Adaptive and standard mode

- Rolling back to drivers of which I am sure it used to work a few years ago

- Clean reinstall of NVIDIA drivers

- Checked if FSX is running as administrator.

 

Did not try a virus scan yet, but that would seem extremely implausible.

Share this post


Link to post
Share on other sites

Have you tried setting vsync through the NVIDIA Control Panel rather than NVIDIA Inspector? Also, there's a newer version of NVIDIA Inspector/Profile Inspector that might be worth a try here: http://www.guru3d.com/files-details/nvidia-inspector-download.html.

I already have the newest version of NVIDIA Inspector (Profile Inspector), and yes, I have tried applying via the regular NVIDIA Control Panel. No luck.

 

I am wondering if there is any setting inside FSX or Windows 10, that could possibly prevent vsync from working? 

 

Bottom line is: VSync works, but not in FSX in any way whatsoever. 

Share this post


Link to post
Share on other sites

But even though it looked like that, the FPS indicator showed 29.9 - 30.0 FPS all the time. I wondered why VSync only seemed to be working intermittently.

Arjen,

looking at your settings, the fact that you see the FPS counter steadily on 30 is related to your use of the FSX internal limiter...it is not necessarily due to the 1/2 Refresh rate. Only if you set FPS inside FSX to unlimited and VSync on NI to 1/2 refresh rate, and you see that, on 60 hz monitor, FSX frames remain stable around 30 fps, it means that VSync 1/2 refresh rate is working. This is the only way to verify it is working correctly. 

Bear in mind that I have never set either the internal FPS limiter or NI limiter to any limit as it had an adverse effect on performance, (however other people say they have a better Sim with a frame limiter enabled.).

My suggestion is I would remove all limiters (FSX and NI) and keep VSync 1/2 refresh rate in NI and see what happens.

Another suggestion is to lower the refresh rate of the PMDG panels to 15....30 has always been an fps killer for me...and remember that 1/2 refresh rate is effective in keeping your Sim smooth only, and only if your Sim can run above or at least 30 FPS, otherwise it will have no effect at all....so if you have something killing the FPS in your sim you will loose the benefits of 1/2 refresh rate even if it is selected ON.

By the way..I have also upgraded the OS to Win 10 and 1/2 refresh rate is still working....

The crazy beahviour of FSX... :smile:......!!

I

Share this post


Link to post
Share on other sites

1/2 refresh rate works perfectly for me. Try setting preferred refreshrate to use the 3d application setting. Your setting might be conflicting with the refresh rate?

Share this post


Link to post
Share on other sites

You have to run FSX internal frame rate limiter at Unlimited for this to work. The only place you limit your frames to 30 is in NI when running 1/2 refresh rate.

 

Beyond that the xperiment deleting your AF setting in the cfg.

  • Upvote 1

Share this post


Link to post
Share on other sites

I have your same problem , in my opinion I can confirm that UNDER WIN 10 Vsync doesn't work!!  I did several test!!!!

Share this post


Link to post
Share on other sites

You have to run FSX internal frame rate limiter at Unlimited for this to work. The only place you limit your frames to 30 is in NI when running 1/2 refresh rate.

 

 

Not true!  I've been using 1/2 refresh rate with frames limited to 30 in FSX for years.

The OP's Inspector shows fsx.exe. in the title bar.  Is that correct?  Does Inspector add the period to the end?  I'm not at my sim computer right now to verify.

Share this post


Link to post
Share on other sites

I have your same problem , in my opinion I can confirm that UNDER WIN 10 Vsync doesn't work!!  I did several test!!!!

 

Not a Windows 10 problem. It must be system specific as vsync (1/2 refresh rate) is working perfectly for me in Windows 10 Pro, 64bit with FSX:SE.

Share this post


Link to post
Share on other sites

Guys I have tried it with and without any FPS limiters!

When I switch to outside views, FPS jumps to 100+, with vsync turned on in Inspector! I have checked in Inspector, control panel, (both global and specific profiles) and everything is set to application controlled. 

 

The funny thing is, it's working in GTA V just fine!

 

Is there any other software or setting inside Windows that could possibly interfere with everything? I have no extra software installed to limit my FPS. 

 

By the way, I always used to run vsync 1/2 without an FPS limiter most of the time. It just depended on the plane I was flying. In PMDG planes it would be smooth, but let's say I pick the Trike (in which frames want to go to 100+), that it would microstutter and I would need to limit the FPS. 

 

And yes, my FPS is more than sufficient to run VSync 1/2. Even at add-on airports 35-60 FPS is what I usually get.

 

Btw, really appreciating all the replies keep them coming, I must be able to solve this... 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this