cannow

Saitek flight yoke

Recommended Posts

Anyone else experiencing issues with Saitek flight yoke has gone crazy since todays update been for ages .pan and tilt is locking on buttons unresponsive . Fine rolling back to none experimental version and my x box controller works fine .

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Same for me...

Even tried to configure the tilt with my keyboard but the result is the same, endless pan

Share this post


Link to post
Share on other sites

Pushed an update (0.1.716) let me know if it fixes the issue

Regards,
Keven

Share this post


Link to post
Share on other sites

Same problem here. I am running 0.1.717 and still have the problem, although it is intermittent. I could not pinpoint exactly what triggers the crazyness. Sometimes it hust hangs, then next time I press the Hat it just goes crazy. Sometimes I can counter balance it by pressing the opposite way, but it does not always work.

It feels like the buttons are working "intermittent". For example, it detects the button for say 5 secondes. If I press and release during that time no problem. If the "button detection" stops while I am pressing, then it feels like I am keeping pressure on the hat while in reality I released the button. Sometimes I press and nothing happens.

I hope this helps you Keven, feel free to come back to me if you need more specifics (hardware, rig etc ...)

Share this post


Link to post
Share on other sites

Yes we have to be patient, even Keven needs to sleep :)

I am very confident the issue will be resolved, we just have to be patient. Remember this is an Alpha Experimental software.

Share this post


Link to post
Share on other sites
Just now, TopGun33 said:

Yes we have to be patient, even Keven needs to sleep :)

I am very confident the issue will be resolved, we just have to be patient. Remember this is an Alpha Experimental software.

Yes of course, no complaints at all!
I'm using chaseplane for a while and actually this is the first issue I encountered which is pretty good for an alpha software :gaul:

Share this post


Link to post
Share on other sites

So to add further information, this also happens with my HOTAS Warthog coolie hat. I reinstalled all the hardware from scratch and it sill does happen.

Share this post


Link to post
Share on other sites

Up till today no problems with the newest update. However today a very slow or no respons on using the Saitek Cessna yoke's buttons and when an action occurs, it's unstoppable. Only presets and mousemovements are working ok.

Share this post


Link to post
Share on other sites

Yep, going to have to agree, something has gone wrong with the yoke hat switch.  Left and right work OK, but forward and back takes you to strange places :laugh:

 

Version 717 used.  Was OK in previous versions

 

Thanks

 

Clive

 

 

Update.....If you delete any doors that you have setup, then everything goes back to normal. So, it's a conflict with the door setup.

 

Hope this helps Keven :blink:

Share this post


Link to post
Share on other sites

Kevin Just retried sorry worse if anything no  doors created here never could get them to work

Share this post


Link to post
Share on other sites

Can I escalate removed experimental build and cant use old build so now dead in the air till a fix hope you can sort something soon 

Share this post


Link to post
Share on other sites

Hi,

Let me know if the issue is still present in the current version (0.1.719)

Regards,
Keven

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now