kevinfirth

Earth Simulations AutoGenesis 6-1

Recommended Posts

Quote

<?xml version="1.0" encoding="UTF-8"?>
<SimBase.Document Type="AddOnXml" version="4,0" id="add-on">
    <AddOn.Name>ES-Vol-6-1</AddOn.Name>
    <AddOn.Description>Scotland 6.1 by Earth Simulations</AddOn.Description>
     <AddOn.Component>
        <Category>Autogen</Category>
        <Path>G:\Autogenesis\P3D\P3D-30cm-Pro-Edition-Install\P3Dv2.2\Autogen</Path>
    </AddOn.Component>
 <AddOn.Component>
        <Category>Effects</Category>
        <Path>G:\Autogenesis\P3D\P3D-30cm-Pro-Edition-Install\P3Dv2.2\Effects</Path>
    </AddOn.Component>
    <AddOn.Component>
        <Category>Texture</Category>
        <Path>G:\Autogenesis\P3D\P3D-30cm-Pro-Edition-Install\P3Dv2.2\Texture</Path>
  <Type>GLOBAL</Type>
    </AddOn.Component>
    <AddOn.Component>
        <Category>Sound</Category>
        <Path>G:\Autogenesis\P3D\P3D-30cm-Pro-Edition-Install\P3Dv2.2\Sound</Path>
    </AddOn.Component>
    <AddOn.Component>
        <Category>SimObjects</Category>
        <Path>G:\Autogenesis\P3D\P3D-30cm-Pro-Edition-Install\P3Dv2.2\Simobjects\Airplanes</Path>
    </AddOn.Component>
 <AddOn.Component>
        <Category>SimObjects</Category>
        <Path>G:\Autogenesis\P3D\P3D-30cm-Pro-Edition-Install\P3Dv2.2\Simobjects\Boats</Path>
    </AddOn.Component>
 <AddOn.Component>
  <Category>Scenery</Category>
  <Path>G:\Autogenesis\P3D\P3D-30cm-Pro-Edition-Install\Earth Simulations\ES-Vol-6-1\ES-6-1-Terrain</Path>
  <Name>ES-6-1-Terrain</Name>
  <Layer>700</Layer>
 </AddOn.Component>
 <AddOn.Component>
  <Category>Scenery</Category>
  <Path>G:\Autogenesis\P3D\P3D-30cm-Pro-Edition-Install\Earth Simulations\ES-Vol-6-1\ES-6-1-Vectors</Path>
  <Name>ES-6-1-Vectors</Name>
  <Layer>701</Layer>
 </AddOn.Component>
 <AddOn.Component>
  <Category>Scenery</Category>
  <Path>G:\Autogenesis\P3D\P3D-30cm-Pro-Edition-Install\Earth Simulations\ES-Vol-6-1\ES-6-1-TFX</Path>
  <Name>ES-6-1-TFX</Name>
  <Layer>702</Layer>
 </AddOn.Component>
 <AddOn.Component>
  <Category>Scenery</Category>
  <Path>G:\Autogenesis\P3D\P3D-30cm-Pro-Edition-Install\Earth Simulations\ES-Vol-6-1\ES-6-1-Photo</Path>
  <Name>ES-6-1-Photo</Name>
  <Layer>703</Layer>
 </AddOn.Component>
 <AddOn.Component>
  <Category>Scenery</Category>
  <Path>G:\Autogenesis\P3D\P3D-30cm-Pro-Edition-Install\Earth Simulations\ES-Vol-6-1\ES-6-1-3D</Path>
  <Name>ES-6-1-3D</Name>
  <Layer>704</Layer>
 </AddOn.Component>
 <AddOn.Component>
  <Category>Scenery</Category>
  <Path>G:\Autogenesis\P3D\P3D-30cm-Pro-Edition-Install\Earth Simulations\ES-Vol-6-1\ES-6-1-Airports</Path>
  <Name>ES-6-1-Airports</Name>
  <Layer>705</Layer>
 </AddOn.Component>
 <AddOn.Component>
  <Category>Scenery</Category>
  <Path>G:\Autogenesis\P3D\P3D-30cm-Pro-Edition-Install\Earth Simulations\ES-3D</Path>
  <Name>ES-3D</Name>
  <Layer>706</Layer>
 </AddOn.Component>
 <AddOn.Component>
  <Category>Scenery</Category>
  <Path>G:\Autogenesis\P3D\P3D-30cm-Pro-Edition-Install\Earth Simulations\ES-SFX</Path>
  <Name>ES-SFX</Name>
  <Layer>707</Layer>
 </AddOn.Component>
</SimBase.Document>

Here's the xml for adding on vol6-1 in P3D4.  Just change the paths to your install locations.....

Rather presciently, ES distributed their backups neatly in the required folders, so all you have to do is unzip your ESI-packs (if you made them) and structure the add-on.xml accordingly.  Easy-peasy!

Cheers K

 

EDIT: ensure scenery components have a layer number (doesn't have to be consecutive) and a name.  I kept getting content error messages saying the 'TITLE' attribute was required...what it meant was it needed the <Name>...</Name> entry!  Nice to know LM is continuing the MS tradition of an opaque SDK :p

 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Good work Kevin, also make sure that the name is unique as a duplicate name will overwrite the previous entry!!..

Jorge

Share this post


Link to post

Are the other ES scenery packages working in P3D v4, Kevin?

Share this post


Link to post

I, too, have all the ES Sceneries, some as ESI packs and others not - ie disk images, so I will also be interested in following this thread.  At 73, I am finding the SDK somewhat less clear than "opaque". Regards.

Maurice.

Share this post


Link to post

Hello Kevin

I notice there is a link to the ES autogen folder that would normally be in P3d root.

How does this fair with the autogen description files?

Does the autogen merge with other autogen descriptions and work as one?

I have been using Arno’s autogen configuration merger from FSdeveloper with V3 and have tried his V4 version which is in beta although it does not convert the Legacy files at the moment, which seems to be causing problems for me.

Also is the only way to add the scenery manually? As that would involve a lot of typing to create an XML file.

Thanks

Share this post


Link to post

For treescapes, I just copy the texture folder to the appropriate photoscenery folder, works fine. I've only got experience with treescapes, though.

No sign of a return from Darren and Vicki? It was a rather sudden departure.

Share this post


Link to post

I would love to hear from Darren and Vicki. I miss them :sad:

Share this post


Link to post
3 hours ago, Christopher Low said:

Are the other ES scenery packages working in P3D v4, Kevin?

unclear at present I have not tested.   am proceeding v slowly

watch this space....

Share this post


Link to post
1 hour ago, dabba said:

Does the autogen merge with other autogen descriptions and work as one?

That premise is the reason for this test.  I discussed it with Arno this morning regarding whether ACM is necessary under v4.  Right now I can say the xml returns no content errors.  Need to load the scenery for a flight as a full test but didnt have time before work this morning.

Share this post


Link to post
1 hour ago, dabba said:

Also is the only way to add the scenery manually? As that would involve a lot of typing to create an XML file.

Cut and paste works wonders. This xml file took less time to put together than addind all the entries to scenery.cfg and copying files to folders...  

Share this post


Link to post
1 hour ago, OzWhitey said:

 

For treescapes, I just copy the texture folder to the appropriate photoscenery folder, works fine. I've only got experience with treescapes, though.

No sign of a return from Darren and Vicki? It was a rather sudden departure.

 

Treescapes are different thats just agn files which dont need to be referenced in an add-on.cfg

 

No chance of a Darren and Vikki reprise sorry.... 

Share this post


Link to post

They quit at the wrong time. They had some good tech there, that was thwarted by bad marketing and a horrible distribution platform. But the idea for what they were doing was great, and we've now got the sim and graphics cards to do justice to high-density 'autogen'. TReescapes used to be impossible to run with sliders to the right, now its a piece of cake.

Kevin, you seem linked in with this. Why no chance of a Darren/Vicki reprise? They could even just pop in to a thread like this and see how much their work was appreciated, I got the impression they felt undervalued near the end. If they want to come and join us here, I will make the tea and we can sit arouind and chat about photoscenery. :happy:

Share this post


Link to post

Hello Kevin!

I suppose we can do the same with Earth Simulations, Isle of Man?

 

Share this post


Link to post

HI Kevin

I have had a quick play with both the XML method & Arno’s Autogen Merger.

Tested on ES , Orbx Airfields, Sim720 Airfields

The Autogen merger appears to work although does not as yet merge the Legacy file which may or may not be the problem I have at the moment which is the Dynamic 3d autogen vegetation needs to be ticked, and at the moment I am getting CTD at different places within ES areas when the trees are active. No issue as yet with the buildings, only the trees (if I untick Dynamic 3d autogen vegetation only the buildings show) and no issue.  Orbx & Sim720 appear OK.

I have also tried the XLM method with the same issues above plus random areas within Orbx airfields have no autogen.

AS an odd ball chance I have tried to change the ES AutogenDescriptions to AutogenDescriptions_Legacy  with still the same issues above.

I assume something about the trees does not like the new Dynamic 3d autogen vegetation, or requires a conversion.

Regards

Share this post


Link to post
56 minutes ago, OzWhitey said:

Kevin, you seem linked in with this. Why no chance of a Darren/Vicki reprise? They could even just pop in to a thread like this and see how much their work was appreciated, I got the impression they felt undervalued near the end. If they want to come and join us here, I will make the tea and we can sit arouind and chat about photoscenery. :happy:

Please just accept it's not going to happen.  I am aware of more than I'm willing to post publicly.  I was a huge fan of their work and I feel their loss tremendously, but I am not going to plaster anyone's personal business all over the internet, sorry.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now