markosslegend

Engine Sounds

Recommended Posts

Hi all,

I tried really hard not to post here but I cannot find a fix for my issue.  As many other people have had, I cannot hear the engine sounds (over what sounds like a generic monotone engine sound) of both the 737 NGX and 777 aircraft and the sound only slightly adjusts for each different view.  I cannot hear the engines spool up when starting, cannot hear a definite difference at takeoff, cannot hear reverse thrusts and cruising leaves a lot to be desired .  I have tried every fix that I could find; updating sound drivers, checking that the speakers are set to stereo and working with no issue and checking that the sound settings in the FMC are correct.

I am still running P3D v3.4 and have just started using the sim again after a few month break.  It seems like it should be a simple fix but I can't put my finger on it.

Any help would be great and thanks in advance.

Mark Osborne

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Mark, as annoying as the problem is, you have provided too little information.  For a start, it might help by adding whether you have an on-board sound card/dedicated sound card (which one), system specs, whether the issue is PMDG specific or a general sound issue with all aircraft.  Have you checked that all the sounds files have correctly loaded onto your aircraft sound folder.

Share this post


Link to post
Share on other sites

Thanks Erich for your reply,

Realtek High Definition Audio sound card.

Intel i7-6700 overclocked to 4.7GHz, Asus Z170 MB, 32 GB RAM, EVGA GTX 980Ti

The only add-on aircraft I have are PMDG 737, 747 and 777.  The problem only appears to be those aircraft, when I fly a default model I can hear definite engine sounds and appropriate type and volume changes when cycling through the different views.

As for the sound files loading correctly, I have no idea, how would I check that.  I installed as per the instruction in setup.  The only thing I changed (as advised) was selecting the C drive as installation destination instead of Program Files.

Thanks again,

Mark Osborne

Share this post


Link to post
Share on other sites

I acknowledged you said you verified you had check to make sure settings were stereo, but if a setting happens to be 5.1 instead of stereo this is one of the things that can happen.  A double check of windows sound settings, P3D sound settings and PMDG sound settings is one recommendation.

Another issue not yet addressed is how the engines actually sound in the cockpit.  In the B777 especially, there is not as much engine sound as you expect.  What about exterior sounds?  If they are okay then you probably are hearing correct sounds in the cockpit.  This is one reason addon sound packages are popular, they are for people that don't want realism but prefer "theatrical realism."

Share this post


Link to post
Share on other sites
27 minutes ago, markosslegend said:

 

Realtek High Definition Audio sound card.

 

Mark, that may be your problem, right there.  It may be worth investing a few bucks in something like an Asus Xonar DG soundcard.  The onboard Realtek sound cards are not the best.

 

Just my opinion,  but historically I have always had issues with onboard soundcards.

Share this post


Link to post
Share on other sites
1 hour ago, markosslegend said:

cruising leaves a lot to be desired . 

You won't really hear much engine here to be fair.  It's mostly air noise.

Share this post


Link to post
Share on other sites

Thanks for your replies,

Dan, yep have done a check of windows, realtek and P3D and all sounds are in stereo.  The 777 sounds the same inside and outside of the cockpit with very little engine sound whether at idle or full throttle.  No matter which view I use - inside or outside - it sounds like a generic fan running with very little difference in the type, quality or volume of the sound.  I was happy with the default sounds.

Erich, you may be right.  I've heard from others as well that Asus don't have the best sound cards.  However, I don't have a problem with any other program or game.  I agree with you about cruising, but again there is very little difference between inside and outside aircraft noises, and there is no difference between cruising sound and taxi/take-out sound.

Once again thanks for your help, I can't help to think there is a really simple fix.  If the audio files did not install properly.  Do you think it would be worth re-installing the PMDG aircraft from scratch.

 

Mark Osborne

  • Upvote 1

Share this post


Link to post
Share on other sites
3 hours ago, markosslegend said:

Once again thanks for your help, I can't help to think there is a really simple fix.  If the audio files did not install properly.  Do you think it would be worth re-installing the PMDG aircraft from scratch.

Not sure, maybe try repair. The sounds outside should definitely be different, louder and vary with position.  I have a Realtek sound chip too, but it's on a ASRock mobo... left asus behind a couple of builds ago.  I ended up adding a SoundBlaster card to my asus board, they are very very cheap.

Share this post


Link to post
Share on other sites

So I've done a complete uninstall and reinstall of all three PMDG aircraft with no difference to the sounds.  I've double and triple checked that all my audio streams are in stereo and my sound card drivers are up to date.  I would really rather not buy a new sound card, by the sounds of it loads of people are using the default mobo sound cards with no issues.  There is definitely only minimal sound change when switching through views and I can't hear the engine sounds on take off.  Just sounds like one very generic loud fan, something that you would associate with FS 2000.

This is whats written in the P3D config file:

[SOUND]
PrimaryPlaybackDevice={DEF00000-9C6D-47ED-AAF1-4DDA8F2B5C03}
VoicePlaybackDevice={DEF00002-9C6D-47ED-AAF1-4DDA8F2B5C03}
VoiceCaptureDevice={DEF00003-9C6D-47ED-AAF1-4DDA8F2B5C03}
SOUND=1
SOUND_QUALITY=2
SOUND_LOD=0
SOUND_FADER1=0.600000
SOUND_FADER2=0.500000
SOUND_FADER3=0.500000
SOUND_FADER4=0.500000

Does this look correct to everyone?  I'm not sure how to decipher the config file.

Thanks again

Mark Osborne

Share this post


Link to post
Share on other sites
13 minutes ago, markosslegend said:

Does this look correct to everyone?

The interface IDs don't mean anything to me other than "they're the same for each." Keep in mind that, even though you've assigned one, it doesn't mean the correct one has been assigned. I'd try to assign different devices if you can. I'd also check the settings in the device's properties to ensure that it isn't set to something you don't have (5.1 Surround when you're only using 2 speakers, as an example).

15 minutes ago, markosslegend said:

So I've done a complete uninstall and reinstall of all three PMDG aircraft with no difference to the sounds.

As I always point out: uninstalls/reinstalls are largely pointless. Avoid them unless instructed to do so.

Share this post


Link to post
Share on other sites

Thanks Kyle,

Yep only really did the reinstall due to the recent upgrade of the 777 and 747 that required it.  I have triple checked that the audio devices are only in stereo.

I currently use P3D with Oculus and Flyinside.  While I was adjusting the sound settings, I noticed when I click outside the P3D window on the desktop I can hear the engine sounds fine but no cockpit noises.  When I click back into the P3D window this horrible generic "fan" type noises starts up which muffles the sound of the engines but then allows me to hear the cockpit noises.  When I adjust all the P3D sounds to zero, I can still hear this annoying "fan" noise.

Am I missing a setting in P3D?

Thanks

Mark Osborne

Share this post


Link to post
Share on other sites
13 minutes ago, markosslegend said:

When I adjust all the P3D sounds to zero, I can still hear this annoying "fan" noise.

Am I missing a setting in P3D?

Sounds more like a mis-configured sound device, honestly. The sound settings for P3D are shown in the Intro Manual, which I don't have in front of me, and don't want to give you contrary advice.

Something is routing the vast majority of the sound away from your speakers while the sim is in focus. This usually points to hardware mis-configuration.

Share this post


Link to post
Share on other sites

Hi Guys,

So I think half my issue is sorted.  In the PMDG FMC sounds options I set both ambience and environment levels to 10 which made the engine sounds much clearer and easier to hear.  However the engine volume is still quite low even though in the P3D sounds options the engine volume is set to max.  A problem that I'm getting around by simply turning my speakers up.  Interestingly enough, when I alter the master volume in the PMDG FMC sound options, it has no effect on engine volume but effects all other volumes.  Also too, when switching the sound to my headphones only, the engine sounds are only played through the speakers and not the headphones, while everything else comes through the headphones as normal.  Very weird!

Anyway thanks to everyone that commented.  I've got it to a point where I'm happy how the sounds are and can happily use the sim.

Thanks again

Mark Osborne

 

Share this post


Link to post
Share on other sites
11 hours ago, markosslegend said:

Also too, when switching the sound to my headphones only, the engine sounds are only played through the speakers and not the headphones, while everything else comes through the headphones as normal.  Very weird!

Not weird. I've consistently said that this is a hardware configuration issue, but you've spent this whole time messing with the software settings. It's your own prerogative to do as you please, but...again: your hardware is not properly configured on your machine, so the fact that it is behaving oddly is not at all surprising to me.

If this is acceptable to you, fine, but it's definitely a hardware config issue as I've said. If you'd spent as much time going down the avenue I'd pointed you down earlier, you'd probably have it resolved in a more predictable way.

Share this post


Link to post
Share on other sites

Hi Kyle,

I did spend loads of time with the hardware configuration.  I've updated the sound card driver, made sure the speakers were configured to stereo, tried different output jacks, uninstalled and reinstalled the audio driver.  I did all of this before I posted because that's what searching for previous sound issues threads told me to do.  It made no difference to the sound.  I don't know what else to do.  That's why I'm on here posting.  I'm not great with computers and can't find a sound troubleshooting guide other than whats in previous posts I've already searched for.  Obviously I've done something wrong, but I can't find the issue.  I appreciate the help, but I don't know how to configure my sound device other than whats already been stated and what I've already done.

Mark Osborne

Share this post


Link to post
Share on other sites

Check you bios and verify the on board sound device is enabled.  Check the windows device manager and make sure you don't have other sound devices, such as HD Audio from a video card.

Share this post


Link to post
Share on other sites

Hi Dan,

On board sound is enabled in the BIOS.

In the device manager I have two sound options

1: Audio inputs and outputs

2: Sound, video and game controllers

In both sections all the sound options are enabled, working and drivers have been updated.

Share this post


Link to post
Share on other sites

Stumbled across this thread by luck.

I've actually noticed a sound issue with my setup. I completed a flight in both the 737 and the 777 (different occasions) and I kept on losing the engine sounds. When I changed views, I wouldn't get the expected change of sounds (switching to external view, I would think I'm locked away in the baggage bay). I found that turning the sound off/on (pressing Q) solved the issue, but only for a short time.

Half thinking it's a memory issue? But that's a completely uneducated guess. I can list my specs if need be.

 

 

Share this post


Link to post
Share on other sites
23 hours ago, markosslegend said:

In both sections all the sound options are enabled, working and drivers have been updated.

In the Device Manager, under the Sound, video and game controllers item:  You should see an item for the RealTek High Definition Audio or whatever sound chip you have.... that is good; however, if you see other sound devices then disable them.  I didn't intend to send you into the drive settings, only the device manager. Sorry.

Sometimes Nvidia installs a HD Audio device intended to be use when you hook up something to the card that needs both video and audio signal.  It can be a problem to have two sound devices active, not always but possible.

  • Upvote 1

Share this post


Link to post
Share on other sites

Hi Mark!

I've had this issue as well. The grinding sound could be the compass in some of the default aircrafts like the Carenado A-36. When I switched into other aircrafts - beeing it a PMDG one or for example the F-22 - this grinding noise kept on annoying me. I tried to set up a new default scenario in an aircraft not containing this old compass. It didn't work. Solution was to delete my saved scenario to force P3D to load the "real default flight". The one with the F-22 at Eglin Airbase. This solved the problem for me. Looks like a P3D bug as it effects both, PMDG and P3D included aircraft.

Greetings,

Share this post


Link to post
Share on other sites

Hi Lufthasnsi,

After spending some more time on the issue over the past day I have found that my issue was mainly caused by me running P3D with FlyInside to use Oculus Rift.  After taking Dan's advice and disabling the other sound sources in the device manager, when opening P3D normally (without FlyInisde) the sound was perfect.  However when I opened P3D with FlyInisde the sound reverted back to my issue.  Turns out there is a box to uncheck in the FlyInisde options that is separate to the P3D options menu.  FlyInisde automatically defaults the sound to headphones, unchecking this box allows me to properly divert the sound through my speakers.  The sound is now perfect and very usable.  The only issue I have left (and I can definitely live with it so its not really an issue) is when I click out of the P3D/FlyInisde window, all sounds are muted except for the engine sounds which are still audible.  Apparently FlyInside will not work when the "Mute on lost focus" box is checked in the P3D sound settings.  It did not occur to me that FlyInside would alter the sound, I just assumed it was purely graphics - how wrong I was.

Anyway thanks all for the help.  Happy siming

Mark Osborne

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now